Reply

Armor paid subscription - unable to activate on RBR50 router

konabob
Tutor

Armor paid subscription - unable to activate on RBR50 router

I purchased Netgear Armor security after about two weeks of trialing the product. When I login to the RBR50 router from my PC it says "Security Status Not Activated". When I login to the Orbi App from my ipad it says "Security Expired". Using the ipad app when I tap the Security tile it brings up a screen saying it is checking the status of my account, and then goes to a screen to renew my subscription. When I login and enter my activation code, it says the activation code was already used. I have no way to activate the $70 security subscription on my router. I made this purchase intending to upgrade a trial subscription to a full year paid subscription on my router. The Orbi ipad app shows no blocked threats since my trial subscription expire one week ago. The router firmware is V2.3.5.30.

The Netgear Armor subscription purchase is active on my Windows PC's and android phone, it is not active on my router, which was the main intent of the purchase.

Any suggestions on how to activate my paid subscription on the RBR50 router?

Thanks.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 13
Holybird
Aspirant

Re: Armor paid subscription - unable to activate on RBR50 router

I'm having the exact same issue. I've reinstalled the phone app but the issue remains. The web portal states, "Not activated", the app states, "expired" but the Armor site shows my license is valid.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 2 of 13
schumaku
Guru

Re: Armor paid subscription - unable to activate on RBR50 router

Get in touch with both Netgear and Bitdefender Support - nothing the community can do here.

Message 3 of 13
DexterJB
NETGEAR Moderator

Re: Armor paid subscription - unable to activate on RBR50 router

Hi @konabob and @Holybird, if you haven't reached out to Bitdefender yet, I'd recommend doing so using their support channels on the link below since other users have reported that they were able to get it sorted out for them. If you have, please send me a private message with the serial number of your device and the email address used for the subscription.

 

https://www.bitdefender.com/consumer/support/

 

Dexter

Message 4 of 13
konabob
Tutor

Re: Armor paid subscription - unable to activate on RBR50 router

Just sent you a PM Dexter. I have not heard back from Bitdefender yet. Thanks in advance for your assistance. Bob.

Message 5 of 13
Holybird
Aspirant

Re: Armor paid subscription - unable to activate on RBR50 router

Bitdefender got back to me and did something on their side. I was able to restart the trial which immediately switched over to my subscription.  Bear in mind this was after a full factory reset at the latest firmware. Both my orbi app and web portal are reporting an active subscription now.

Message 6 of 13
konabob
Tutor

Re: Armor paid subscription - unable to activate on RBR50 router

My Netgear Armor subscription has been activated. I received this email from Bitdefender support after Dexter got involved after seeing my post in this forum. Thank you Dexter and Alina from Bitdefender.

 

Dear Bob,

Thank you for your patience and please accept our apologies for the delay in our reply.

Please note that we have made some adjustments on your account and you should now be able to see your active Netgear Armor subscription.

Let me know if everything is OK. Have a lovely day!


Best regards,
Alina Bizga
Bitdefender Support Team

Message 7 of 13
gagarzac
Aspirant

Re: Armor paid subscription - unable to activate on RBR50 router

Hello Dexter & Alina:

 

I would like to get some help, I've started the trial period on my R8000 router and had to factory reset it, now I can't activate the netgear armor, sent a ticket to bitdefender and so far I got a response stating that i had to re-reset it, and I did.

But the problem still is there, the Nighthawk app on the iphone as well as via the routerlogin.net page says that "An error has occured", Sent the screenshots of both ways to bitdefender about 15 days ago and I'm not getting a response so far, I guess they just dropped on me.

 

Any help?

Message 8 of 13
konabob
Tutor

Re: Armor paid subscription - unable to activate on RBR50 router

Hello gagarzac, I recommend you send DexterJB (a moderator on the forum) a private message. Include the serial number of your router and your help ticket number with Bitdefender, along with the description of the issue

 

https://community.netgear.com/t5/user/viewprofilepage/user-id/266983

 

Good luck. Bob.

Message 9 of 13
js_home
Aspirant

Re: Armor paid subscription - unable to activate on RBR50 router

Hi Dexter,

 

I came across this conversation when trying to search the web for a solution to the issue that I'm facing with activating my ARMOR paid subscription on my router that appears to be exactly the same as the other users described in this thread. Being a multi-year Bitdefender user, I recently purchased the NETGEAR Orbi set and soon came to the conclusion that I would pull the trigger on buying the ARMOR subscription (this happened on October 13). Upon activation, I began using the service on all of my connected devices including the RBR50 router where it for some reason showed I was still using the 30 day trial that came with the router (the other devices immediately switched to the paid subscription). Believing this would happen to the router as soon as the trial period is over (Nov 12), I paid to attention to this until now when, upon checking, the router says the service has expired and I am not able to activate it again with the subscription I have already purchased a month ago. Hope you can help me resolve this issue just like you did to the other members of the community.

 

Many thanks,


Jan 

 

Message 10 of 13
hjk_plm
NETGEAR Expert

Re: Armor paid subscription - unable to activate on RBR50 router

Hello Jan,

 

After puchasing, did you recieve the activation code from NETGEAR Armor with the activation code? Following is the instruction to activate the Armor subscription. https://kb.netgear.com/000060247/How-do-I-activate-my-NETGEAR-Armor-subscription-using-an-activation...

 

If you already taken above steps to activate, could you please check if your login email used in armor.netgear.com portal and your Orbi app login email matches? 

 

Also I recommend filing a support request with the Bitdefender. 

 

Thanks,

Haejo

Message 11 of 13
js_home
Aspirant

Re: Armor paid subscription - unable to activate on RBR50 router

Hello Haejo,

 

Thanks for your reply. Upon purchase I obviously did receive the activation code and used it according to the given instructions. Actually, I have been running Bitdefender security software through the ARMOR subscription since the day of purchase/activation on all of my devices but the RBR50 router that for some reason kept the 30-day trial that came with the unit, until it expired yesterday. My login credentials are the same for both the Orbi app and the Netgear Armor portal, so this also cannot be the reason for the issue. I guess that I'm facing the exact same problem that the other members posted in this thread earlier, that were eventually able to resolve it through the Netgear support staff (I already sent a private message to the person who was mentioned to help fix that for the others). But thanks anyway, it's appreciated!

 

Best,

 

Jan

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 12 of 13
Orbi-Roc
Luminary

Re: Armor paid subscription - unable to activate on RBR50 router

Hi @js_home .

 

I had the exact same issue. Here's what I did to resolve it. I went to Bitdefender Support and opened a chat session, in which I explained briefly the problem I was experiencing. The rep told me that the case would be escalated to the next level and would be hearing from them shortly. I then received an email with a case number. I then sent a private message to @DexterJB explaining the problem and gave him both the case number I got from Bitdefender Support and my router's serial number. Within two business days, the problem was solved. Good luck!

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 13 of 13
Top Contributors
Discussion stats
  • 12 replies
  • 4964 views
  • 2 kudos
  • 8 in conversation
Announcements

Orbi WiFi 6E