Orbi WiFi 7 RBE973
Reply

Re: Armor slows internet speed drastically

erock82
Guide

Armor slows internet speed drastically

HI,

I just installed the Netgear Armor on my RBK50 router. I noticed the internet seemed to slow a lot. I ran on speed test on a few connected devices and got ~10Mbps consistently. I have a 150 Mbps connection with my internet provider, that was always reliable before I install Netgear Armor. The strange thing is if I use the speed test in the orbi app I get 150 Mbps, but using the same device right after running the speed test via google I get 10 Mbps. This leads me to believe that Netgear Armor is doing something to my internet speed. Anybody else running into this issue?

Also, equally frustrating is there appears to be no support for this software via Bitdefender or Netgear. So, I have no tech support for this even though I am paying a yearly fee to use this product......

 

 

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 1 of 24
Orbi-Roc
Luminary

Re: Armor slows internet speed drastically

Hi @erock82 . No change in speed at my end. Performance impact was also on my mind prior to activating Armor. Perhaps others will chime in and give us their feedback. One thing I would suggest is to de-activate Armor and run the same apps speed tests; and immediately reactivate Armor and run the same speed tests again. 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 2 of 24
Orbi-Roc
Luminary

Re: Armor slows internet speed drastically

Hi again @erock82 . I just ran another test, this playing a YouTube 4K video. While the video is running, you can click on stats for nerds and get the actual speed of your connection; and I see no deterioration whatsoever. How many devices do you have connected to your Orbi at the same time while running the tests you ran?

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 3 of 24
erock82
Guide

Re: Armor slows internet speed drastically

Hi @Orbi-Roc.  Thanks for the advince.  I tried the youtube test and got ~60 Mbps, still ~90 less than what I'm paying for.  I ran the google speed test too and got ~40 Mbps.  I did notice sometimes I can get the up 50 Mbps with armor.  But it's usually ~10Mbps.  I'll try deactiving armor and see if I get the 150 Mbps.  The weird thing is that the speed test in the Orbi App will always show 150 Mbps.  I'll run other speed test before and after with the 10 Mbps results.  

 

It also seems like I'm getting more lag on my devices too since installing armor...

Message 4 of 24
Orbi-Roc
Luminary

Re: Armor slows internet speed drastically

That's interesting. At my end, Ookla, Orbi app and YouTube, are all report the same, give or take. As for devices, installing Bitdefender Total Security on individual devices will definitely have some performance impact. I've installed Total Security on two Windows computers, a laptop and a desktop, due to the increased vulnerability of Win devices. But I do not intend to install Total Security on Mac OS and iOS devices. Good luck with your next tests!

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 5 of 24
DexterJB
NETGEAR Moderator

Re: Armor slows internet speed drastically

Hi @erock82, are you still experiencing the issue?

 

Dexter

Message 6 of 24
erock82
Guide

Re: Armor slows internet speed drastically

Hi @DexterJB

Yes, I am still having the extremely slow internet speeds.  Been a busy couple of days hopefully I'll get to deactivating armor tonight and see if that is the problem.  Not sure how it isn't that this point...

Message 7 of 24
DexterJB
NETGEAR Moderator

Re: Armor slows internet speed drastically

Thanks for responding. Please keep us posted for us to provide a recommendation.

 

Dexter

Message 8 of 24
erock82
Guide

Re: Armor slows internet speed drastically

Hi @DexterJB,

 

I disabled armor but still the same issue.  Maybe the firmware update caused the slow down?  Or maybe armor is still running in the background?  The interface isn't the best and I don't trust that armor has actually been disabled.  

Message 9 of 24
DexterJB
NETGEAR Moderator

Re: Armor slows internet speed drastically

Thanks for the update. As a way to isolate the issue, please try resetting the router back to factory defaults and check if the issue will persist. You can back up the router settings in case you'd want to restore it. However, it is recommended to reconfigure everything instead as a way to avoid any lingering issues to be carried over.

 

Dexter

Message 10 of 24
DexterJB
NETGEAR Moderator

Re: Armor slows internet speed drastically

Hi @erock82, were you able to get this sorted out?

 

Dexter

Message 11 of 24
erock82
Guide

Re: Armor slows internet speed drastically

Upgrading to firmware V2.3.1.60 seems to have help.  I'll keep an eye on it. 

Message 12 of 24
Orbi-Roc
Luminary

Re: Armor slows internet speed drastically

Hi @erock82 

 

Disabling Daisy-Chain Topology made a big difference for me.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 13 of 24
gerimaster
Tutor

Re: Armor slows internet speed drastically

Yes is true Armor slowing down download and upload speed. Not speed tests like Ookla. Real world usage with file download or upload to FTP or WEB very slow.

 

With Armor on 500Mbit internet line :

Speedtest.net 450-480 Mbit ???? (Maybe Armor not inspecting speedtest urls?)

File download from FTP: 20-70Mbit

File download from WEB: 30-80Mbit

 

 

Without Armor :

Speedtest.net 450-480Mbit

File download from FTP: 250 -350Mbit

File download from WEB: 300-450Mbit

 

 

We have more servers, all have 1Gbit internet connection.

I disabled Armor. The most routers with packet inspection for 500Mbit -1Gbit running on 10-40 core processors, not on ARM 4 core (800mhz) technology from 2014. This router is not powerful enough for packet inspections. Armor on home routers is only a Joke. 

 

 

Message 14 of 24
texjones
Guide

Re: Armor slows internet speed drastically

I installed Armor on the router and then bit defender on my devices . Heavy Wifi impact impact on devices particularly W10 Laptops. Today uninstalled bit defender on all my devices ( PCs and android phones) and the speed dramtically increased ( 3 X ) . Also bit defender kept on telling me my subscription had expired on android phones when I bought for a year. The armor site is also horrible on firefox but OK on Chrome. All in all won't be renewing this piece of software . Now thinking about taking it off the Router as well

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 15 of 24
DexterJB
NETGEAR Moderator

Re: Armor slows internet speed drastically

Hi @texjones, welcome to the community! We'd recommend checking with the Bitdefender support team on this for them to drill down on the issue. You can reach them on their support channels on the link below.

 

https://www.bitdefender.com/consumer/support/

 

Dexter

Message 16 of 24
texjones
Guide

Re: Armor slows internet speed drastically

Thank you Dexter. I have reached out as you recommended. And I have now gained a ticket # with their support.

Message 17 of 24
PeteKol
Initiate

Re: Armor slows internet speed drastically

Wifi slows to a crawl for me as well. Armor enabled, slow wifi and ethernet. Armor disabled, wifi and ethernet fast. Tried again hours later. Armor enabled, slow wifi and ethernet. Armor disabled, wifi and ethernet fast again. Using 2.3.5.26 firmware.

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 18 of 24
texjones
Guide

Re: Armor slows internet speed drastically

Received ticket number on 6th September from Bit defender support . No response as of today September 17th.

 

Since I removed bit defender from all my devices the internet speeds are dramatically faster.

 

However since I paid for Armor / Bit defender I would appreciate a response as to what was causing the product to cause the derioration in Internet speed

 

I am happt to try reinstalling but not until tech support provides advice

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 19 of 24
twick19
Aspirant

Re: Armor slows internet speed drastically

I upgraded firmware and I have not enabled Armor but my internet speeds are now running less than 10 Mbps.  Before I was running at 170 Mbps and above.  Another case of an upgrade killing the product.

Model: R7000|AC1900 Smart WIFI Router
Message 20 of 24
DexterJB
NETGEAR Moderator

Re: Armor slows internet speed drastically

Hi @twick19, we recommend doing a factory reset after the firmware update if you haven't done so yet. Let us know how that goes.

 

Dexter

Message 21 of 24
PeteKol
Initiate

Re: Armor slows internet speed drastically

I did a factory reset but waited to ensure everything was working ok. I had already purchased a year of Armor, so decided to re-activate it. I went to the Orbi app to do so but got an error. I tapped on Activate Trial. I get a screen saying Activating ... wait while we activate Netgear Armor on your rourter - after about 10 seconds I get a pop up "Error. Failed to subscribe" tapped try again. Same error.

 

After having so many problems - i first encountered the bug that the router resets after a restart, then fixed that, then experienced slowness issues and I did a factory reset, now can't activate Armor again after a reset, even though I paid for it, I feel this is an inferior product. With so many other wifi options, unless this can be resolved with little to no effort on my part, it's time for me to move on.

 

 

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 22 of 24
Orbi-Roc
Luminary

Re: Armor slows internet speed drastically

Hi @PeteKol . I had a similar issue and it got resolved with very little effort within two business days. First, go to Bitdefender Support and open a chat session to briefly explain the difficulty you're having to activate a paid subscription. I assume that your attempting the activation via your mobile device, correct? If affirmative, the chat rep will open up a support ticket and escalate your case to the next level. Once you have your support case number, drop a private message to @DexterJB giving the same brief explanation on the issue, the BD ticket number and your Orbi router serial number. Two business days, you'll be up and running. BD has been having hiccups with activation since the get go; and frankly, it baffles the brain as to why they haven't been able to fix this yet. Armor is two years old now; so one would think that ... Any way, good luck!

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 23 of 24
mmaeder
Initiate

Re: Armor slows internet speed drastically

I have the exact same problem. Luckily I'm still using my test month. 
The funny thing was though I upgraded my internet to 1Gbps during the time I activated the Netgear Armor trial. 

 

Before my internet upgrade I always capped at like 48 Megabytes / s. 

A few days into my Netgear Armor trial and Internet upgrade I noticed that I'm downloading at only 25 Megabytes / s and being capped at ~25.6 Megabytes / s. 

My first thought obviously was: Something went wrong during the upgrade process to 1 Gbps so I contacted the provider and asked them but they only asked me todo even more tests and send them screenshots from my speedtests. 


Funny enough, I always tested via speedtest beforehand and I always got around +/- 700Mbps. but as soon as I 'actively' downloaded something from steam or wherever, doesn't matter, I always got capped at ~25MB/s. 

Just before sending the Mail to my provider that it isn't my Netgear Router I remembered my trial for Netgear Armor deactivated it, just to check and lo and behold it jumps up to 80MB/s etc. 

My thought is it's slowing down traffic because of DPI (deep packet inspection) probably? But that wouldn't explain why it capps my bandwidth at exactly 25MB/s it never goes higher than that with Netgear Armor active.

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 24 of 24
Top Contributors
Discussion stats
  • 23 replies
  • 20622 views
  • 27 kudos
  • 8 in conversation
Announcements

Orbi WiFi 7