Reply
Highlighted

Armor subscription activated but not not applied to RBR50

I bought a subscription and during activation was presented with a very confusing dialog and apparently chose poorly.  The activation was accepted, but the RBR50 is still running on the trial.  See screenshot.  Please see screenshot attached. How do I transfer the activation to the router?  

Attempting to go direct to support, I am not presented that option as it says my support period “expired” on 7-20-19, at date 5 weeks in the future.

 

 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 52
Highlighted
NETGEAR Moderator

Re: Armor subscription activated but not not applied to RBR50

Hi @SilentService, welcome to the community! Your one year paid subscription will take effect as soon as the trial period expires, which according to the screenshot, is still 9 days out. Please keep us posted if it doesn't switch over.

 

Dexter

Message 2 of 52
Highlighted

Re: Armor subscription activated but not not applied to RBR50

Hi Dexter,

 

Armor is NOT active on my router as screenshot shows.  Subscription shows active on zero devices.  Pls advise,

Rob

Message 3 of 52
Highlighted
NETGEAR Moderator

Re: Armor subscription activated but not not applied to RBR50

Hi @SilentService, does the router UI and/or the Orbi app show that your Armor subscription is active?

 

Dexter

Message 4 of 52
Highlighted

Re: Armor subscription activated but not not applied to RBR50

Hi again. The Orbi app security panel says expired. I can’t attach screenshot because suddenly .jpeg files are not accepted as a valid attachment type.
Message 5 of 52
Highlighted

Re: Armor subscription activated but not not applied to RBR50

Here is the screenshot I was unable to attach earlier

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 6 of 52
Highlighted
NETGEAR Moderator

Re: Armor subscription activated but not not applied to RBR50

Hi @SilentService, thank you for responding. Please make sure that the credentials that you've used for the trial is the same as the one you've used when you subscribed. Also, what happens if you go and select Renew Your Subscription and senter the activation code that you've received?

 

Dexter

Message 7 of 52
Highlighted
Guide

Re: Armor subscription activated but not not applied to RBR50

I have the same problem. The rollover from Free to Subscription status did not happen. Status in Orbi App is "Inactive" though I purchased the year subscription. The subscription info shows it has over 300 days remaining though it is not applied to any device, including router.  Have trouble ticket and have sent same info to both Netgear and BitDefender. Can't get any reply. Would really like to resolve this but need some help from somebody at Netgear or Bit Defender. Frustrated! 

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 8 of 52
Highlighted
Luminary

Re: Armor subscription activated but not not applied to RBR50

HI @DexterJB . You know, and I know you do, there has been so many posts from user experiencing difficulties transitioning from TRIAL to PAID that one must wonder: DOES BITDEFENDER REALLY WANT US TO BUY INTO THIS OR NOT? Becausea if they do, they better get their act together PDQ and facilitate the process! Honestly Dexter, I've never, but NEVER seen anything like this. No matter how technically-able a company is, if it can't handle something as simple as to ACCEPT a PAID subscription to their product, then they have a real problem, don't they?

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 9 of 52
Highlighted
Star

Re: Armor subscription activated but not not applied to RBR50

I have the same problem where before trial expired everything was working fine, and after I paid for subscription it's no longer working. By the way I have entered the activation code and my subscription is now recognized as active in my Netgear account (and also bitdefender is working on my Android phone using the subscription). It's just that my Orbi does not recognize the subscription as active (and no, I will not reset my router if that is the recommended "fix" - that is too painfull to deal with so I will do that only when it's time to update to new firmware again). But because of this frustration I'm also never going to renew the Arbi subscription again - I should not have to deal with wasting an hour or so because Netgear can't get simple activation working without making consumers going through this hassle.

Message 10 of 52
Highlighted
Initiate

Re: Armor subscription activated but not not applied to RBR50

I hate to say Me Too, but I am having the same problem. Active on my phone and not active on the router and I can not find any options to transfer etc.

Message 11 of 52
Highlighted
Guide

Re: Armor subscription activated but not not applied to RBR50

Spoke again with Bit Defender Tech Support about my trouble ticket (from several weeks ago) which has found no reponse from either Bit Defender or Netgear. Of course the support agent promised he would send the ticket back up to the higher level support and that I would receive a reply within a couple of days. Sorry to say I don't expect much. But, that is how they want to play the game.

 

With the exeption of VPN and this Netgear Armor problem (VPN Doesn't work on Mac) my Orbi has worked very well and is a good system. But I will find another solution and never purchase another netgear product (Currently have another Netgear router in office and several netgear switches). They obviouly don't care as can be seen from the lack of responses here in the forum or the tech support groups.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 12 of 52
Highlighted
Luminary

Re: Armor subscription activated but not not applied to RBR50

Hi @jhelton . I don't know about Armor/Netgear/Bitdefender VPN, but I have no problem whatsoever running NordVPN IKE on my two MacBook Pros.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 13 of 52
Guide

Re: Armor subscription activated but not not applied to RBR50

Thanks for the info but the VPN I spoke of is the built-in vpn on the Orbi Router. There seems to be a conflict with the OpenVPN version for Mac, Mac OS and Orbi.  Am familiar with Nord, Express, and DisconnectMe VPN's. All are great products.

Message 14 of 52
Highlighted

Re: Armor subscription activated but not not applied to RBR50

Hi. I'm having the exact same problem. I paid for the year subscription and have not been able to find any real help at all. This is frustrating beyond belief.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 15 of 52
Highlighted

Re: Armor subscription activated but not not applied to RBR50

Sorry about the double post.

Message 16 of 52
Highlighted
Tutor
Tutor

Re: Armor subscription activated but not not applied to RBR50

I have the same problem . Activated but not applied to RBR 50 on Orbi App Security feature.
Hope there will be a solution soon .
Message 17 of 52
Highlighted

Re: Armor subscription activated but not not applied to RBR50

I got my issue resolved. I went to the Bitdefender website and spoke with the support folks via chat. I talked with them last night and it was fixed this morning. Here's a link to the site: https://www.bitdefender.com/consumer/support/

Message 18 of 52
Highlighted
Luminary

Re: Armor subscription activated but not not applied to RBR50

That's good news @Retsailor2009 . Did the rep offer any hints as to why the process is this difficult?

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 19 of 52
Highlighted
Guide

Re: Armor subscription activated but not not applied to RBR50

Glad your issue was resolved. I contacted Bit Defender Tech support weeks ago, received a trouble ticket number, and was told to wait and it would be resolved. NOTHING!

 

I spoke again with Bit Defender Tech Support on Friday. Tech pulled up my trouble ticket and said, Yep, it was sent up but nothing was done. He advised he would be sure to send it up again so it would be handled.  As of this morning, NOTHING.

 

Would you describe what had to be accomplished to resolve the issue?

 

Whoever is the manager of this trial to full version of Bit Defender for the Orbi Router, whether the manager is from Netgear or Bit Defender, or both, have not earned kudos for this process. It shouldn't be this hard. Nor should it take this much grief, from so many people, to get it reolved!  POOR MANAGEMENT!

Message 20 of 52
Highlighted

Re: Armor subscription activated but not not applied to RBR50

They gave me no idea as to what the issue was. I did send an email back to the rep asking for the days that I paid for but didn't get back. I've yet to hear back from them. 

Message 21 of 52
Highlighted
Luminary

Re: Armor subscription activated but not not applied to RBR50

Heck @Retsailor2009 , with all the aggravation they caused, they should add three months to your subscription! (;<))

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 22 of 52
Highlighted

Re: Armor subscription activated but not not applied to RBR50

I understand your frustration. Poor support makes wanting to buy from or support a company very difficult. To be honest with you, after going in loops for about 3 times, I became aggravated and made my way to the Bitdefender site. Even their support will take you in loops if you don't pay attention. That's why I posted the link. To answer your question, I did nothing more than get in a chat with them and explain the issue. I told them that there were a huge amount of users having the exact same issue. I told them how frustrated I and they were. That's it. Sorry I can't give you anything more. Good luck and I hope that you and the rest reading this have the same luck I did. There's a screenshot of the chat I had with them last night attached.

Message 23 of 52
Highlighted

Re: Armor subscription activated but not not applied to RBR50

Attached is a copy of the email I got from them this morning. Maybe it'll help, maybe it won't. But, if it helps than my work here is done ;-)

Message 24 of 52
Highlighted

Re: Armor subscription activated but not not applied to RBR50

@Orbi-Roc I don't disagree with you there lol

 

 

Message 25 of 52
Top Contributors
Discussion stats
  • 51 replies
  • 4365 views
  • 39 kudos
  • 13 in conversation
Announcements