Orbi WiFi 7 RBE973
Reply

Re: Is Armor activated or not?

Gary_A
Guide

Is Armor activated or not?

Armor.netgear.com website shows I have a subscription.  The IOS App shows the tile for Armor as expired, clicking it takes me to a screen to renew my subscription, clicking to renew takes me to the Armor portal/site and shows I have a subscription.  What am I missing?

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 18
Santap
Tutor

Re: Is Armor activated or not?

Exactly same issue for me as well. 

Router: Orbi RBR50

Firmware: 2.3.1.60

Message 2 of 18
Gary_A
Guide

Re: Is Armor activated or not?

I called support at Bitdefender and they have escalated it to a level 2 as the tech could not figure out the reason the the orbi app or router is not seeing that Armor is activated.  Great tech, understood the problem but just couldn't fix it.  Netgear really needs to take some ownership in this but knowing that they only provide 90 days of support via phone or e-mail after pruchase means I don't want to call and be told I have to pay for the call.  I will update this thread once I see what Bitdefender does.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 3 of 18
Gary_A
Guide

Re: Is Armor activated or not?

Bitfender resolved my issue and Armor shows actived in the app and router now.  I recommend contacting them at https://www.bitdefender.com/consumer/support/

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 4 of 18
Christian_R
NETGEAR Employee Retired

Re: Is Armor activated or not?

Hello @Santap

 

We have also noticed an issue. If you believe that your expiration date on the status is not accurate, please DM me with your serial number/email address and we will look into it for you. 

 

@Gary_A - Glad to hear you were able to get it resolved. Also, thanks for posting an update on the thread as it may help others who may experience the same issue. 

 

~Christian 

 

Message 5 of 18
Einrich
Star

Re: Is Armor activated or not?

I have the exact same issue (on latest router firmware and latest android app). When I go deep to the Netgear Armor page (black background), it shows that I have 323 days left on my subscription.

 

Obviously - I paid to renew.

 

Except that something went wrong during the renewal in the router and in the app, as there the Armor still shows respectively there as Not Activated and as Expired...

 

It's only when I click renew in the app (which is stupid as I already renewed) that I am prompted for a licence (which of course I already used) but then I am sent to the Armor Page and where everything is fine...

 

What must I do to fix this? I contacted bitdefender who told me I ha to contact netgear (which I did)...

2 months later, 5 reminders later, there's nothing on my ticket.

 

No answer, no reply, no action. Just personal frustration over what seems like a good product.

 

If support can / wants to look at it, I can give them my info. In the meantime, I feel ripped-off.

 

 

Message 6 of 18
Einrich
Star

Re: Is Armor activated or not?

I have also done a check... Since Armor is "considered active" in the black armor page, I decide to try to download a test malware file. Of course, for that I had to disable bitdefender and its associated url defender in my browser. I could then download the sample EICAR test file.

 

This shows that if the router states the armor is not activated, then it's not working to protect those device on your network that do not have antivirus (think your tv, your game console, cameras, etc).

 

This also shows that the "trial activation" and "renewal" features of both the ORBI APP (and the lack of management features in THE ROUTER) are an issue. As soon as both don't sync properly, and if you have used up a licence, then you are effectively in trouble.

 

Customer support can't handle this well, as the licences are not issued by them but via B2B2C from Bitdefender. You being a C (a customer) can't really get support from B (netgear) while the other Business (Bitdefender) asks you to work with them.

 

Senior Management at Netgear, in the product dev, should look into it.

Message 7 of 18
Einrich
Star

Re: Is Armor activated or not?

Factory setting resets the trial, but if you are passed trial, then the APP blocs you at that stage. The app cannot find a renewed account for some reason. There's therefore an automation issue where the licence exists but isn't found. Pasting it in the app (for those who didn't try a factory reset) does not work (says license already used).

Message 8 of 18
Christian_R
NETGEAR Employee Retired

Re: Is Armor activated or not?

Hi Einrich - Thank you for your post. I have responded to your message requesting for more information. 


~Christian 

Message 9 of 18
iamadamc
Aspirant

Re: Is Armor activated or not?

I have same issue. Please advise how I can get help?
Message 10 of 18
DexterJB
NETGEAR Moderator

Re: Is Armor activated or not?

Hi @iamadamc, welcome to the community! It is best to reach out to the Bitdefender support team for them to sort it out on their end. You can contact them via the link below.

 

https://www.bitdefender.com/consumer/support/

 

Dexter

Message 11 of 18
Gary_A
Guide

Re: Is Armor activated or not?

Bitdefender solved my issue within 24 hours once I reached out to them.  Armor has worked as expected since then.

Message 12 of 18
Einrich
Star

Re: Is Armor activated or not?

Honestly - Netgear support did not manage to do anything. I opened a ticket, complained here, got help from a nice moderator. But it's only after sharing ALL of my experience with bitdefender that they fixed it. 1st time they told me to go to netgear. That was a mistake. 2nd time they fixed it. Glad they did - i was getting frustrated. This said - I do believe that the 2 companies need to fix this issue and iron out the support process. I will not post anymore about this. Short answer - Contact bitdefender support and be persistent.

 

Message 13 of 18
Wisconsingal
Tutor

Re: Is Armor activated or not?

I just purchased the armor subscription And I am experiencing the very same issue. I tried going to the consumer help site suggested here but I can’t find a phone number nor can I find any information on how to fix this.
Model: R7000P|Nighthawk AC2300 Smart WiFi Dual Band Gigabit Router
Message 14 of 18
Gary_A
Guide

Re: Is Armor activated or not?

I contacted the number for Bitdefender on their website, they resolved the issue very quickly.
Message 15 of 18
Wisconsingal
Tutor

Re: Is Armor activated or not?

Thanks I'll give that a try.. 

 

I work in the Tech support/customer service industry and this type of scenario is a bit ridiculous.  By now their should be specific steps to resolve it listed somewhere publicly for paying customers or at the very least general steps customers were expected to follow to resolve it. 

.  You mentioned that you called them and they had it resolved quickly, what was done to resolve it?  

Message 16 of 18
Wisconsingal
Tutor

Re: Is Armor activated or not?

Hi,

 

I did put a call into Bitdefender, the customer support team member was not able to fix the issue or identify the root cause so he opened up a case and forwarded it to their Tech Support team.   While waiting for Tech support, I was able to resolve the issue on my own.  I ended up doing a factory reset on the router and re-enabled/activated Armor security.  App now shows it's Activated.  

 

 

Message 17 of 18
TheFloridian
Aspirant

Re: Is Armor activated or not?

Hi All,

Rebooting the router fixed the issue on my end. Hope it works for you.

TheFloridian
Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 18 of 18
Top Contributors
Discussion stats
  • 17 replies
  • 8658 views
  • 10 kudos
  • 8 in conversation
Announcements

Orbi WiFi 7