Orbi WiFi 7 RBE973

Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

KellyOrbi
Apprentice

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Did Netgear Support tell you to do the nuclear option?    This is getting ridiculous!  We've had this problem since August.

Message 26 of 96
-SlowJoe-
Apprentice

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Crickets on my end lately. (Attached screenshot)

They only collected data/configs from my router and then went quiet on me. Confident now my configs have nothing to do with it as this is legit effecting every customer using netgear armor on a mobile device. Hopefully NG support established that by now. Still hoping the more support tickets we submit the higher their urgency will be!

Keeping fingers crossed because I think the product has potential. It’s also a deal compared to bitdefender’s offerings as you can cover unlimited devices. That said, if it doesn’t work will have to look elsewhere eventually…
Message 27 of 96
Jeffgear
Luminary

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Agree that the product has potential if the security score and reporting accurately reflected iOS devices. Despite the fact Orbi thinks my iOS devices are not protect the installed Bitdefender app does a great job at blocking dubious sites and redirects in phishing emails.

If they fix the iOS device reconciliation and allow whitelisting or exclusions for smart home devices it thinks are eligible for the agent, it would be a great product. The other quirk with the current Orbi app version is you can no longer list the devices it thinks are unprotected and eligible - you have go through each device one by one checking their security status to find them.

I’m on the fence now and may try another 3rd party device protection product outside of Orbi integration when my Armor renewal is up. Overall Netgear is good kit and it’s been fun to own and experience it, but it concerns me that every product I have of theirs has a range of bugs, feature limitations and niggles that really are obvious issues that must be impacting a large group of users. Maybe their bug fixing focus is on the SME product range that represents are larger sales margin but most SMEs are influenced by their staff who own the home product range. So they should be careful they don’t alienate too many home users who are IT support staff would then not recommend Netgear into their SMEs.
Message 28 of 96
Jeffgear
Luminary

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

FYI I’ve tried my iPhone running with private wi-fi addressing disabled all week to see if Orbi/Armor recognised it as protected in the Orbi app security tab. It’s not made any difference despite Bitdefender running on the phone and me having to edit the device name in Orbi Device Manager as it saw it as a new phone when I disabled private addressing.

Message 29 of 96
Jeffgear
Luminary

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

I had another follow up call from NG Support. After recalling the full history for about an hour and sending through more screen shots from the Orbi app and iOS Bitdefender, and being put on hold as the agent conveyed my updates back to someone else, I was told the issue will be resolved in the next Orbi app update, and my case would now be closed.

Given I’ve been through a few Orbi app, Bitdefender app and iOS updates over the last year (and with hindsight did the unnecessary nuke option of factory resetting my router) during which time this issue has been apparent, I’m not entirely convinced it will be resolved in an impending Orbi app update, but I’ll reserve a degree of optimism that the person working behind the scenes is enlightened about the root cause and the app development fixes that are forthcoming.
Message 30 of 96
-SlowJoe-
Apprentice

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Wow, maybe some movement?!

Think your skepticism is warranted for sure and I’m with you on it. Hopefully we’re wrong though.

No movement on my end.
Message 31 of 96
BK1959
Star

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Thanks for this update! We’ll keep our fingers crossed.
Message 32 of 96
KellyOrbi
Apprentice

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Pathetic that they haven't fixed this yet.   I am not optimistic that the next update will fix it.

Message 33 of 96
BK1959
Star

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Got a new Orbi app update on my iPhone yesterday, which hasn’t solved the problems. Apart from not recognizing Armor on iOS devices, the Orbi app keeps prompting me to allow notifications although I have already allowed them in the settings….
Message 34 of 96
KellyOrbi
Apprentice

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

The fun continues...

Message 35 of 96
Jeffgear
Luminary

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

I updated the Orbi app to version 2.21.0.329 and it’s made no different to the Armor security feature not recognising it’s actually installed and running on iOS devices. I tried disabling Armor in the Orbi app and re enabling.

I’m disappointed in the support team who clearly fobbed me off and closed the case on the assumption the new app was fixing a range of bugs without actually confirming the update actually fixed the iOS issue. In fact I explicitly asked the agent if it actually fixed this issue and they said it did. I even asked if they were sure and confident in this assertion. Pretty tardy and unprofessional. I now have the pleasure of raising a new case from scratch if I cannot re open the case…
Message 36 of 96
-SlowJoe-
Apprentice

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

That’s unfortunate. I’m starting to think it may actually be attributed to the Bitdefender for Netgear Armor app and not the Nighthawk/Orbi apps. That’s the only common denominator here and it hasn’t been updated in 7 months (at least the iOS version). Here’s to hoping someone behind the scenes at Netgear knows what’s going on and the customer service reps are just out of the loop.
Message 37 of 96
Jeffgear
Luminary

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

I’m thinking the same - the iOS Bitdefender app or the back end armour console (armor.Netgear.com) are not reconciling with the Orbi app. The Orbi app likely does an API call to the armor console for an update on device protection status. But the console itself says they are protected - or it did at one point but I now have each iOS device listed twice, once with a red B badge and the other entry without. Green checks for threats and vulnerabilities for the entries without the red B badge. Interestingly the red badged iOS devices show not yet scanned but green rock for no threats. Running the scan locally on the device doesn’t reflect on the console. I think duplication of devices was after I changed back to private addressing under my device’s wifi setting as this made no difference to the Orbi app security status after several days. I could tidy this up and remove all iOS devices from the armor console, log them back into Bitdefender and refresh them again, await for the. To have scans run so they get green ticks, but the Orbi app will still say they are unprotected, whether or not the console shows a red badge or not.

So my bet also is the Bitdefender app is at fault and has not been updated through various iOS updates since 15.x to correctly provide device status to the console which in turn provides this to the Orbi app over an API call.
Message 38 of 96
Briansf
Apprentice

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Just D/L the newest NetGear Armor update and no change with my iPhone 13. It recognizes the phone but is still says I need to install it with Bitdefender. Same as usual. I actually think the update made things worse. Will be leaving Netgear nighthawk and Bitdefender when subscription expires. Customer support is the worst. Cannot get thru to talk to anyone! 

Message 39 of 96
Jeffgear
Luminary

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Out of idle curiosity and some degree of relentless hope, I decided to log into the armor.Netgear.com console and delete all iOS devices. I have 2 iPhones and 2 iPads but there were duplicates for when I tried private addressing, some with a different status. I deleted them all.
On my iPhone I re ran the Bitdefender app scan and enabled web protection. Meanwhile back in the Orbi app the iOS devices changed from showing “add armor” (or whatever it reported previously) to no status and clicking the security tab reports “security details currently unavailable…” The security score has gone up thinking the iOS devices are ineligible devices. This is what happens. After a day or so, the security tab in Orbi reverts to saying the iOS devices are eligible for protection and the security score drops.
Message 40 of 96
Briansf
Apprentice

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Thanks for the info. Were you able to install bit defender on your iPhones and iPads so it shows installed in the Nighthawk app? Bitdefender app seems to run just fine on my iPhone and scans with no problems. Only my iPhone 13 is affected. My iPad runs bit defender just fine and shows installed in the Night hawk app. My set up is Xfinity 1.2G plan, Netgear CM1200 modem and Netgear RAX80 Router, iPad air2 and Mac mini M1. I've deleted Nighthawk app and Bitdefender on iPhone and reinstalled but no change.  

Message 41 of 96
Jeffgear
Luminary

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

The Bitdefender app installed on the iOS devices shows as installed in the armor web console but not on the Orbi app - that’s the key issue here. Bitdefender works as expected locally on the iOS devices, scanning and providing VPN web protection.

My MacBook works fine running Bitdefender and shows running on the Orbi app, but none of my 4 iOS devices do. So it’s just certain iOS devices, regardless of private networking enabled or not.

Message 42 of 96
pehlm
Aspirant

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

This is also on Android. (see this thread).

Message 43 of 96
Dorm
Initiate

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

This also happens with nighthawk for my rax120.
My iPhone 13 pro and galaxy 22 max are shown as not installed locally.
I did it twice, and still, not recognized.
Also, on armor site my galaxy has the "B" badge and for some reason duplicate the iPhone and galaxy devices.
Message 44 of 96
BK1959
Star

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Another quirky issue in the Orbi app: protection level is down to 74 or 71 because I haven’t “turned on security notifications”. But all notifications have been turned on!
The latest app update hasn’t solved any of the problems.
Message 45 of 96
Jeffgear
Luminary

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Just seen a new Orbi app update - version 2.21.1.353 - sadly this hasn’t resolved the Armor Security issue with the iOS Bitdefender app. Maybe they focussed on the connectivity bugs that have surfaced. Meanwhile the Bitdefender app remains on version 4.0.0 after 7 months.

The odd thing now is the Security score log is fluctuating between 84 and 88 each day, repeating the same messages reporting that I have turned on or indeed turned off security notifications - which is mistaken as it has always been turned on in my iOS settings.
Message 46 of 96
-SlowJoe-
Apprentice

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

Was optimistic but think it’s passed lol (see attached image). If they reach out, going to try to explain one more time. May have to give up on NG Armor in its entirety if this last shot doesn’t work. This issue is too basic to waste this much time/energy on. Sad. Had potential.
Message 47 of 96
Briansf
Apprentice

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

So it happens not only on iOS devices. I just upgraded my iPad air2 to the new iPad 10.9 and when I transferred all my files to the new iPad netgear armor showed Bitdefender as not being installed when in fact it is. Before with the old iPad it showed that it was installed. Really buggy software! Also Bitdefender shows that my software is out of date on the new 10.9 iPad even though it is. Oh..I also have my iPhone listed twice in armor. one shows Bitdefender installed and the other not installed. Also noticed that the MAC addresses are different even though it's the same phone. And one other thing I noticed. When I switch my iPhone to 2.4G it will not connect to the network! My iPad however works fine in 2.4G. I know protection is still working because I accidentally typed in a wrong web site and Bitdefender caught the mistake. I guess it's just buggy software. My iMac Mini works just fine. 

Message 48 of 96
Briansf
Apprentice

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

It's not just the Orbi App! I'm running the RAX-80 router and I get the same thing. I'm using the Netgear Nighthawk App with Bitdefender. My notifications are also turned on and I get the same thing. Security level changes from 81 to 79. I'm at the point where I don't even to look at it anymore! Just checked and no updates available. Does Bitdefender or Netgear care? 

 

Message 49 of 96
Briansf
Apprentice

Re: Netgear Armor Not Recognizing Bitdefender for Armor on Mobile Devices

I have the RAX-80 router and I get the same thing. My security fluctuates also. My security notifications are always on. Must be buggy software. 

Message 50 of 96
Top Contributors
Discussion stats
Announcements

Orbi WiFi 7