Orbi WiFi 7 RBE973
Reply

Netgear CM2050v not working with Xfinity stream

CSMoore
Aspirant

Netgear CM2050v not working with Xfinity stream

My Xfinity stream is no longer working. Have Netgear CM2050V. Internet works fine. Used to work fine, but something changed. Guys and menus work fine, but Xfinity stream of video just has 3 dots pulsing. It seems the video str is not getting through. Ideas to try?
Message 1 of 4
plemans
Guru

Re: Netgear CM2050v not working with Xfinity stream

The CM2050v doesn't block anything. Its a modem only device. 

It'd be the router blocking/preventing something. 

What router do you have? 

Message 2 of 4
CSMoore
Aspirant

Re: Netgear CM2050v not working with Xfinity stream

Thanks, understood.   Just wasn't sure if there was anything at all within the modem, as saw some of the info on Netgear Armour.  I have Linksys router, nothing changed in a long time on router. 

I'm pretty sure it is something on the Comcast side of things, as nothing changed on my end. 

Also further debugging, I see it is just hanging only on my WiFi for in-home channels, and the to-go channels work fine. 

Menus and everything is ok, just doesn't show the video streaming.  All other apps streaming ok too.

 

 

Message 3 of 4
plemans
Guru

Re: Netgear CM2050v not working with Xfinity stream

Netgear Armor would be on a router, not the modem. 

You could try a different DNS provider. Or check on the linksys forums for help with their device

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 308 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 7