Orbi WiFi 7 RBE973

Re: Orbi app saying Armor not installed on iPad


Orbi app saying Armor not installed on iPad

Just to note that the Orbi app has been recently updated (1 week ago, now version and my issue with my iPhone and iPad showing as eligible for Bitdefender Security is still present despite both devices actually running the Bitdefender app and using the VPN, and giving a successful scan from the Bitdefender app.


Have tried rebooting the Orbi router (numerous times) and the two Apple devices with the misreporting Security status. Two other Apples devices (same models) report their status fine in the Orbi app. Have tried purging the two offending devices from the armor console and reinstalling the app on the devices, as well as forgetting the wifi association and re-associating to wifi to force a refresh of private wifi addressing.


So this has not been fixed by an Orbi app update. I suspect my option of last resort remains a factory reset and rebuild of the Orbi router - something I have been avoiding to do to date and will wait for when I can devote/waste what could be a full day's tinkering.


Unless anyone has any tricks up their sleeve to try?

Message 1 of 3

Re: Orbi app saying Armor not installed on iPad

Message 2 of 3

Re: Orbi app saying Armor not installed on iPad

Yes sounds like exactly the same issue for me, so it appears there’s also this bug on the RBR50 running v2.7.4.24 firmware.

Will await an update and not waste time factory resetting etc.
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation

Orbi 770 Series