Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation

Top Contributors

ReadyNas 316 - ReadyNas app unauthorized  to access Google Drive Cloud

Hi, when switching the "Off/On" button on Cloud Service Tab for Google Drive, I have the message :" unauthorized. it could be invalid user account credential or the is not allowed to access cloud drive. Stopped syncing with Google Drive".

I can still access my google drive by pressing "Google Drive" which means that my credential are correct. There is red light beside the Google drive Logo (instead of Blue or Green).

It worked the first time I switched to "ON" and set up google drive. few hours after I deleted the Application access on Google drive web page (I wanted to delete DropBox access and pressed on the wrong line. SInce then, tried everthing: Switched Off, and Switched On Google Drive, deleted the session, tried to use another share, used a another browser, emptying all cookies and historical data, used another computer... nothing works.

It seems that ReadyNas app kept a track of the deletion of the service or google (but I don't think so), I also noticed that when I try to change the name of the share originally synchronised with Google, the NAS is stating that I cannot change the name because another app is using it..."Google drive"... 

This is why I think my problem is with the server and not Google website. I need in a way or another to empty cache or delete this log related to the first google connection and get back to a situation like if it was the first time that I try to switch on the service related to Google Drive Cloud.


I am using ReadyNas316 with 6.9.4 firmware. It is not 3 days that I am trying everything but I failed.


Thank you for you help dear Netgear community

Model: RN31662D|ReadyNAS 316 6-Bay 6x2TB Desktop Drive
Message 1 of 3
NETGEAR Moderator

Re: ReadyNas 316 - ReadyNas app unauthorized  to access Google Drive Cloud



Welcome to the Community!


Removing the application access on the Google drive page does not remove the configuration set on the NAS. The NAS then is being blocked by Gdrive since there is no application access available to permit it.


This can be removed through backend access, if you are comfortable with SSH if not you may want to contact Support for assistance on this. You may also want to try doing an OS-Reinstall, this procedure resets settings on the NAS though I am not sure if this will get the config cleared.


OS-Reinstall will reset your Admin password and Network settings. Click here on how to do OS-Reinstall.


Hope this helps!






NETGEAR Community Team

It's what you do that defines you
NETGEAR Community User Guidelines
Message 2 of 3

Re: ReadyNas 316 - ReadyNas app unauthorized  to access Google Drive Cloud

Hi Marc_V


Thank you for you answer, I am in a "home" environement so I do not mind activate an SSH access, is there a link or guidelines available to change application access through SSH backend access?


Thank you

Message 3 of 3