× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Re: Error setting email alerts

joe_schmo
Tutor

Error setting email alerts

RN428

 

I am trying to send a test alert, and I get an error: 1001000022 Contact Technical Support.


I try removing and re-adding the email and get same thing. 

Netgear no longer offers tech support so wondering if anyone here has any ideas what I can try.

Message 1 of 8
joe_schmo
Tutor

Re: Error setting email alerts

When I try to click on "Sign in with Google", it takes me to a page that says "Redirecting. Please wait..."  And that's it.

I wonder if something is broken with that sign in page?

Message 2 of 8
StephenB
Guru

Re: Error setting email alerts


@joe_schmo wrote:

When I try to click on "Sign in with Google", it takes me to a page that says "Redirecting. Please wait..."  And that's it.

I wonder if something is broken with that sign in page?


Google dropped their "less secure apps" setting, so now you need 2FA enabled on your google account in order to get an app-specific password.  

 

Another option is to get a second email address for sending the alerts (but still send them to gmail).  Yahoo still allows app specific passwords w/o 2FA.

Message 3 of 8
givememynamebak
Luminary

Re: Error setting email alerts

I get the same error: 1001000022 on my 628x. However, it works just fine on my Readynas Pro6 when I clear out all "Alert Contacts" and login with "Sign In With Google" button it all works. But, on the 628x with OS6 (same version), I get this page:

192.168.1.100/emailservicecb.html

 

That stays on this page that says:

Redirecting. Please wait...

 

It just hangs there, and does nothing.  I don't even get the option to login with Google.

 

The logs say:

Oct 27 23:47:04 ReadyNAS dbus[5080]: [system] Activating via systemd: service name='com.readynas.OAuth2Vault' unit='dbus-com.readynas.OAuth2Vault.service'
Oct 27 23:47:04 ReadyNAS systemd[1]: systemd-journald-audit.socket: Cannot add dependency job, ignoring: Unit systemd-journald-audit.socket is masked.
Oct 27 23:47:04 ReadyNAS systemd[1]: Starting OAuth2 Vault Service...
Oct 27 23:47:04 ReadyNAS oauth2-vault[11650]: time="10-27-2022 23:47:04" level=error msg="Failed to decode config: EOF"
Oct 27 23:47:04 ReadyNAS oauth2-vault[11650]: time="10-27-2022 23:47:04" level=fatal msg="Failed to call LoadEmailService1Config: EOF"
Oct 27 23:47:04 ReadyNAS systemd[1]: oauth2-vault.service: Main process exited, code=exited, status=1/FAILURE
Oct 27 23:47:04 ReadyNAS systemd[1]: Failed to start OAuth2 Vault Service.
Oct 27 23:47:04 ReadyNAS systemd[1]: oauth2-vault.service: Unit entered failed state.
Oct 27 23:47:04 ReadyNAS systemd[1]: oauth2-vault.service: Failed with result 'exit-code'.
Oct 27 23:47:29 ReadyNAS dbus[5080]: [system] Failed to activate service 'com.readynas.OAuth2Vault': timed out
Oct 27 23:47:29 ReadyNAS readynasd[6069]: Failed to issue method call: Activation of com.readynas.OAuth2Vault timed out
Oct 27 23:47:29 ReadyNAS readynasd[6069]: Failed to delete active oauth2 email service.

 

I have no idea how to get the oauth2-vault.service to start up properly.  Until then... I get only:

192.168.1.100/emailservicecb.html

 

That stays on this page that says:

Redirecting. Please wait...

 

I'd appreciate any suggestions!

 

Message 4 of 8
givememynamebak
Luminary

Re: Error setting email alerts

I was able to fix this by copying the following files from my ReadyNAS Pro6 to my 628x.  So I am posting what worked for me.

 

From Pro6 to 628x as follows:

 

scp /etc/msmtprc 192.168.1.100:/etc/msmtprc

scp /etc/frontview/alert.conf 192.168.1.100:/etc/frontview/alert.conf

scp /etc/frontview/.oauth2-vault-email.json 192.168.1.100:/etc/frontview/.oauth2-vault-email.json

 

Reloaded the page on the 628x and test message sent successfully!  The .oauth2-vault-email.json was the one that made the oauth2-vault.service finally work right.  I'm not sure how it was corrupted.

 

# systemctl --type=service

oauth2-vault.service loaded active running OAuth2 Vault Service

Message 5 of 8
aprosnyak
Tutor

Re: Error setting email alerts

@givememynamebak thanks for your hint. Just deleted .oauth2-vault-email.json and alert.conf, relogined to gmail and everything works fine )).

Message 6 of 8
jimk1963
Luminary

Re: Error setting email alerts

YES!! Thank you for this fix.

 

In my case, RN424 worked fine, RN528X had the same symptom as you described. I SSH'd into my RN424 and ran these commands:

 

scp /etc/msmtprc 192.168.1.xxx:/etc/msmtprc

scp /etc/frontview/alert.conf 192.168.1.xxx:/etc/frontview/alert.conf

scp /etc/frontview/.oauth2-vault-email.json 192.168.1.xxx:/etc/frontview/.oauth2-vault-email.json

 

Note when I executed the first command, some warning message popped up asking me to confirm access to the other NAS, then also made me enter the other NAS's credentials before it would execute the command. After that, each command required the other NAS's credentials to execute. 

 

I refreshed the RN528X System/Settings page (page where alerts are set up), ran the test message, and Bam! Worked perfectly. Thanks again, this was perplexing. I was chasing after Google security issues, going further down the rabbit hole.

Message 7 of 8
givememynamebak
Luminary

Re: Error setting email alerts

That's great that you had another machine to SCP from - and glad to hear it helped!

 

Cheers!

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 1172 views
  • 5 kudos
  • 5 in conversation
Announcements