Reply
JBDragon1
Virtuoso

I can't Update software on my NAS. I even tried to delete and that failed.

I'm trying to Update PLEX and it's been failing.  I just tried updating EMBY and that is doing the same.  Both are failing to Update.  I even tried to delete PLEX and that failed.  What is going on? I'm running firmware 6.10.3 on my ReadyNAS 516.

 

Model: ReadyNAS-OS6|, RN51600|ReadyNAS 516 6-Bay Diskless
Message 1 of 14
StephenB
Guru

Re: I can't Update software on my NAS. I even tried to delete and that failed.

Have you checked for a full OS partition/

Message 2 of 14
JBDragon1
Virtuoso

Re: I can't Update software on my NAS. I even tried to delete and that failed.

It shows 6.10 TB free.

Message 3 of 14
StephenB
Guru

Re: I can't Update software on my NAS. I even tried to delete and that failed.


@JBDragon1 wrote:

It shows 6.10 TB free.


No.  You are confusing the data volume with the OS partition.  Likely your OS partition (which is only 4 GB - not TB) is full.

 

Do you have ssh enabled?

 

You can use the procedure here to analyze and possibly fix it:  https://community.netgear.com/t5/New-ReadyNAS-Users-General/ReadyNAS-214-System-Volume-root-useage-9...

Message 4 of 14
JBDragon1
Virtuoso

Re: I can't Update software on my NAS. I even tried to delete and that failed.

OK, so MNT is showing like 2.3G Total.

 

Message 5 of 14
StephenB
Guru

Re: I can't Update software on my NAS. I even tried to delete and that failed.


@JBDragon1 wrote:

OK, so MNT is showing like 2.3G Total.

 


That's not full, but has less free space than usual.

 

Can you post the output of btrfs fi df /mnt ?

Also, what other apps do you have installed?

Message 6 of 14
JBDragon1
Virtuoso

Re: I can't Update software on my NAS. I even tried to delete and that failed.

This is what I get.

Data, single: total=3.58GiB, used=2.32GiB
System, DUP: total=8.00MiB, used=16.00KiB
Metadata, DUP: total=204.56MiB, used=24.77MiB
GlobalReserve, single: total=16.00MiB, used=0.00B

 

 

As for other Apps.  I have EMPY which is simular to PLEX.   Tautulli which gives me al kind of usage Data for PLEX.  netdata NT, stat, these 2 I've had off for a while.  I haven't used them in a while.  EMPY I normally have off.  I have it to play around with.  Then there's a few programs I've manually installed by SSH into the NAS like NZBGet, Sonarr and Radarr.  These 3 programs of course don't show up in the installed apps page.  I've been using this setup for a number of years now.  I haven't touched anything, or change anything recently.  I tried to installed a new PLEX update and it failed.  So I assumed it was PLEX.  But there's been like 6 updates since and they all fail.  I've since tried to Delete PLEX and that fails.  Delete EMBY, that fails. etc.  Update fails.  Many times when I try to update or Remove, the NAS I don't now, CRASHES?  It goes to a new page saying Connecting to the ReadNAS Admin Page...  Then I have to log back in again.

 

I do have the WinSCP program installed on my Windows computer to access my NAS that way.  Makes it quicker, easy to delete stuff.  My PLEX Media Server Backup directory I didn't change.  So it was going into the Default. Is that the same limited Partition???  I moved the Plex Transcoding folder out to my Media Folder.  Do I need to do that with the Backup?  I assume that's a backup, but then I'm not sure where the normal PLEX files are at, and if there's 2 copy's in this limited space?  The Main and the Backup?

 

 

Message 7 of 14
StephenB
Guru

Re: I can't Update software on my NAS. I even tried to delete and that failed.


@JBDragon1 wrote:

This is what I get.

Data, single: total=3.58GiB, used=2.32GiB

Total=3.58 GiB means that the file system has 3.58 GiB allocated (and allocated space is not free).

 

Running a balance on the OS partition will help.  Make sure you are logging into ssh as root (not admin).  Start with

# btrfs balance start -dusage=0 /

When that completes, run it again without the -dusage parameter.  You'll get a warning on the run time, but ignore it.

# btrfs balance start /

This second one might fail.  If it does,  then try this instead:

# btrfs balance start -dlimit=1 /

Then increase the -dlimit parameter by 1 and repeat until you get to the number that fails (or until you get to 6).

Then run 

# btrfs fi df /

and let us know that the new total is.

 

 


@JBDragon1 wrote:

 

As for other Apps.  I have EMPY which is simular to PLEX.   Tautulli which gives me al kind of usage Data for PLEX.  netdata NT, stat, these 2 I've had off for a while.  I haven't used them in a while.  EMPY I normally have off.  I have it to play around with.  Then there's a few programs I've manually installed by SSH into the NAS like NZBGet, Sonarr and Radarr. 


When installing your own stuff with apt-get, you need to be careful not to overload the OS partition.  If it gets completely full, the NAS configuration can get corrupted. 

 

The simplest way to reduce OS partition space usage is to move OS folders created by the application to the data volume, and then replace the folders on the OS partition with softlinks.  Note that /apps on the OS is a mount point for /data/.apps, so you can create a "various" folder in /apps, and move the folders into there.

 

ReadyNAS apps are already supposed to put their data into /apps, but not all of them do that.  You might consider removing the apps you haven't used for a while.

 

If you installed the plex package for the ReadyNAS (available from plex), then the backup folder should already be in /apps.  If it's not there, then it might be taking up OS space.  I don't know what the default transcoding directory is, so, I suggest that you create a transcode folder in /apps, and set it explicitly to that.

 

 

 

 

Message 8 of 14
JBDragon1
Virtuoso

Re: I can't Update software on my NAS. I even tried to delete and that failed.

It now shows,

Data, single: total=2.44GiB, used=2.13GiB
System, DUP: total=32.00MiB, used=16.00KiB
Metadata, DUP: total=128.00MiB, used=23.91MiB
GlobalReserve, single: total=16.00MiB, used=0.00B
 
I still can't delete anything.
Message 9 of 14
StephenB
Guru

Re: I can't Update software on my NAS. I even tried to delete and that failed.


@JBDragon1 wrote:
Data, single: total=2.44GiB, used=2.13GiB

Definitely better.

 


@JBDragon1 wrote:
I still can't delete anything.

I'm assuming you mean uninstall.  

 

Are you only using the web interface, or have you also tried removing something via ssh?

Have you looked for errors in the log zip?

 

Message 10 of 14
JBDragon1
Virtuoso

Re: I can't Update software on my NAS. I even tried to delete and that failed.

I'm on the NAS the normal way, and trying to update an app and it's failing.  I tried installing a random app from the available apps section on the NAS and that also fails. The Antivirus software has no problem updating it's self.

Message 11 of 14
StephenB
Guru

Re: I can't Update software on my NAS. I even tried to delete and that failed.


@JBDragon1 wrote:

I'm on the NAS the normal way, and trying to update an app and it's failing.  


What do you think is "normal"? 

  • ssh? 
  • the admin web ui?

What errors are you seeing in the log zip file?

 

Start with app-install.log and apt-history.log.

Message 12 of 14
JBDragon1
Virtuoso

Re: I can't Update software on my NAS. I even tried to delete and that failed.

Normal, as in Admin Web UI.

 

AS for Logs, I get this,

-- Logs begin at Mon 2020-05-25 15:03:48 PDT, end at Thu 2020-05-28 18:09:39 PDT. --
May 27 21:34:24 READYNAS fv-app-install[17747]: [/tmp/plexmediaserver_1.19.3.2852-219a9974e_amd64.deb](0%) prepare
May 27 18:10:26 READYNAS fv-app-install[1897]: [tvmosaic](0%) prepare
May 27 18:07:48 READYNAS fv-app-install[1026]: [/tmp/emby-server-netgear_4.5.0.11_amd64.deb](0%) prepare
-- Reboot --
May 26 21:11:13 READYNAS fv-app-install[16725]: [/tmp/emby-server-netgear_4.5.0.11_amd64.deb](0%) prepare
May 26 18:49:46 READYNAS fv-app-install[7325]: [couchpotato](0%) prepare
-- Reboot --
May 26 18:20:47 READYNAS fv-app-install[16739]: [/tmp/emby-server-netgear_4.5.0.11_amd64.deb](0%) prepare

 

 

 

Then it looks like I have a bunch of these.  I'm showing the last 2.

 

Start-Date: 2020-05-27 21:34:26
Commandline: apt-get -qq install --fix-broken
Upgrade: vim-runtime:amd64 (2:7.4.488-7+deb8u3, 2:7.4.488-7+deb8u4)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2020-05-27 21:34:29

 

Start-Date: 2020-05-28 10:03:41
Commandline: apt-get -qq install --fix-broken
Upgrade: vim-runtime:amd64 (2:7.4.488-7+deb8u3, 2:7.4.488-7+deb8u4)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2020-05-28 10:03:48

 

 

 

Message 13 of 14
JBDragon1
Virtuoso

Re: I can't Update software on my NAS. I even tried to delete and that failed.

Ok, after looking closly at the errors, it was vim giving me issues.  Some kind of error it had was now allowing anything else to be installed.  So I uninstalled it.   EMBY installed normally after than.  PLEX, seem to be working, and then it rebooted.  But looking at PLEX, it seems to have been updated.  So that was strange.   Will have to see if that happens again with the next PLEX update.

 

Message 14 of 14
Top Contributors
Discussion stats
  • 13 replies
  • 570 views
  • 0 kudos
  • 2 in conversation
Announcements