× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Mounting ReadyNAS Share over SSHFS

EvilSupahFly
Aspirant

Mounting ReadyNAS Share over SSHFS

So... my friend and I were in the local Good Will a few weeks ago, and we stumbled upon a ReadyNAS 2120 for $25. They had no idea what it was, nor how (or even if it worked). They let me plug the power in to test it and the lights came on, so I crossed my fingers and bought it.

 

Long story short, after much trial and error, after verifying that the HDDs were still good, I was able to get it running, successfully updated the firmware to 6.10.10, updated the built-in Plex, and got all my movies and TV shows moved over.

 

The problem I'm having now is that I want to mount a specific folder (~/src) from the 2120 on a couple local Linux Mint boxes which share a couple source code projects. I figured the easiest way was to simply put all the projects on the NAS, create a special "code monkey" share for them and automate the mounting process by generating an ssh keypair (which I did with ssh-keygen -t rsa -b 4096) and adding a line to /etc/fstab to load the share on each boot, but it isn't working. Each time I try to mount the project folder from the NAS on a machine, I'm prompted for a password - which the SSH key was supposed to eliminate.

 

From the web interface of the 2120, I imported the key as the KB article here describes, which was accepted by the 2120 with no issue:

 

rnas_ssh.png

 

 

And I've added the following line to /etc/fstab based on this Ubuntu article, since I use Mint (an Ubuntu derivative):

 

coders@10.42.2.95:/data/Code_Monkeys/projects /home/[LOCAL_USER]/src sshfs x-systemd.automount,transform_symlinks,identityfile=/home/[LOCAL_USER]/.ssh/media_server.rsa,allow_other,default_permissions,idmap=user 0 0

 

I've also tried mounting like this, again to no automagical avail:

 

coders@10.42.2.95:/data/Code_Monkeys/projects /home/[LOCAL_USER]/src sshfs _netdev 0 0

 

I can mount manually, which is a good thing, but I want it to mount automagically on boot using the SSH keys, which it isn't doing. Both fstab entries seem to work, but both require me to manually enter the password.

 

TLDR; Is the problem likey on the NAS or the local machines trying to connect? I need a debug option. Is there a way for me to watch step-by-step what happens to see which side the problem is on?

Model: RN2120|ReadyNAS 2120 1U 4-Bay Diskless
Message 1 of 4

Accepted Solutions
Sandshark
Sensei

Re: Mounting ReadyNAS Share over SSHFS

Actually, the easiest way is to use NFS, though it's less secure.

View solution in original post

Message 3 of 4

All Replies
EvilSupahFly
Aspirant

Re: Mounting ReadyNAS Share over SSHFS

I thought it might be that the 2120 was expecting ed25519, so I generated a new key on one of the machines and attempted to upload it but the NAS doesn't like it.

 

Screenshot from 2024-04-16 18-08-13.png

 

Message 2 of 4
Sandshark
Sensei

Re: Mounting ReadyNAS Share over SSHFS

Actually, the easiest way is to use NFS, though it's less secure.

Message 3 of 4
EvilSupahFly
Aspirant

Re: Mounting ReadyNAS Share over SSHFS

I can do that but I was hoping to keep things a little more secure. I suppose if I tweak the UID and GID settings, I can prevent or minimize people from mucking around where they ought not.

Meanwhile, using ssh -vvvvv I have discovered that the SSH key is the issue. The NAS is rejecting the proffered key. I've tried removing all the keys and generating new pairs but the issue persists. Sadly, the 2120 is considered EOL now and I don't think I can get tech support for second hand equipment.
Message 4 of 4
Discussion stats
  • 3 replies
  • 577 views
  • 2 kudos
  • 2 in conversation
Announcements