× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

ReadyNAS Duo V2 USB2.0 Destroys DATA

DrBrain
Follower

ReadyNAS Duo V2 USB2.0 Destroys DATA

Hello Forum & Support
The worst thing your product could do just happend, here is my story.

Sytem: ReadyNAS Duo V2 (with RAIDator 5.3.9) 2xSamsung 2TB (X-Raid), runnig since 2011 or so, last factory reset 11-15-2013 for RADIator 5.3.9.
External Storage: Samsung 3TB D3 USB 3.0 (MBR Partion, NTFS Filesystem), brand new.

I've transferred all Data from the NAS onto the Samsung 3TB USB, through my local PC system (Windows 7 x64), and was about to perform a factory reset on the NAS to wipe the NAS clean.

Today I connected my Samsung 3TB D3 USB 3.0 exteral backup storage to the NAS. It din't worked on the USB3.0 at all, but that's just fine, because I needed to have the external drive as a backup drive, so USB 2.0 will be just fine. Now the worst thing that you could imagine from from a backup specialized device happened. Just at the moment when the external drive gets connected to the NAS via USB 2.0, the NAS DESTROYS all Data on external backup disk, BY AUTOMATIC PARTIONING the external drive into 2 GPT Partions (32GB, 4GB both Linux Raid Filesytem, and the rest remains unallocated).

Im a tech, and I've worked for mid size businesses, imagine that would happen with your valueable custumer data on an emergency roll back, this company would be dead for days may be longer. The companies I've worked for so far, has to have only one NAS and one external backup medium locked up in a safe. Imagine someone in that company comes with the idea to buy a new ReadyNAS Duo v2, and plug-in the last remainig backup (imagine that emergency situation), this is it...

Im very, very upset, because this is a real nasty killer bug, if public would know about ... I don't know...

By the way, I have tried different combinations, with GPT with out GPT (Primarypartions), all the same effect, that moment when the drive is connected, (it seems to me that) the NAS tries to convert the external storage into an internal X-Raid storage, but without any functionality. I had situations where the NAS reports an unkown filesystem and somtimes it assigns a USB drive with 32 GB free space. I've used an Intenso USB 3.0 1Tb for cross-checking that behaveior all tests runs fine on USB 3.0 as well as on USB 2.0.

All what's sad was sad in anger, so I'm not mad with you guys but that has to be fixed ASAP.

EDIT:
I also subseqently checked the external drive on a Linux OS (Kubuntu 10.10 live system), and the external drive works perfectly well, hence the drive controller itself could be removed from the list of possiblilties.
Message 1 of 2
vandermerwe
Master

Re: ReadyNAS Duo V2 USB2.0 Destroys DATA

The forums are not Netgear support.
You should contact Netgear support directly about this.
There is clearly a very unusual problem with your system.
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 3628 views
  • 0 kudos
  • 2 in conversation
Announcements