× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Re: ReadyNAS OS 6 Software Version 6.10.4

Jellen
Aspirant

ReadyNAS OS 6 Software Version 6.10.4

It looks like Netgear released new firmware. I don't see it yet when I check for updates on the devices itself but it's available for download: 

ReadyNAS-OS-6-Software-Version-6-10-4 

 

ReadyNAS OS V6.10.4 Release Notes:

 

Bug Fixes:

  • After configuring for IPv6/64, the actual configuration is IPv6/54
  • NFS client sees NFS volume capacity instead of NFS share quota limit
  • Rsync over SSH unable to back up sub volumes
  • Back up to remote rsync share fails
  • OneDrive is not in sync when file is removed from ReadyNAS
  • HTTPS certificate expires
  • Scroll bar is missing in share content browser
  • Dropbox sign in issue
  • Cannot setup Hotmail for alert
  • iTunes stops working with macOS Catalina or newer

Security Fixes:

  • Fixes security issues

This firmware addresses security vulnerabilities. For more information about security vulnerabilities, visit https://www.netgear.com/about/security.

Message 1 of 39
StephenB
Guru

Re: ReadyNAS OS 6 Software Version 6.10.4


@Jellen wrote:

It looks like Netgear released new firmware. I don't see it yet when I check for updates on the devices itself but it's available for download: 

ReadyNAS-OS-6-Software-Version-6-10-4 

That's their usual practice.  

 

I've installed it on a couple backup NAS with no problems.  

Message 2 of 39
givememynamebak
Luminary

Re: ReadyNAS OS 6 Software Version 6.10.4

Yah, I don't know why "their usual practice" isn't using their own channels in the software.  Beta, Stable & Long Term Support all return nothing for 6.10.4.  Netgear has gone severly down hill, I sure do miss the original Infrant days.  Netgear ruined a good thing by purchasing Infrant to begin with.  Sad.

Model: RN628X|ReadyNAS 628X - Ultimate Performance Business Data Storage - 8-Bay
Message 3 of 39
Sandshark
Sensei

Re: ReadyNAS OS 6 Software Version 6.10.4

They just release it outside the automatic update channel a little before hand.  They've never explained why, but there is no indication they aren't just doing that again.

Message 4 of 39
StephenB
Guru

Re: ReadyNAS OS 6 Software Version 6.10.4


@Sandshark wrote:

They just release it outside the automatic update channel a little before hand.  They've never explained why, but there is no indication they aren't just doing that again.


My guess is that it gives them a chance to see if there are any unexpected issues from early adopters before they push it out.

Message 5 of 39
Bogus
Tutor

Re: ReadyNAS OS 6 Software Version 6.10.4

Unexpected issues? I have one: none of the app icons are working.

I just updated ReadyNAS OS 6.10.3 to 6.10.4 and ... none of the app logos can be found. The path is now for example: https://192.168.0.236/apps/logo/mysqldb.png yet the file is found in /apps/mysqldb/logo.png. I think they switch variables...

This goes for all installed apps. The non-installed apps don't show logos either btw.

Model: RN204|ReadyNAS204 4-Bay
Message 6 of 39
StephenB
Guru

Re: ReadyNAS OS 6 Software Version 6.10.4


@Bogus wrote:

none of the app icons are working.

 


My apps icons are all showing up as usual - both for installed and uninstalled apps.  I checked this on an arm NAS (RN202) and a converted Pro-6 (x86).

 


@Bogus wrote:

The path is now for example:


I am seeing this for plex:

  • http://10.0.0.14/apps/logo/plexmediaserver.png (6.10.4 rn202)
  • https://10.0.0.15/apps/logo/plexmediaserver.png (6.10.3 rn526)

So the path looks the same to me (though I agree that /apps doesn't have a logo folder) -  but the http bit will be a problem for people who are accessing the NAS remotely.

 

@Marc_V , @JohnCM_S :  Can you see that this is logged or at least forwarded to development?

 

Message 7 of 39
Bogus
Tutor

Re: ReadyNAS OS 6 Software Version 6.10.4

Screenshot 2020-12-18 at 13.30.34.pngWeird huh?

Message 8 of 39
StephenB
Guru

Re: ReadyNAS OS 6 Software Version 6.10.4


@Bogus wrote:

Weird huh?


Yes - both the error, and the fact that my two systems are showing something different (but still potentially a problem).

 

Though on my systems, the x86 NAS (also on 6.10.4) is using https, only the arm system is using http.

 

I am wondering if the browser makes a difference (there could be some browser-dependent code in the NAS).  I checked with Chrome, but just confirmed that I see the icons with Chromium Edge as well.  What browser are you using?

 

 

Message 9 of 39
Bogus
Tutor

Re: ReadyNAS OS 6 Software Version 6.10.4

Both Safari and Chrome on macOS show the same 404 errors.

The http redirects to https. Do you know where I can turn that off, I can't seem to find it anymore, and I would like to test if I get the same error with http. I doubt it though.

What I find so 'interesting' is that the folder and app name have traded places:

https://192.168.0.236/apps/logo/mysqldb.png

while it should be:

https://192.168.0.236/apps/mysqldb/logo.png

just like:

/apps/mysqldb/logo.png. 

Message 10 of 39
StephenB
Guru

Re: ReadyNAS OS 6 Software Version 6.10.4


@Bogus wrote:

 

What I find so 'interesting' is that the folder and app name have traded places:

 


There is nothing new here - as I said earlier this is also the case with 6.10.3 and earlier firmware too.  If you look in /etc/frontview/apache/apps-https.conf, you'll find the logos are all aliased in apache.

 

For instance on my 6.10.3 system, the installed app logos are aliased as

Alias /apps/logo/plexmediaserver.png /apps/plexmediaserver/logo.png
Alias /apps/logo/smbplus.png /apps/smbplus/logo.png

Available apps are aliased as 

Alias /apps/logo/ajaxplorer.png /apps/.freeapps/ajaxplorer/logo.png
Alias /apps/logo/archiware-pure.png /apps/.freeapps/archiware-pure/logo.png
Alias /apps/logo/asterisk-app.png /apps/.freeapps/asterisk-app/logo.png
Alias /apps/logo/automatic.png /apps/.freeapps/automatic/logo.png
Alias /apps/logo/awpst-ngr.png /apps/.freeapps/awpst-ngr/logo.png
...

6.10.4 has the same aliases in apps-https.conf.

 

If you have ssh access, you might want to check this file.  FWIW, if you haven't tried rebooting the NAS and clearing the browser cache, you probably should do that first.

 


@Bogus wrote:

The http redirects to https.

You can enable http admin access in system->settings->http.

 

Redirection itself can be done in the apache server, but browsers also will automatically redirect to https if the service is available.  Any methods for managing that depend on the browser.

Message 11 of 39
Bogus
Tutor

Re: ReadyNAS OS 6 Software Version 6.10.4

There's definitely something weird with this update...

I figured it had to be the HTTP/HTTPS setting on the admin/ssytem/settings page, but it was greyed out. 

Also my transmission app had trouble connecting to the outside.

So I rebooted. 

I could login with HTTP again, no redirect. All the icons appeared.

I tried loggin in with HTTPS, it nagged a couple of times about an expired session and prompted me 4 times with the admin login and password. But eventually the admin page came up with all the icons in place!

Transmission works too, connecting etc.

Very strange.

 

So thank you Stephen for the execellent suggestion to just reboot 😄

Message 12 of 39
BaJohn
Virtuoso

Re: ReadyNAS OS 6 Software Version 6.10.4

Although a little late to the party, I noticed on my 'Upgarde' today that the system rebooted twice automatically, which I had never seen before on the NAS system.

..... and yes I am still alive ... avoiding teh Covid like a 'rabbit in headlights'.

 

Model: RN51600|ReadyNAS 516 6-Bay Diskless
Message 13 of 39
Limerick_fr
Guide

Re: ReadyNAS OS 6 Software Version 6.10.4

Hi all,

 

With the kind help of @StephenB I managed to setup a daily backup from my ReadyNAS to ann attached USB HDD few months ago.

It was been working smoothly since I updated from 6.10.3 to 6.10.4.

What is strange, is that the backup shows as completed wihin a second with the log stating it has been successful. But no change has been made to the destination HDD.

So I went back to 6.10.3 and then the backup works as perfectly as it was perfroming before the firmware update.

 

The trap is that, from the log, nothing is wrong with 6.10.4 but, in fact, it is.

 

I will keep this 6.10.3 until there is a 6.10.5 released to give it a try.

 

Lim.

 

Message 14 of 39
StephenB
Guru

Re: ReadyNAS OS 6 Software Version 6.10.4


@Limerick_fr wrote:

With the kind help of @StephenB I managed to setup a daily backup from my ReadyNAS to ann attached USB HDD few months ago.

It was been working smoothly since I updated from 6.10.3 to 6.10.4.

What is strange, is that the backup shows as completed wihin a second with the log stating it has been successful. But no change has been made to the destination HDD.

So I went back to 6.10.3 and then the backup works as perfectly as it was performing before the firmware update.

 

 


I am running 6.10.4 on my backup NAS (but not the main one yet).  The "pull" rsync backup jobs on those NAS are running correctly. 

 

If I have a chance over the holiday break, I'll try a few other tests and report back here.

Message 15 of 39
paulcarlucci
Aspirant

Re: ReadyNAS OS 6 Software Version 6.10.4

My "pull" rsync job is fine, but my "push" rsync job now instantly succeeds without doing any work as of 6.10.4.

Message 16 of 39
rn_enthusiast
Virtuoso

Re: ReadyNAS OS 6 Software Version 6.10.4

Hi @paulcarlucci 

 

Just out of interest, how is your Push job configured? Are you backing up your entire volume - i.e. the source is "data" and not a particular share?

 

Message 17 of 39
Limerick_fr
Guide

Re: ReadyNAS OS 6 Software Version 6.10.4

In my case, the source is indeed "data".

Message 18 of 39
bedlam1
Prodigy

Re: ReadyNAS OS 6 Software Version 6.10.4

My "push" backup of "data" also completes in 1-2 seconds but does not do anything.

I have reverted to OS 6.10.3 and all is well again.

Netgear need to fix this soon as I am sure there are hundreds or more users not aware of their backups being stalled

Message 19 of 39
rn_enthusiast
Virtuoso

Re: ReadyNAS OS 6 Software Version 6.10.4

Yea we have several reports of this now in configurations where:

- It is a Push backup

- The source is the volume, i.e "data" and not a specific share

 

@JohnCM_Sand @Marc_V  - Any updates on this? I myself have the same config and can't update to 6.10.4 for obvious reasons.

 

Thanks

Message 20 of 39
paulcarlucci
Aspirant

Re: ReadyNAS OS 6 Software Version 6.10.4

@rn_enthusiast indeed it is, in my case "data" is the entire volume getting rsync pushed to an off-site backup.
Message 21 of 39
BastianW
Aspirant

Re: ReadyNAS OS 6 Software Version 6.10.4

I have a strange issue here ... Since the upgrade to 6.10.4 my users can no longer delete some of my files/folders on the NAS. If they try that the Windows OS is saying that the files are in use...The issue also couldn´t be fixed with a NAS reboot or via Windows OS reboot.

 

Sometimes the folders disapear and if a user is trying to re-create them they got the error message that they are still in use somewhere else.

 

Is that only us?!?

Message 22 of 39
BastianW
Aspirant

Re: ReadyNAS OS 6 Software Version 6.10.4

Update:

 

When I create a new share and then click on the plus and try to assign some groups to the newly created share it failed ... nothing happened ... Can somebody reproduce that maybe as well?

 

Message 23 of 39
StephenB
Guru

Re: ReadyNAS OS 6 Software Version 6.10.4


@BastianW wrote:

Update:

 

When I create a new share and then click on the plus and try to assign some groups to the newly created share it failed ... nothing happened ... Can somebody reproduce that maybe as well?

 


What happens if you click on the share settings wheel, and make the changes there?

Message 24 of 39
BastianW
Aspirant

Re: ReadyNAS OS 6 Software Version 6.10.4

Hi Stephen,

thats working and seamed to solve the 2nd issue, so thanks for that. However we still struggle with various "you do not have rights" issues when deleting files or folders...

 

Whats also strange is that a user can create a new folder and get directly the error message "You need permissions to perform this action" bevore he can type in the name from the folder. However there is a so called "New Folder" created, but the users are unable to delete or rename the folder ... its also not possible to open the new folder and put files in it.

 

It looks like if old folders before the firmware update are not affected and are working. Moving a folder from a Windows PC to the NAS also caused the same affect. The folder then get right issues...

Message 25 of 39
Top Contributors
Discussion stats
  • 38 replies
  • 7558 views
  • 6 kudos
  • 13 in conversation
Announcements