Reply

UPS issue ReadyNas Duo IDialogplus Riello (IDP80)

kwanm3
Luminary

UPS issue ReadyNas Duo IDialogplus Riello (IDP80)

Just bought a Riello iDialogplus IDP80 and connected to my Readynas Duo.

However in Raidar and in Front view the Nas does not recognize that there is a UPS attached. It has the USB monitoring cable attached. However if I remove the USB cable, the logs detect that a UPS has been removed. Once I plug cable back in again it does not show in logs that a UPS has been attched, but again if disconnected it logs a UPS disconnect again.

Therefore the NAS must know it has a UPS attached, but is not logging correctly to show in Raidar or Frontview.

I appreciate that this UPS is not on the approved list, but also not on the incompatible list either. Is this a firmware issue or a setting I have missed. As I understand from the manual it should just be a case of connecting the power up to the UPS output and connect the USB monitoring cable and away you go.

I have tried to reboot once the UPS attached, but still the same.

Any help appreciated.
Message 1 of 4
NewAngel
Luminary

Re: UPS issue ReadyNas Duo IDialogplus Riello (IDP80)

Hi,

I'm searching to solve a similar problem but with an UPS IPEL/INFOSEC 1000 VA.
Idem not on compatibility list and not on icompatible list. My UPS is detected when I remove the USB cable. So I think we have a chance to make communicate UPS and DUO.
After search on web (a lot of hours), I've found DUO work with NUT software to monitoring UPS.
There's a compatability list of material support by NUT on http://www.networkupstools.org/compat/stable.html (RIELLO is not on, sorry...).

I've modified NUT's files (/etc/nut) to try to communicate with UPS, but I've a communicate error for each time.

In console mode, when I make :

nas:~# /etc/init.d/nut start
Starting Network UPS Tools: (upsdrvctl failed) upsmon.

I don't found info on upsdrvctl...

I've test some different driver but without result. By the past, I've uninstall NUTpackage and reinstall it with NUT-USB package, the list of drivers installed is more important but I don't f found the megatec driver (wich is for my UPS).

How install a specific driver on debian ?

Thanks for help

NewAngel
------------------------------------------------------------
NewAngel : new-angel@hotmail.fr
Suivez-moi sur Twitter / Follow me on Twitter : http://twitter.com/NewAngel_fr
------------------------------------------------------------
Merci à tous les développeurs pour votre travail / Thanks all developers for your work
Message 2 of 4
kwanm3
Luminary

Re: UPS issue ReadyNas Duo IDialogplus Riello (IDP80)

Is there no one from the Jedi Council about? Thought I might have had some kind of feedback on this issue. I can't believe that I and the other newbie have this issue with the readynas and UPS?? If this is a firmware bug then is anyone investigating?
Message 3 of 4
magomar
Luminary

Re: UPS issue ReadyNas Duo IDialogplus Riello (IDP80)

I am having the same problem with a Riello iPlug

This is very frustrating because I've been trying to find a UPS in the compatibility list in my county that was suitable to my needs without success. 😞

The ones I can find are too expensive for a domestic setup
Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 2560 views
  • 0 kudos
  • 3 in conversation
Announcements