Reply
kugodfather
Follower

Can't connect to Netgear Genie app using ios or ipad

I am using ios version 8.4.1 on my iphone and I have a C3700-NAS cable modem/router. I can connect using genie from my pc, but not from my apple devices. I can see the wireless network but cant log into the genie app. Is there something I need to turn on on the router?

Message 1 of 7
beebrat
Aspirant

Re: Can't connect to Netgear Genie app using ios or ipad

I am having the same issues.  It worked fine for the past year.  We moved and tried to hook it up and nothing Apple works.  PC and Android work just fine.  Can't figure out how to fix it.

Message 2 of 7
DarrenM
NETGEAR Moderator

Re: Can't connect to Netgear Genie app using ios or ipad

Are you guy using comcast xfinity because I am seeing reports of others on comcast with IOS devices not working and found that changing the DNS to googles DNS is fixing the issue. The DNS is 8.8.8.8 and secondary as 8.8.4.4. also linked a article on how to do this see if that lets the Apple devices to connect.

 

http://www.macinstruct.com/node/558

 

DarrenM

Message 3 of 7
Ozarkham
Initiate

Re: Can't connect to Netgear Genie app using ios or ipad

Same issue here with DGND3700 router DSL modem. Works fine on Mac but iphone tells me password is wrong and its the same one I'm using from the Mac and from the internet web page. 

Message 4 of 7
DexterJB
NETGEAR Moderator

Re: Can't connect to Netgear Genie app using ios or ipad

Hi @Ozarkham,

 

1. Was it working before?

2. Have you tried using another iOS device?

3. What is the iOS version of your iPhone?

4. Have you tried changing the router password?

 

Regards,

 

Dexter

Community Team

Message 5 of 7
Ozarkham
Initiate

Re: Can't connect to Netgear Genie app using ios or ipad

I had changed the password. I changed it back to the default, told my phone to forget the network, then signed back in. Now it works.
Message 6 of 7
-Mark-
Initiate

Re: Can't connect to Netgear Genie app using ios or ipad

Same issue.  Cannot logon from Genie running on the PC, cannot while using the Apple App.

 

I'm on the the latest v1.0.3.46_1.1.32 firmware as well.

 

I purchased the router for the same reason as well.  Parental controls. 

 

This needs to get fixed.  It's been out there as an issue way too long.  You really think I'm going to purchase another NetGear product if this is the kind of attention is spent to resolving issues?    Do I really have to fall back to an old-old-old firmware release?

 

Come on.  If I supported clients like this on in MY job I would be fired. 

 

 

Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 10510 views
  • 9 kudos
  • 6 in conversation
Announcements