Reply

Betreff: New Firmware v2.3.2.108 (XR500)

Netduma-Fraser
NetDuma Partner

Betreff: New Firmware v2.3.2.108 (XR500)

@A_F11 Is it plugged into a router/modem? If so on that give the XR a static IP and that should help.
Message 226 of 769
A_F11
Aspirant

Betreff: New Firmware v2.3.2.108 (XR500)

@Netduma-Fraser i will try that, thanks. Do you know when call of duty will get enabled filtering mode in geofilter?

Message 227 of 769
Netduma-Fraser
NetDuma Partner

Betreff: New Firmware v2.3.2.108 (XR500)

@A_F11 hopefully in the next build but you can give your device a PlayStation device type in Device Manager and add it to the Geo-Filter using the manual option and you will be able to filter properly.
Message 228 of 769
Raf1212
Apprentice

Betreff: New Firmware v2.3.2.108 (XR500)

@Netduma-Fraser I'm sorry to write this, I thought it would be fine, the router started to lose wifi and cable connections, so I restored the factory settings, I set a static ip, a few hours worked fine, now the internet disappears randomly again, the processors have 100 percent power, qos turns off by itself,

 

Message 229 of 769
Netduma-Fraser
NetDuma Partner

Betreff: New Firmware v2.3.2.108 (XR500)

Sorry to hear that @Raf1212 when you see the issue again could you do this please:

Access the debug page: http://192.168.1.1/debug.htm
Click “Enable WAN/LAN Packet Capture”.
Click "Start Capture".
After 5 minutes. Click “Save debug log”.
Send the debug log to @TimChang
Message 230 of 769
Oblius
Aspirant

Re: New Firmware v2.3.2.108

 
Message 231 of 769

Re: New Firmware v2.3.2.108

Is IPV6 currently working with this build or should I leave it disabled?

Model: XR500|Nighthawk Pro Gaming Router
Message 232 of 769
Rockemail
Aspirant

Re: New Firmware v2.3.2.108


@Brainbleach wrote:

Is IPV6 currently working with this build or should I leave it disabled?


It' s still broken. If you enable IPV6 may cause many issues.

Message 233 of 769
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.108

@Brainbleach as above if you have it enabled then QoS won't work correctly.
Message 234 of 769
Raf1212
Apprentice

Re: New Firmware v2.3.2.108

@Netduma-Fraser I wrote a debug log, today again in the evening the processors started working at 98 percent,I wrote to @TimChang,I'm waiting for a reply, because I don't know how to send him these logs, they are zip files

Message 235 of 769
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.108

@Raf1212 that's great, thank you for doing that. If you upload to dropbox and give him the link that should be fine.
Message 236 of 769
Iamcity
Tutor

Re: New Firmware v2.3.2.108 (XR500)

I NEED HELP DOWNLOADING THE NEW FIRMWARE

Model: XR500|Nighthawk Pro Gaming Router
Message 237 of 769
Iamcity
Tutor

Re: New Firmware v2.3.2.108

WHERE IS THE FILE TO DOWNLOAD?

Message 238 of 769
kxndal
Guide

Betreff: New Firmware v2.3.2.108 (XR500)

Message 239 of 769
kxndal
Guide

Betreff: New Firmware v2.3.2.108 (XR500)

Sry for the late Reply. Just Wifi Devices!
Message 240 of 769

Betreff: New Firmware v2.3.2.108 (XR500)

Tbh, I couldn't even get IPv6 to work with QoS off and custom DNS settings.  It would work if I used my ISP dns but not when I tried to use cloudflare.

Model: XR500|Nighthawk Pro Gaming Router
Message 241 of 769
mardock2009
Guide

Betreff: New Firmware v2.3.2.108 (XR500)

Hi

Possible to connect Hybryd VPN to my private openvpn on linux dedicated server no need there login and password ?

because I only have options pure and hidemyass ,in advanced settings I added settings from file .ovpn but still need login password ?

 

Firmware beta108 Without ipv6 and vpn issue all working perfect I just miss appstore adblock.....

Thank you

mardock2009
Model: XR500|Nighthawk Pro Gaming Router
Message 242 of 769
Netduma-Fraser
NetDuma Partner

Betreff: New Firmware v2.3.2.108 (XR500)

Thanks @Brainbleach, @TimChang can you take a look at this issue regarding DNS?

@mardock2009 If you can generate an OpenVPN configuration file from the server then in theory yes and you could leave the login details blank, if it requires them then could you set that up when generating a config?
Message 243 of 769
mardock2009
Guide

Betreff: New Firmware v2.3.2.108 (XR500)

Thank you for quick reply

I reconfigured openvpn to use login and password for auth my server linux ubuntu working but router cant connect...

my client config for linux server ... what do I have to change to make it work on the router ?

client
proto udp
remote secret-IP 1070
dev tun
resolv-retry infinite
nobind
persist-key
persist-tun
tls-client
tls-auth /etc/openvpn/client/ta.key 1 ------------ in router I don't know where to put it
cipher AES-256-CBC
auth SHA1
auth-user-pass /etc/openvpn/auth.txt  ---------  in router remove
remote-cert-tls server
auth-nocache
verb 3
<ca>
-----BEGIN CERTIFICATE-----
...my secret certyficate
-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----
...my secret certificate
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
...my secret key
-----END PRIVATE KEY-----
</key>

 

login and pass i have in file

 auth-user-pass /etc/openvpn/auth.txt - for router remove this line and add login and pass on top

 

i have error in router debug log

Thu Dec 31 14:50:17 2020 OpenVPN 2.4.3 arm-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Nov 23 2020 Thu Dec 31 14:50:17 2020 library versions: OpenSSL 1.0.2n 7 Dec 2017, LZO 2.06 Thu Dec 31 14:50:17 2020 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts Thu Dec 31 14:50:17 2020 Insufficient key material or header text not found in file '[[INLINE]]' (0/128/256 bytes found/min/max) Thu Dec 31 14:50:17 2020 Exiting due to fatal error

 

I'm not an openvpn expert but it should work in theory

thanks

 

 

mardock2009
Model: XR500|Nighthawk Pro Gaming Router
Message 244 of 769
mardock2009
Guide

Betreff: New Firmware v2.3.2.108 (XR500)

update

after this settings:

####################################################

client
proto udp
remote ip 1194
dev tun
resolv-retry infinite
nobind
persist-key
persist-tun
tls-client
cipher AES-256-CBC
auth SHA1
remote-cert-tls server
auth-nocache
verb 3
key-direction 1
<tls-auth>
-----BEGIN OpenVPN Static key V1-----
secret
-----END OpenVPN Static key V1-----
</tls-auth>
<ca>
-----BEGIN CERTIFICATE-----
secret
-----END CERTIFICATE-----
</ca>
<cert>
-----BEGIN CERTIFICATE-----
secret
-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----
secret
-----END PRIVATE KEY-----
</key>

 

i have try connection

router log

Thu Dec 31 15:16:06 2020 OpenVPN 2.4.3 arm-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Nov 23 2020 Thu Dec 31 15:16:06 2020 library versions: OpenSSL 1.0.2n 7 Dec 2017, LZO 2.06 Thu Dec 31 15:16:06 2020 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts Thu Dec 31 15:16:06 2020 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication Thu Dec 31 15:16:06 2020 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication Thu Dec 31 15:16:06 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]right  openvpn ip:1194 Thu Dec 31 15:16:06 2020 Socket Buffers: R=[163840->163840] S=[163840->163840] Thu Dec 31 15:16:06 2020 UDP link local: (not bound) Thu Dec 31 15:16:06 2020 UDP link remote: [AF_INET]right opnevpn ip:1194

Thu Dec 31 15:17:06 2020 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity) Thu Dec 31 15:17:06 2020 TLS Error: TLS handshake failed Thu Dec 31 15:17:06 2020 SIGUSR1[soft,tls-error] received, process restarting Thu Dec 31 15:17:06 2020 Restart pause, 5 second(s)

mardock2009
Model: XR500|Nighthawk Pro Gaming Router
Message 245 of 769
mardock2009
Guide

Betreff: New Firmware v2.3.2.108 (XR500)

ok openvpn working now but only non standard tcp port , udp 1194 ist blocked by firewall in router that's why I couldn't connect.

SOLVED

mardock2009
Model: XR500|Nighthawk Pro Gaming Router
Message 246 of 769
Codester3388
Tutor

Re: New Firmware v2.3.2.108 (XR500)

Been using the last couple versions and haven't had too many issues really other than the devices appearing offline which looks like it is a work in progress. In general, it's not an issue but it's nice to know what device is using up bandwidth as the ones appearing offline but still connected won't show in the network snapshot. I haven't had a chance to set QOS up with the help of Connection Benchmark but I'll get around to it. The software has really matured since I bought the R1 back in 2014. Can't wait for this version to release. 

Message 247 of 769
mrbuckwheet
Initiate

Re: New Firmware v2.3.2.108 (XR500)

Officially jumped ship on the xr500 and bought a new asus GT-AX11000. With all of the issues with firmware, horrible support for updates, and the amount of time that has passed waiting for "the new 3.0" with no clear eta and god knows how many more problems there will be once the full release comes out i will no longer support netgear/duma products. My decision comes from simple accountability and the realization that companies do not care about customers like they used too. The only way they will understand is to show them with $$. The new router was $400. This is money that could have gone to Netgear for future products, add ons or even accessories. I will never purchase another netgear product ever again. Hopefully other people will have this realization as well. Netgear does not support the work this dumaOS team is doing and probably never will. My new router runs flawlessly and with fios gigabit I'm finally getting my 950+ up and down speeds I'm paying for with out any disconnects/restarts. Sorry but I'm getting the sense its just you and you alone working on this software/firmware and my confidence with this product having real support in the long run is nonexistent. Netgear left you and dumaOS on the sideline but noone is saying anything about it.
Message 248 of 769
Iamcity
Tutor

Re: New Firmware v2.3.2.108 (XR500)

I too also have the xr500 and i regret buying it. Ever since I downloaded the beta 3.0 I've started having so much issues. they've been talking about 3.0 for over a year straight and cannot even get the firmware right. They still havent released the finsih product yet. I paid 250 dollars for my router and i can say it was a waste of time. It'll be a long time before i spend that type of money on another router. I'm definetly not buying another Netgear product for damn sure. The fact that you have to pay for customer service is the most rediculous thing I've ever heard.

Model: XR500|Nighthawk Pro Gaming Router
Message 249 of 769
Raf1212
Apprentice

Re: New Firmware v2.3.2.108 (XR500)

@Iamcity ,@mrbuckwheet ,I understand you well, I'm also waiting for a good product, I would also like to replace you, I have plans for tp-link archer or asus

 

Message 250 of 769
Announcements

Orbi WiFi 6E