Reply

Re: New Firmware v2.3.2.120 (XR500)

BIG_DOG
Luminary

Re: New Firmware v2.3.2.120 (XR500)

Hi @Netduma_Alex @Netduma-Fraser 

 

Dug out my XR500 and added this new firmware and it is looking well.  Nice to see some love for the XR500. Everything is running fine, I cannot test ipv6 as my isp does not support it yet. 

Model: XR500|Nighthawk Pro Gaming Router
Message 101 of 412
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

@Jamstaaa can you disable IPv6 please, follow the instructions Tim provided, then re-enable it. When you then notice that it has broken, get the logs and send them to Tim please?
@crmontoy1 can you also follow the steps from Tim please so we can try to narrow down the disconnect issues? I've let the team know about Fifa for heatmap and they will update it - please try it again in a few days. I generally don't recommend to use Ping Assist but if you want to use it I would suggest 40ms.
@Dumauser3348493 what speeds do you usually get and what are you getting now?
@BIG_DOG great to hear that BD, thanks for the feedback!
Message 102 of 412

Re: New Firmware v2.3.2.120 (XR500)

400/down
20/up

Currently getting 120/down over wifi. Disabling qos didn't really help.

I'm gonna try a factory reset from the button and this time I won't enable ipv6 and see if it's corrects the issue.

Message 103 of 412
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

Okay keep us posted!
Message 104 of 412
spdsk8race
Apprentice

Re: New Firmware v2.3.2.120 (XR500)

Well since my downgrade and update etc etc, I am still having disconnects but only once a day now. Will start capturing logs again to see if a new log will help identify it.

Message 105 of 412
Xolhid
Apprentice

Re: New Firmware v2.3.2.120 (XR500)

@TimChang
It would have been nice to do all that if the router was accessable. As I already explained to your coworker when the internet dropped out it was as if the router crashed. It was unresponsive to any way I tried to access it. I don't know how you expect me to gather logs for you when it's not responding at all.
Message 106 of 412
TimChang
NETGEAR Employee

Re: New Firmware v2.3.2.120 (XR500)

Hi @Xolhid,

Okay I see. So only way to recover the device is to reboot the XR500?

Do you have same issue in previous beta version of V2.3.2.114? And did it happen every time within 24 hours?

Can you still help us to collect the debug log after the reboot, we still can look into it and see if any useful information.

BTW, would you also please provide the serial number of XR500, which is in a label that attached in the bottom.

Message 107 of 412
TimChang
NETGEAR Employee

Re: New Firmware v2.3.2.120 (XR500)

@Jamstaaa 

Would you please help to provide the debug logs?

      0. Make sure you've reproduced the issue.

  1. Open the web browser via a PC, go tohttp://routerlogin.com/debug.htm
  2. Click “Enable LAN/WAN Packet Capture”
  3. Click “Start capture”, and wait for 30 seconds.
  4. Click “Save Debug log”.
  5. Send the log to us.
Message 108 of 412
Netduma-Liam
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

OK, thank you. Let us know if you can capture a log with anything useful!

Message 109 of 412
crmontoy1
Guide

Re: New Firmware v2.3.2.120 (XR500)

.@timchang i want send this capture, I wrote before that my devices lost the internet completely 20 mins later after the upgrade(sunday)!! But im not at home everyday checking just in the night so I don’t know if something wrong happened mean time I wasn’t at home... so i wanna help maybe you can check and fix the issues ASAP or perhaps only happened once to me (Disconnections)

If you give me the steps!! Ill be able to send the logs to you
Message 110 of 412
Jamstaaa
Guide

Re: New Firmware v2.3.2.120 (XR500)


@TimChang wrote:

@Jamstaaa 

Would you please help to provide the debug logs?

      0. Make sure you've reproduced the issue.

  1. Open the web browser via a PC, go tohttp://routerlogin.com/debug.htm
  2. Click “Enable LAN/WAN Packet Capture”
  3. Click “Start capture”, and wait for 30 seconds.
  4. Click “Save Debug log”.
  5. Send the log to us.

@TimChang 

I already reset it now so next time IPv6 fails I'll do that.

This still doesnt explain why IPv6 isnt working natively though. Why is the router only working using IPv6to4 and not authenticating with Sky via IPv6 when its avaliable and works fine with my Sky hub on the same line?

Message 111 of 412
Jamstaaa
Guide

Re: New Firmware v2.3.2.120 (XR500)

@Netduma-Fraser @TimChang 

Yet another problem with IPv6. When downloading on Steam my speed was fluctuating betweem 800kbps & 2.5MB/s. As soon as I disabled IPv6 on my NIC download shot straight up to the 9MB/s it should be.

Message 112 of 412
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

@Jamstaaa can you get those logs over to Tim and do a speed test while the log is capturing please with IPv6 enabled.
Message 113 of 412
Jamstaaa
Guide

Re: New Firmware v2.3.2.120 (XR500)

@Netduma-Fraser 

Speed tests show the correct speeds it just seems to be downloads from sites like Steam, Google play etc

Message 114 of 412

Re: New Firmware v2.3.2.120 (XR500)

Ok
So I've reset through the hard button. Rebooted. But the download speeds over wifi are still not full speed. Speedtest.net show 40-80mbps over wifi. Should be 400mbps. Lan connection speeds are fine.
Message 115 of 412
Netduma-Liam
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

What speeds are you seeing in Connection Benchmark? Do they appear to be full speeds?

Message 116 of 412

Re: New Firmware v2.3.2.120 (XR500)

Connection benchmark shows 400mbps over wifi. Kinda strange.
Message 117 of 412
stridahtv
Aspirant

Re: New Firmware v2.3.2.120 (XR500)

Maybe stupid question but can anyone point me in the direction of how to install these?

Message 118 of 412
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

@Dumauser3348493 CB tests directly from the router so it won't change whether you're connected via ethernet or wifi. Are you using smart connect or was that direct to 5GHz?

@stridahtv download the file, then go to the router interface - type routerlogin.net into your browser, go to Settings > Administration > Firmware Update and upload the file there.
Message 119 of 412

Re: New Firmware v2.3.2.120 (XR500)

Smart connect disabled. Testing on 2.4ghz.

Ping under load was unusually high. +40ms dl
Message 120 of 412
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

Can you test via 5GHz please and see what you get? CB we're still improving so I wouldn't focus on that result too much at the moment
Message 121 of 412

Re: New Firmware v2.3.2.120 (XR500)

Just tested and received 338mbps/download which is about right.

Something is up with 2.4ghz
Message 122 of 412
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

Use a WiFi analyzer and find the least congested channels and change to that - there may be quite a few networks in your area - see if speeds are better then. Also set out the antennae like this _ | | _
Message 123 of 412

Re: New Firmware v2.3.2.120 (XR500)

I actually did that before. It doesn't help. My area isn't overly contested and it's only a problem on this firmware. Not on 108.
Message 124 of 412
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

Disable 20/40 co-existence and see if it is any better
Message 125 of 412
Announcements