Reply

Re: New Firmware v2.3.2.120 (XR500)

Re: New Firmware v2.3.2.120 (XR500)

I also recently upgraded to beta 3.0 and am now getting frequent internet drops. What are the steps to downgrade?
Message 401 of 558
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

@ivanrei I believe the Content Blocking only applies to HTTP which of course isn't as helpful unfortunately as most sites now use HTTPS.

@Alittlegrumpy did you do a factory reset after the upgrade?
Message 402 of 558

Re: New Firmware v2.3.2.120 (XR500)

Yes, I did a factory reset after updating. It's been a couple weeks.
Message 403 of 558

Re: New Firmware v2.3.2.120 (XR500)

Yes I did a factory reset after updating. It's been a couple weeks
Message 404 of 558
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

What is the model of the modem/router the XR is connected to? Are ALL devices disconnecting at the time?
Message 405 of 558

Re: New Firmware v2.3.2.120 (XR500)

Coda 4582. It was perfectly fine until the update. Yes, all devices disconnect
Message 406 of 558
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

Is the XR in the DMZ of the Coda? Are all devices connected to the XR? Can you set a static IP on the Coda for the XR please and see if it is more stable?
Message 407 of 558
brandoff7
Star

Re: New Firmware v2.3.2.120 (XR500)

Just had an internet drop on .120 Beta on XR500.

 

It wasn't a full internet drop but the XR500 refused to pass any DNS queries.

 

Could ping out to the internet 1.1.1.1, 8.8.8.8, Carrier DNS & Gateway but no DNS traffic was passing for approx 5 minutes. nslookups failed for 4 servers: 1.1.1.1, 8.8.8.8, 202.142.142.142 & 202.142.142.242.

XR500 was accessible & functional during this. I did not reboot the device, functionality restored on it's own.

 

Packet capture was not running but I've uploaded the Debug Log to OneDrive and I've sent a private message to Tim Cheng with the zip of logs.

Model: XR500|Nighthawk Pro Gaming Router
Message 408 of 558
brandoff7
Star

Re: New Firmware v2.3.2.120 (XR500)

Ok, DNS drop just happened again within 40 minutes of last episode. Have rebooted the XR500 now to fix issues and I Was able to capture some LAN & WAN PCAP's. Uploading to OneDrive & Sending to Tim.

 

Here's what was happening...showing Layer 3 to the internet was up but DNS was being stopped. You'll see DNS is not looking up and DNS lookup is failing.

 

C:\Users\Brandon>ping 1.1.1.1

Pinging 1.1.1.1 with 32 bytes of data
Reply from 1.1.1.1: bytes=32 time=10ms TTL=59

Ping statistics for 1.1.1.1:
Packets: Sent = 1, Received = 1, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 10ms, Maximum = 10ms, Average = 10ms
Control-C
^C
C:\Users\Brandon>ping google.com
Ping request could not find host google.com. Please check the name and try again.

C:\Users\Brandon>nslookup
DNS request timed out.
timeout was 2 seconds.
Default Server: UnKnown
Address: 1.1.1.1

 

Hopefully reboot stabilises things today.

Model: XR500|Nighthawk Pro Gaming Router
Message 409 of 558
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

Thank you for passing it on to Tim, hopefully NG are close to resolving this fully now.
Message 410 of 558
Philippe2021
Tutor

Re: New Firmware v2.3.2.120 (XR500)

Hello,

 

It would be good to fix the following issue which is not fixed in the 120 version: two LOCAL computers whatever they are cannot get connected by ssh if one of them is connected by wifi to the router. Everything works fine if the two computers are connected to the router by an ethernet cable. It seems that the wifi blocks ssh and therefore the port 22. There is no reason for that.

 

Please fix this issue, thanks.

 

Message 411 of 558
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

It's not just specific to SSH, it occurs as well if they just trying to connect to each other regardless. The team are aware so will see what is going on.
Message 412 of 558
LiLAsN
Star

Re: New Firmware v2.3.2.120 (XR500)


@brandoff7 wrote:

Just had an internet drop on .120 Beta on XR500.

 

It wasn't a full internet drop but the XR500 refused to pass any DNS queries.

 

Could ping out to the internet 1.1.1.1, 8.8.8.8, Carrier DNS & Gateway but no DNS traffic was passing for approx 5 minutes. nslookups failed for 4 servers: 1.1.1.1, 8.8.8.8, 202.142.142.142 & 202.142.142.242.

XR500 was accessible & functional during this. I did not reboot the device, functionality restored on it's own.

 

Packet capture was not running but I've uploaded the Debug Log to OneDrive and I've sent a private message to Tim Cheng with the zip of logs.



Ah... So you also faced the same problem as me. So it was a DNS issue that caused my Amazon Alexa to go haywire during that time.

Ok. So let me reiterate my previous post where I posted the solution that worked for me.

What I had to do was shut down all my devices that will be connected to the router, be it TVs or Home Automations, WiFi Extender....

Then I proceeded to shut off the router for 10 minutes. After that, I will power the router back on. Then slowly my PC to check whether the router has finished its boot up. And then I turned on all the devices that I want connected to the main router followed by my Netgear WiFi Extender which has a ridiculously long boot time of 3 minutes and then the devices that would be connected to that.

It solved my constant issues of internet dropouts which you have helped explained which was caused by some DNS query issues.

But once in a while, if the router was rebooted, I run the risk of the same internet drop out issue coming back. Though it won't be as bad as that initial one that I faced.

And no. To those who upgraded to .120 and face this Internet dropout issue, downgrading will not make this issue go away. So you can follow the steps I did to help resolve it. I just couldn't reset the router. Not with the growing number of Home Automation where I give each of them a static IP address. Nobody has the time to sit down on a computer typing away a long list of devices with Static IP Addresses.


I just wish that the router could just work without needing my intervention every other week. Every DumaOS reiterations including the Stable Public Ones has some sort of quirk. Like for my case, when I use my phone connected to WiFi after a long time of my phone being idle, sometimes, the apps will not have access to the internet. So I would have to turn off and turn on the WiFi on my phone in order to finally let the app have a stable connection to the internet via WiFi. And this issue has been prevalent since even the stable version of DumaOS. Anyone has any solution to this issue? Will be much appreciated.

Message 413 of 558
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

@LiLAsN regarding your last issue, turn off Private Addresses on the SSID settings for the router on the phone itself and see if it is more stable
Message 414 of 558
LiLAsN
Star

Re: New Firmware v2.3.2.120 (XR500)


@Netduma-Fraser wrote:
@LiLAsNregarding your last issue, turn off Private Addresses on the SSID settings for the router on the phone itself and see if it is more stable

Thanks for the really quick reply. But I am not using an iPhone though. No such settings on my phone. Similarly, this issue has been around for years. So Samsung Note 7, Note 9, Note 10+ all had this issue.

Message 415 of 558
AlaKru
Initiate

Re: New Firmware v2.3.2.120 (XR500)

Went back to 114 after updating to 120. Frequent dropouts returned on version 120 that 114 had cleared up

Message 416 of 558
brandoff7
Star

Re: New Firmware v2.3.2.120 (XR500)

How are we going with the next beta version? Super keen to get more stability & fixes!
Model: XR500|Nighthawk Pro Gaming Router
Message 417 of 558
Raf1212
Apprentice

Re: New Firmware v2.3.2.120 (XR500)

@brandoff7 I already gave it a rest with beta, now I went to see what's going on, and I see that for 3 months nothing a single version has probably abandoned xr500, and I tested the 207 version on R1 netduma and the same problems, so I see that it is the fault of the hardware only software

Message 418 of 558
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

@LiLAsN try creating a guest WiFi network for the devices to connect to and see whether they are more stable.

@brandoff7 shouldn't be much longer hopefully!
Message 419 of 558
Philippe2021
Tutor

Re: New Firmware v2.3.2.120 (XR500)


@Netduma-Fraser wrote:
It's not just specific to SSH, it occurs as well if they just trying to connect to each other regardless. The team are aware so will see what is going on.

Indeed, it's the same problem for samba. They work by ethernet and not by wifi. Something must be fixed in DumaOS.

Message 420 of 558
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

Likely for Netgear but we'll get on it!
Message 421 of 558
Philippe2021
Tutor

Re: New Firmware v2.3.2.120 (XR500)


@Netduma-Fraser wrote:
Likely for Netgear but we'll get on it!

And nfs either ! samba, nfs, ssh do not work with one of the PCs connected by wifi and everything works fine as soon as the two PCs are plugged to the XR500 by an ethernet cable. And only if the XR500 is configured as a router. When it is configured in AP mode, everything is normal. I hope my message will be helpful ;-).

Message 422 of 558
Patsalos97
Aspirant

Re: New Firmware v2.3.2.120 (XR500)

where can i found the duma os 3.0 update file for xr500?

Model: XR500|Nighthawk Pro Gaming Router
Message 423 of 558
Netduma-Fraser
NetDuma Partner

Re: New Firmware v2.3.2.120 (XR500)

@Patsalos97 it's the first post of this topic
Message 424 of 558

Re: New Firmware v2.3.2.120 (XR500)

Hey @Alittlegrumpy I have a different router than you do (R800P) but have constant issues installing prompted firmware upgrades.  I've had buffering and complete dropping of my wifi since purchasing in Sept of 2020, when I also purchased a Netgear modem and the extended tech support (save your money if you haven't already purchased this).  I recently learned that my Netgear router is under constant DoS attack.  None of the recommended steps would stop it, so they sent me a replacement that was supposed to be new but is used and has the exact same problem.  Log in to the back end and check your router log.  I am wondering if there is a bigger security issue with these routers.  Netgear has proven themselves to be a joke both with product and support.  Good luck!

 

 

Message 425 of 558
Announcements