Reply

New - XR450/XR500 Firmware Version 2.3.2.130 Released

FURRYe38
Guru

New - XR450/XR500 Firmware Version 2.3.2.130 Released

New FW for XR450 and XR500 has been released for those who want to try.

Please post your experiences in this thread please:

https://community.netgear.com/t5/Nighthawk-Pro-Gaming-Routers/New-XR450-XR500-Firmware-Version-2-3-2...

 

Good Luck. 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.3.5(Router mode/LAG Disabled) & EX7700x2
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK953(v6.0.3.68) & XR450(v130), RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, and WNHDE111
Message 1 of 66
mathmath51
Apprentice

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

Can you share your feedback compared to the latest beta version when you'll get the chance please ?

I'm not sure I want to dust it off and plug it again honestly...

 

Thanks

Model: XR500|Nighthawk Pro Gaming Router
Message 2 of 66
FURRYe38
Guru

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

Well what is the reason for not using yours? 

If your not using it now then it maybe time to give it a try. Wouldn't hurt. 

 

I'll be loading my XR450 up today maybe and will be testing it out over the weekend. 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.3.5(Router mode/LAG Disabled) & EX7700x2
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK953(v6.0.3.68) & XR450(v130), RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, and WNHDE111
Message 3 of 66
Raf1212
Apprentice

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

@FURRYe38 My dust is in my cupboard, I have had a new internet 2gb orange france for a few weeks, and as far as I know xr500 does not support such speeds and does not have an aggregation port, because livebox5 has 2gb divided by 1gb per port, so thank you, and when will there be a list of corrections as for version 120

Message 4 of 66
Philippe2021
Guide

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released


@mathmath51 wrote:

Can you share your feedback compared to the latest beta version when you'll get the chance please ?

I'm not sure I want to dust it off and plug it again honestly...

 

Thanks


Some observations:

  1. The wifi issue is not solved (this issue is only in router mode, not in AP mode !): NFS, Samba, SSH and other services are still not working by Wifi; for example even if I try from my PC laptop to open the http server of my NAS, that does not work; It's not a DumaOS issue, it's a Netgear issue and Netgear does not care about selling unfinished products (it's quite a old issue ! And yes I did not forget a factory reset)
  2. Still no adblockers (DumaOS)
  3. New things like ping heatmap; I let other people talking about that.
Model: XR500|Nighthawk Pro Gaming Router
Message 5 of 66
Netduma-Liam
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

Thanks for feeding back @Philippe2021. I've made a note of this and passed it upwards, we'll make the guys at Netgear aware of any bugs you guys report with this firmware, new or old.

 

Currently none of the routers in the NPG line-up have Adblocker, we are discussing it with Netgear though so it may be coming in a future firmware.

 

Message 6 of 66
FURRYe38
Guru

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

Correct, The XR300, 450 and 500 are limited by there 1Gb WAN/LAN ports an no LAG support. So you'll be limited by this router. 

IF your going to keep 2Gb for your WAN service, then you may want to get into a different router that supports 2Gb WAN speeds. 

 


@Raf1212 wrote:

@FURRYe38 My dust is in my cupboard, I have had a new internet 2gb orange france for a few weeks, and as far as I know xr500 does not support such speeds and does not have an aggregation port, because livebox5 has 2gb divided by 1gb per port, so thank you, and when will there be a list of corrections as for version 120


 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.3.5(Router mode/LAG Disabled) & EX7700x2
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK953(v6.0.3.68) & XR450(v130), RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, and WNHDE111
Message 7 of 66
Fubar__
Guide

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

I just updated my XR500, through firmware update in router menu. And did a factory rest.

My internet connection is 1000/1000 Mbps.This speed is what i got with previous firmware 2.3.2.120.

My download speed is still the same, but my upload speed is lowered to 100 Mbps. Tested with different providers on speedtest.net

QOS on/off, congestion at 100% no difference.

Does anyone else have the same problem with lower upload speeds?

 

 

 

 

 

 

Message 8 of 66
Netduma-Fraser
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

Weird its specifically 100Mbps like it's limited in some way, can you try using a different cable please?
Message 9 of 66
Phantomblu
Apprentice

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

 


@Fubar__ wrote:

I just updated my XR500, through firmware update in router menu. And did a factory rest.

My internet connection is 1000/1000 Mbps.This speed is what i got with previous firmware 2.3.2.120.

My download speed is still the same, but my upload speed is lowered to 100 Mbps. Tested with different providers on speedtest.net

QOS on/off, congestion at 100% no difference.

Does anyone else have the same problem with lower upload speeds?

 

 

 

Installed the new version with reset and I must say that for now I have not had any problem except for the fact that there is always the problem of displaying ping servers on the right in Ping Heatmat, there are no more servers for Modern Warfare, maybe no longer supported?

 

 

 

 


 

Model: XR500|Nighthawk Pro Gaming Router
Message 10 of 66
Netduma-Fraser
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

@Phantomblue Modern Warfare has been removed probably for the foreseeable future. Warzone has been temporarily moved and you can see why here: https://twitter.com/NETDUMA/status/1448334413771718664 it also appears Vanguard is doing the same thing as it was working less than 24 hours ago when we made the update.
Message 11 of 66

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

TLDR: I have had minimal issues so far but nothing that hinders the output of my XR450, the changes have been an incredible improvement from before and the transition was seemless.

  • The Dashboard is more responsive and way faster but I still get the message "Uncaught TypeError: Cannot read properties of null (reading 'normprop')" and I still have to mini boxes at the bottom with the clockwise-moving loading white circle. 
  • I love the new Geo-Filter as it works a lot better than before and the polygon mode is huge. My only problem is the map and trying to work it. I think an option should be added so that you have to turn it on before you can change the map and then turn it off so that you don't accidently move it. It doesn't quite work like Google maps where it zooms where you point, it seems to be random but the ability to drag and move the map makes it fairly easy to get where you want it. 
  • The ping heatmap seems to be working fine, had troubles yesterday with Vanguard and finding servers close to me, sometimes they would show, sometimes not, but that may be on their end with their servers and myself not wanting to play at a high ping. Two days ago, it was working flawlessly so it must be on their side. 
  • I have had no problems with Wifi or any device that is connected.
  • My download/upload speeds are great, pretty much the same as before.
  • My PingPlotter graph has actually shown significant improvement without changing any settings. 
  • QOS is working fine, way better than before.
  • Traffic prioritization took a hot minute but I figured out that if I added my PS5 as a games console and turned off the default DumaOS classified games that my speeds were greatly improved verses using both or just the default. 
  • Connection benchmark is awesome but when it is testing speed, I am not sure if it is testing the full speed or just the speed after the QOS is setup where you have, for example, the QOS set at 70% so your speeds are based off of that 70% but it rates your speed as if it's comparing you to the full 100% so it thinks you are getting 30% less.
  • The device manager is nice, it's a lot easer to read every device name. 
  • Network monitor has shown improvements to the network snapshot though it no longer says the bandwidth amounts that the devices are using. Also the bottom left of the x-axis populates the names of devices but it cuts off the name of anything more than 3-4 characters long. 
  • I have yet to use the Traffic Controller but once I figure out how I want to implement it, if at all, then I will add my thoughts and results on that.
  • I don't use Hybrid VPN but I am considering buying one, I am just not sure if it will help. If I choose to get one, I will be sure to add the results and my thoughts.
  • System Information is a lot faster at loading. I still seem to get a lot of [admin login] from source ... it's always my computer. I have also noticed the following that seems to occur several times a day, occuring in reverse order but this is how it shows and it's always the same 7:
    •  [DumaOS] Cloudsync DPI result 'nil','failed to sync'
    • [DumaOS] Cloudsync DPI 'skipping mirror'
    • [DumaOS] Cloudsync DPI 'HTTP sync failed'
    • [DumaOS] HTTP download failed with code '404'
    • [DumaOS] The selected theme does not exist: 'default'
    • [DumaOS] Theme path does match manifest 'default'
    • [DumaOS] Cloudsync Themes result 'false','All mirrors are down'
  • No problems with most of the settings. I tried turning on UPnP but it still doesn't work, or at least I never saw it working. I'm not sure if it is in the background but nothing populated. 
Message 12 of 66
Netduma-Fraser
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

Thanks for the feedback! What web browser are you using to access the interface? I explained why Vanguard isn't showing servers on heatmap in the post just above yours. The speed part doesn't take account of QoS at the moment and the rest does. The router checks whether there are any new cloud updates, for Geo-Filter, Heatmap and general DPI related things and that's what you're seeing in the log there.
Message 13 of 66

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

Awesome, thank you. As for the heatmap, it mostly shows but if it doesn't, it eventually shows after trying it 3-4 times. 

Message 14 of 66
FURRYe38
Guru

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

Heres what I got with my XR450:

https://community.netgear.com/t5/Nighthawk-Pro-Gaming-Routers/New-XR450-XR500-Firmware-Version-2-3-2...


@Fubar__ wrote:

I just updated my XR500, through firmware update in router menu. And did a factory rest.

My internet connection is 1000/1000 Mbps.This speed is what i got with previous firmware 2.3.2.120.

My download speed is still the same, but my upload speed is lowered to 100 Mbps. Tested with different providers on speedtest.net

QOS on/off, congestion at 100% no difference.

Does anyone else have the same problem with lower upload speeds?

 

 

 

 

 

 


 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.3.5(Router mode/LAG Disabled) & EX7700x2
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK953(v6.0.3.68) & XR450(v130), RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, and WNHDE111
Message 15 of 66
View9
Guide

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

Does QOS work with IPv6 in this new update? Is there a changelog i can have a look at prior to upgrading?
Model: XR500|Nighthawk Pro Gaming Router
Message 16 of 66

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

Everything was working fine until yesterday when the XR450 started to have me log-in 1-3 times an hour as in the pop-up showed up and I had to click on the log-in button. I also got the message "The operation is taking longer than expected. Please briefly wait before using this Rapp." when using mostly the Geo-Filter. Today, I am getting that message whenever I try to do anything, including just changing through the options. I haven't changed anything and it was working amazing at the beginning. Now I can't seem to even get connected to a game on COD Vanguard. I don't think it's the game because nobody else is reporting any issues. 

Message 17 of 66
Netduma-Liam
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

@View9  It should work normally, yes. Are you having any issues with it? There isn't an extensive changlog on this update as a lot of the changes were security updates.

 

@DredPirate13 Did you factory reset after installing the new firmware? Are you only seeing this in Geo-filter or are other rapps also showing this error?

Message 18 of 66
Raf1212
Apprentice

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

oh damn, I don't know whether to install, there is no change log, and I already see that people are reporting problems, I will wait, because somehow I have no pressure

Message 19 of 66
Netduma-Liam
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

@Raf1212 There'll be another one soon with much more changes. Of course I'd suggest upgrading to this one as there's security updates, but realistically you won't notice much difference beyond that. However, if you're not interested, we'll have another one soon with much more DumaOS changes that will be far more interesting for you.

Message 20 of 66
Raf1212
Apprentice

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

@Netduma-Liam  I updated, restored the factory settings,
-on speed tests shows half the speed
-ipv6 did not detect me at all
-after 10 minutes I started getting a message that I am logged in on another device and whether to continue
-after three such messages, I lost access to the router
good luck, thank you, it's a waste of time

Message 21 of 66
Netduma-Liam
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

On which speedtest? Connection Benchmark or a third-party speedtest? Could you run both and compare the results?

How are you checking that IPv6 is not currently working? Do devices in Device Manager have IPv6 addresses?

Can you provide a screenshot of the error you were receiving if possible? Did the entire router lose connection or were you just forced out of the interface?

Message 22 of 66

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

Are you talking about Revert To Factory Default Settings --> Erase?

Message 23 of 66
Netduma-Fraser
NetDuma Partner

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

Yes that's how to factory reset via the interface
Message 24 of 66

Re: New - XR450/XR500 Firmware Version 2.3.2.130 Released

I hadn't but I just did and now my QOS is messed up. Every time I go into it I get the message "device not found" and then it constantly reverts to showing the applications instead of the devices, which is what I want. I added all of my devices back into the LAN setup but it now appears that I will be having to adjust the QOS, when it starts to work, constantly for several weeks as the QOS is only showing devices that have connected since the reset. 

Message 25 of 66
Discussion stats
Announcements

Orbi WiFi 6E