Reply

Firmware 2.3.2.32 Breaks Internet Speed

NetriX
Aspirant

Firmware 2.3.2.32 Breaks Internet Speed

Firmware 2.3.2.32 breaks my internet speed. I run a 1Gbps Up/Down connection. With the latest firmware my speed tops out at 56 Mbps.

 

QOS is disabled and proper speed is set in Anti-Bufferbloat Options.

 

Reverting back to V2.3.2.22 has solved this issue.

Model: XR500| Nighthawk Pro Gaming Router
Message 1 of 24
Killhippie
Prodigy

Re: Firmware 2.3.2.32 Breaks Internet Speed

That is odd, I read your report on the Netduma forum. I updated via the link on the Netgear site. I didnt have the update issues you had, but what is odd is the speed isssue. I get nowhere near 1Gbps Symetrical. Im on a lowly 57Mpbs Down and 17Mbps up, and othats what I get no drop in speed at all. So I get more at 57Mbps than you on a 1Gbps line.

 

 I hope this is sorted out for you as I have to say this fIrmware (2.3.2.32) is running well for me, and has stopped my friends drop outs too. I'm in the UK on a PPPoE cionnection so maybe it has something to do with connection type as well as the headline speed. Hope it gets sorted soon.

Model: XR500| Nighthawk Pro Gaming Router
Message 2 of 24
Netduma_Jack
NetDuma Partner

Re: Firmware 2.3.2.32 Breaks Internet Speed

Thanks for posting here Netrix - as Killhippie has pointed out it seems to only affect a few routers. I've seen probably three or four cases of it so far, which is relatively low compared to how many people are using it. We're investigating this issue and will let everyone know when a fixed version of the firmware is available! Smiley Happy

Message 3 of 24
NetriX
Aspirant

Re: Firmware 2.3.2.32 Breaks Internet Speed

Have you noticed ping increases? I tend to be stable when limiting my bandwidth at 70% bufferbloat,

 

So, 57 Mbps would be about 6% on bufferbloat. As I don't know what's going on behind the scenes my ping has doubled on the new firmware.

Message 4 of 24
FURRYe38
Guru

Re: Firmware 2.3.2.32 Breaks Internet Speed

Has a full factory reset been performed on the router after the FW update and set up from scratch and walk thru the setup wizard??

What is the Mfr and model# of the ISP modem?

You also can revert back to .v22 FW as well if you can't get the speeds right.

 


@NetriX wrote:

Firmware 2.3.2.32 breaks my internet speed. I run a 1Gbps Up/Down connection. With the latest firmware my speed tops out at 56 Mbps.

 

QOS is disabled and proper speed is set in Anti-Bufferbloat Options.

 

Reverting back to V2.3.2.22 has solved this issue.


 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 5 of 24

Re: Firmware 2.3.2.32 Breaks Internet Speed

I can confirm I had issues with 2.3.2.32 as well, very slow internet speeds and enabling geo filtering would knock my xbox offline.  Reverting to 2.3.2.22 fixed it for me as well. Is this other thread netgear/netduma acknowledged that it appears to be buggy firmware.

 

https://community.netgear.com/t5/Nighthawk-Pro-Gaming-Routers/GEO-FILTER-FILTERING-NOT-WORKING/m-p/1...

Message 6 of 24
Killhippie
Prodigy

Re: Firmware 2.3.2.32 Breaks Internet Speed

Pings are stable and are as they were before for myself, my pings to London from southern UK are 8-12ms, just as they were on the previous version.

Model: XR700| Nighthawk Pro Gaming Router
Message 7 of 24
Netduma_Jack
NetDuma Partner

Re: Firmware 2.3.2.32 Breaks Internet Speed

It's worth noting that there are many users of this firmware who aren't experiencing any issues - we're trying to ascertain whether this is a bug with the firmware or something else. Thank you for letting us know what happened in your experience.

 

For anyone else experiencing major issues with 2.3.2.32, I'd recommend letting us know your issue first before downgrading - it's possible the issue could be fixed through simple configuration changes Smiley Happy

Message 8 of 24
Lexist2112
Luminary

Re: Firmware 2.3.2.32 Breaks Internet Speed

All,

Just updated to FW2.3.2.32, install was quick and the XR500 rebooted and reconnected to the Motorola modem.

Ran a few speed tests and ping time is stable for me around 16ms and i'm getting my 300/20 speed on my PC(connected Cat6).

Before installing the FW I had disconnected all my extenders and AP and after the FW update on the XR500 and speed test I reconnected all my extenders and AP's, one at a time.

Running wireless speed tests i'm getting my wireless speeds  as before, the EX8000 connects well as has been a performer!

I will continue to test all my other WiFi clients, but they all have connected automatically ....as usual.

 

The 30 minutes of running the NEW FW, i've been monitoring for intenet drop outs and have not seen any as of yet. Once again, I'll monitor

 

Message 9 of 24
FURRYe38
Guru

Re: Firmware 2.3.2.32 Breaks Internet Speed

What Mfr and model# is your modem?

Did you perform a factory reset after the update or just update and continue?

 


@Lexist2112 wrote:

All,

Just updated to FW2.3.2.32, install was quick and the XR500 rebooted and reconnected to the Motorola modem.

Ran a few speed tests and ping time is stable for me around 16ms and i'm getting my 300/20 speed on my PC(connected Cat6).

Before installing the FW I had disconnected all my extenders and AP and after the FW update on the XR500 and speed test I reconnected all my extenders and AP's, one at a time.

Running wireless speed tests i'm getting my wireless speeds  as before, the EX8000 connects well as has been a performer!

I will continue to test all my other WiFi clients, but they all have connected automatically ....as usual.

 

The 30 minutes of running the NEW FW, i've been monitoring for intenet drop outs and have not seen any as of yet. Once again, I'll monitor

 


 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 10 of 24
Netduma_Jack
NetDuma Partner

Re: Firmware 2.3.2.32 Breaks Internet Speed

Interesting - thank you for letting us know the steps you've taken. At first glance then, this issue could be related to how the new firmware is installed rather than what is contained within the firmware. Very interesting stuff, and I'm sure it will help us to investigate the issue!

Message 11 of 24
Lexist2112
Luminary

Re: Firmware 2.3.2.32 Breaks Internet Speed

All,

Sorry for late reply...busy weekend!   Here is my method and hardware.

Hardware:

1) Netgear XR500

2)Motorola Arris SB6183 modem (300down/20up)

3) Dlink 8-port switch

 

FW install method...straightforward, nothing fancy

1) downloaded the latest FW via the Netgear site ontu my wired Cat6 PC, using latest version of Firefox

2) Unzipped files ontu desktop

3) accessed XR500, via wired wired PC using Firefox(Web based)

4) Manually installed unzipped latest FW

5) XR500 self installed the new FW and 5-8 min later, router was back online

 

Router has been up and running straight since Friday...roughly 36hrs. I've not experienced any dropped internet connections, between modem and XR500.

Literally the network is stable and no hiccups, as mentioned in my earlier posts, ALL my extenders and AP's wirelessly connected, and all wired and wireless clients are getting internet and the speeds are the same as it was on FW .22

 

 

 

 

Model: XR500| Nighthawk Pro Gaming Router
Message 12 of 24
Killhippie
Prodigy

Re: Firmware 2.3.2.32 Breaks Internet Speed

I did a factory reset as I had a anomaly with the speed test on the router but I downloaded the firmware again and reapplied it then did the factory reset. I had disconnected all other devices also, I should have mentioned this thinking about it. I only had my iMac attached at update. I downloaded the firmware applied it reset it, went and had a coffee as it always I feel takes longer to do its thing than you relaise, so I give it a good five miniutes after updating. I applied all my settings then shut the router down and removed the power for 10 minutes while some gear was moved about by my Carer and then I booted it back up. All has been fine since, pings are low, and the odd  issue I had after PS4 updates has gone too. Before this current version the router would lose the internet when a PS4 update came along and you could not boot into it the GUI, this didnt happen when version 6.0.0 came out on 2.3.2.32.

Model: XR500| Nighthawk Pro Gaming Router
Message 13 of 24
AgamemnonIV
Aspirant

Re: Firmware 2.3.2.32 Breaks Internet Speed

I can also add that my speed tests went from ~250mbps down to ~50mpbs.  Seems to be throttled, and pulled down to slow immediately.  I haven't tried to revert to the older firmware.  

 

I just used the gui to update.  

Model: XR500| Nighthawk Pro Gaming Router
Message 14 of 24
Netduma_Jack
NetDuma Partner

Re: Firmware 2.3.2.32 Breaks Internet Speed

Could you try factory resetting your router and see if that fixes the issue please? Let us know how you get on. Thanks.

Message 15 of 24
AgamemnonIV
Aspirant

Re: Firmware 2.3.2.32 Breaks Internet Speed

I reverted to the  2.3.2.22, and that resolved the issue.  I have a custom VPN server running, that reconfiguring requires multiple locations and re-distributing files.  Resetting to factory is not acceptible.  

Model: XR500| Nighthawk Pro Gaming Router
Message 16 of 24
FURRYe38
Guru

Re: Firmware 2.3.2.32 Breaks Internet Speed

You need to factory reset when upgrading to v.32 after you apply it and see. Seems that others are having good luck in this method.

 

I presume NG will be fixing this upgrade and not having to reset issue as I presume NG intended method is to upgrade FW with always having to do a reset. There many some major changes in the v.32 FW which are not taking correctly and needs a factory reset.

 

We've seen this issue in other NG routers.


@AgamemnonIV wrote:

I reverted to the  2.3.2.22, and that resolved the issue.  I have a custom VPN server running, that reconfiguring requires multiple locations and re-distributing files.  Resetting to factory is not acceptible.  


 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 17 of 24
OlegP
Apprentice

Re: Firmware 2.3.2.32 Breaks Internet Speed


@Netduma_Jack wrote:

Thanks for posting here Netrix - as Killhippie has pointed out it seems to only affect a few routers. I've seen probably three or four cases of it so far, which is relatively low compared to how many people are using it. We're investigating this issue and will let everyone know when a fixed version of the firmware is available! Smiley Happy


True, there are most likely very many people using the router, but how many of them do you think will actually bother to register on forums and extensively troubleshoot their device when they have severe issues?

 

I’m really hoping that the fix is incoming soon becuase I seriously doubt that this particular issue is isolated to just a few reported cases.

Message 18 of 24
Killhippie
Prodigy

Re: Firmware 2.3.2.32 Breaks Internet Speed

Enough that on this forum there would be a large amount of complaints, this router is not the kind bought by those that are not tech savy. Also this router is sold all over the world so it would be noticed. The disconnect thread was large enough to show that many people join these forums to voice concerns. I would relead the firmware again from the download link, the router will ask if you want to install the same version (corrupt installs happen) then do no factory reset and see how it goes.

Model: XR500| Nighthawk Pro Gaming Router
Message 19 of 24
AgamemnonIV
Aspirant

Re: Firmware 2.3.2.32 Breaks Internet Speed

Thanks for the advice  @Killhippie  I tried re-updating to the 32 firmware, and the issue came back speeds were throttled by router.  Reverted again to 22, problem went away, back to full speed.  Hopefully folks can get their act together on this.  

Model: XR500| Nighthawk Pro Gaming Router
Message 20 of 24
OlegP
Apprentice

Re: Firmware 2.3.2.32 Breaks Internet Speed

I disagree. The tech savvy people are using Microtic router's or flashing custom firmware on their own routers. They aren't buying an off the shelf consumer router at their local Best buy.

This is the Leet Pro-gaming Win Button router that's marketed for the masses. It's sold as a set it and forget it type of device for the average Joe's.

I don't want to mess around with ports and packet headers when configuring QOS settings for games. That's why I bought into this product in the first place.
Message 21 of 24
FURRYe38
Guru

Re: Firmware 2.3.2.32 Breaks Internet Speed

I'm still buying consumer routers from Amazon and Best buy. Just got the XR450 from Costco last month. Been working with routers for years. Doesn't mean everyone isn't buying from local stores either.

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 22 of 24
AgamemnonIV
Aspirant

Re: Firmware 2.3.2.32 Breaks Internet Speed

I figured I'd send the update here as well.  I asked netgear support about this issue, and they gave me a few things to try, but then also said to just wait 24hr or so and try again.  So I did that, and my speeds increased!  I honestly dont understand, but maybe background processes?  Anyway, it 'just works' again.  Something to try for anyone with such issues.  

 

Any experts understand/believe this was actually the issue?

Model: XR500| Nighthawk Pro Gaming Router
Message 23 of 24
Netduma_Jack
NetDuma Partner

Re: Firmware 2.3.2.32 Breaks Internet Speed

It’s possible your line was congested or underperforming at the time, but I’m not sure. That’s probably why they suggested waiting!
Happy to hear it’s working for you now.
Message 24 of 24
Top Contributors
Discussion stats
  • 23 replies
  • 4852 views
  • 10 kudos
  • 8 in conversation
Announcements

Orbi WiFi 6E