Reply
Apprentice

XR500: All devices suddenly loose the ability to download, but can still upload

I'd like to know if anyone else has had this issue.

 

All my connected devices lose the ability to download, but the DumaOS panel shows they are still uploading (blue bar graph instead of red). I often have to reboot the modem, router, or both to get it back to normal. 

 

This has been something that maybe happens every few months, but over the last 24h (and after switching to Gigabit internet), it's happened three times and I'm at my witts end. 

 

I'm using V2.3.2.40 firmware. 

 

Any suggestions or advice would be greatly appreciated. 

Model: XR500|Nighthawk Pro Gaming Router
Message 1 of 12
Guru

Re: XR500: All devices suddenly loose the ability to download, but can still upload

What is the Mfr and model# of the ISP modem the NG router is connected too?

 

Happens with both wired and wireless devices? 

 

My Setup (Cable 1Gbps/50Mbps)>CM1200(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.102
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 2 of 12
Apprentice

Re: XR500: All devices suddenly loose the ability to download, but can still upload

The modem is a Hitron CODA-4582U (DOCSIS 3.1) routing through the Netgear XR500 on the Rogers Canada Gigabit plan.

 

The moden is a wifi modem, but that's all been disabled and it's routing everything through the XR500.

 

When the problem happens, all devices, incuding wired, will only show as upload only. 

Message 3 of 12
Guru

Re: XR500: All devices suddenly loose the ability to download, but can still upload

Problem maybe with your modem. It has a built in router already. 

This would be a double NAT condition which isn't recommended. https://kb.netgear.com/30186/What-is-Double-NAT
Couple of options,

1. Configure the modem for transparent bridge mode. Then use the NG router in router mode. You'll need to contact the ISP for help and information in regards to the modem being bridged correctly.
2. If you can't bridge the modem, disable ALL wifi radios on the modem, configure the modems DMZ/ExposedHost or IP Pass-Through for the IP address the NG router gets from the modem.

 

Please give #2 a try...

 

My Setup (Cable 1Gbps/50Mbps)>CM1200(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.102
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 4 of 12
Apprentice

Re: XR500: All devices suddenly loose the ability to download, but can still upload

The first thing I did when I set the modem up is to put it into bridge mode, so it's currently acting only as a "dumb" modem and the router handles everything else. 

 

I've checked the logs on the modem and router and nothing seems out of the ordinary (i.e. no logs during the times when I experience this problem). 

Message 5 of 12
Guru

Re: XR500: All devices suddenly loose the ability to download, but can still upload

Might try a factory reset of the XR router and setup from scratch. Power OFF the ISP modem for 30 seconds while the XR router is resetting. Walk thru the setup wizard. After that completes. Don't change anything else, besides WiFi. Enable Beamforming. Leave QoS and Anti Buffer settings at default. 


Check with different PCs or devices for download ability for comparison. See if the behavior changes. 

My Setup (Cable 1Gbps/50Mbps)>CM1200(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.102
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 6 of 12
NetDuma Partner

Re: XR500: All devices suddenly loose the ability to download, but can still upload

This is a very strange issue, not heard of it before. You mention it started happening more frequently after changing speeds so if you connect direct to modem do you ever experience this. Do you download a lot at all? If so next time you do this could you check Traffic Prioritization and see if it is prioritizing download please?
Message 7 of 12
Apprentice

Re: XR500: All devices suddenly loose the ability to download, but can still upload

Just a quick update and observation - I was able to monitor this issue live while I was looking directly at the modem and the DumaOS network monitor. 

 

The lights on the modem for uplink and downlink should be blue - but they turned green while this problem occured (all devices in the network monitor showed as uploading only) then the lights turned blue and things returned back to normal. 

 

So my thoughts are this: the modem itself loses connection momentarily and the network monitor maybe isn't relaying the correct information (i.e. no data at all, rather than upload only). 

 

If this continues to happen, I will assume it's a modem/connection issue and not an issue with the XR500. 

 

In the meantime, I have disabled QOS just for testing. 

 

@Netduma-Fraser It wouldn't be practical to test for more than a few minutes with devices connected directly to the modem, since they would be things like an IP camera, Voip system, or my TV - all my portable devices run on wifi only and none of my laptops have an ethernet port. That's not to say I can't find a way to connect a PC to the modem directly, but that would mean everything else would be without internet access while I wait for a random issue to happen (i.e. no security system, no home phone, etc.). I'd rather not go there. I don't download anything other than through steam or Xbox live, but we do stream a lot and have quite a few connected devices (20+). 

 

I will report back if any new observations are made. I may do a complete factory reset and start from scratch just to see what happens, but I'm leaning more towards a modem/network issue right now.

Message 8 of 12
NetDuma Partner

Re: XR500: All devices suddenly loose the ability to download, but can still upload

Totally understand, it’s not always practical to do that. It could be that something is being prioritised when it shouldn’t be and as the feature is designed for low bandwidth prioritisation (I.e gaming) priotizing a huge download could cause issues. Sounds like you may have found the cause though so that’s great, keep us posted.
Message 9 of 12
Guru

Re: XR500: All devices suddenly loose the ability to download, but can still upload

Have your ISP check the singal and quality of there service up to the modem. Have them check there logs to see if they see any thing on there side when this happens on the modem. 

 

 

My Setup (Cable 1Gbps/50Mbps)>CM1200(LAG Disabled)>RBK853 v3.2.17.12
RBK50 v2.7.2.102
Additional NG HW: C7800/CM1100/CAX80/CM2000, Orbi CBK40, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 10 of 12
Apprentice

Re: XR500: All devices suddenly loose the ability to download, but can still upload

Another quick update and then this topic can be closed.

 

I lost internet connection again on the modem twice this morning, so I had the modem swapped out. One of the lights on the modem, which was a dark blue before, is now cyan, which is a good thing. So far so good, but I do not believe the router is at fault here - it just seems to report "uploading" on devices when there is no connection available. Maybe it's a bug, but it's probably too rare or out-of-sight for anyone to notice. 

 

Thanks for all the help.

Message 11 of 12
NetDuma Partner

Re: XR500: All devices suddenly loose the ability to download, but can still upload

Great to hear that, thank you very much for the update!
Message 12 of 12
Top Contributors
Discussion stats
  • 11 replies
  • 1195 views
  • 1 kudo
  • 3 in conversation
Announcements