Reply

Re: XR500 DHCP issue

Netduma-Fraser
NetDuma Partner

Re: XR500 DHCP issue

That doesn't really make much sense, the devices are requesting a public IP address or a LAN address from the modem?
Message 76 of 208
GooniesNvrSayDi
Apprentice

Re: XR500 DHCP issue

A public IP address from the ISP is what they are telling me. I have fiber internet with an ONT with one Ethernet port plugged into the router’s Internet port. My PS4 and Apple TV are hardwired into the router. Also a S8000 Nighthawk switch is hardwired for which the Hue Hub is wired to. These devices are showing up in my ISP’s routing table as wanting a public IP. I reboot my router and they clear the extra devices from the table and all is well for about 8 hours and then it all happens again. Back in December it was occurring and happened to notice my NAT was Open so I set it to Secure. This seemed to resolve the issue until now.
Message 77 of 208
GooniesNvrSayDi
Apprentice

Re: XR500 DHCP issue

From my ISP in December.

 

Thanks for calling in just now about your connection dropping. After digging around some, we're of the mind that this behaviour is due to some unexpected DHCP requests that the router is forwarding to us instead of handling internally. You noted that this started on the 26th so I rooted around some historical logs and I do see a difference starting then. The question boils down to why some other devices besides the netgear are popping up on our end. We should basically only ever be talking to the router directly. 

There's a lot of data in the logs, but cutting out some here's an example from the 25th. The 24th looks the same, and these are all the requests in the 24 hour period: redacted due to IP address

 

******

But on the 26th some other devices start popping up. This behaviour continues until today:

 

 

Message 78 of 208
Netduma_Jack
NetDuma Partner

Re: XR500 DHCP issue

That's very odd. I've never seen this problem before. Just to double check - the switch is connected into the XR500 right?

 

At this point, I would reboot your modem then factory reset your XR500 and see if that solves the problem. Perhaps there is some DMZ or port forwarding rule that is causing problems.

Message 79 of 208
GooniesNvrSayDi
Apprentice

Re: XR500 DHCP issue

Correct, the switch is plugged into one of the 4 Ethernet ports. I do not have any port forwarding or DMZ configured.
Message 80 of 208
FURRYe38
Guru

Re: XR500 DHCP issue

What Firmware is currently loaded?
What is the Mfr and model# of the ISP ONT the NG router is connected too?


@GooniesNvrSayDi wrote:
Correct, the switch is plugged into one of the 4 Ethernet ports. I do not have any port forwarding or DMZ configured.

 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 81 of 208
Netduma-Fraser
NetDuma Partner

Re: XR500 DHCP issue

When the issue occurs do you notice that you're unable to connect to the internet or the interface with wired or wireless devices?
Message 82 of 208
GooniesNvrSayDi
Apprentice

Re: XR500 DHCP issue

Wired and wireless devices are unable to connect to the Internet. I am still able to access the NetDuma interface with both wired and wireless devices during this time.
Message 83 of 208
FURRYe38
Guru

Re: XR500 DHCP issue

What Firmware is currently loaded?
What is the Mfr and model# of the ISP ONT the NG router is connected too?


@GooniesNvrSayDi wrote:
Wired and wireless devices are unable to connect to the Internet. I am still able to access the NetDuma interface with both wired and wireless devices during this time.

 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 84 of 208
Netduma-Fraser
NetDuma Partner

Re: XR500 DHCP issue

When this happens, on one of the devices, can you find out what IP it is receiving please?
Message 85 of 208
GooniesNvrSayDi
Apprentice

Re: XR500 DHCP issue

Firmware version 2.3.2.40

 

ONT is Adtran 401 micro(the one without voice)4A2C390C-857E-4350-97CA-7947EF71A99D.jpeg

Message 86 of 208
FURRYe38
Guru

Re: XR500 DHCP issue

Ok, just checking for NAT issues here. Your fine here. 

SHouldn't be having any issues with DHCP on the XR router. 


@GooniesNvrSayDi wrote:

Firmware version 2.3.2.40

 

ONT is Adtran 401 micro(the one without voice)4A2C390C-857E-4350-97CA-7947EF71A99D.jpeg


 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 87 of 208
Netduma-Fraser
NetDuma Partner

Re: XR500 DHCP issue

Goonies, can you tell what the IP address shows on the actual device network settings when the issue occurs?
Message 88 of 208
Boga
Initiate

Re: XR500 DHCP issue

Im pretty sure you have seen this problem before.

 

http://forum.netduma.com/topic/28035-xr500-no-internet-after-reboot/

Message 89 of 208
Netduma-Fraser
NetDuma Partner

Re: XR500 DHCP issue

Yes it does sound like that, just trying to be sure
Message 90 of 208
GooniesNvrSayDi
Apprentice

Re: XR500 DHCP issue

It has occurred again. Looking at the XR500 IP address it is the one assigned by my ISP. The devices that are requesting an IP and getting forwarded to my ISP (PS4, Apple TV, etc) are showing a local IP of 192.168.*.* so nothing seems out of the ordinary when looking in the DumaOS dashboard.

Message 91 of 208
GooniesNvrSayDi
Apprentice

Re: XR500 DHCP issue

@Boga the forum post you referenced in the NetDuma community sounds the same except mine occurs without a reboot and just happens after a certain amount of time lapses

Message 92 of 208
Netduma_Jack
NetDuma Partner

Re: XR500 DHCP issue

This may have been suggested before, but have you tried installing this hotfix firmware?

 

https://kb.netgear.com/000060127/XR500-Firmware-Version-2-3-2-32

Message 93 of 208
GooniesNvrSayDi
Apprentice

Re: XR500 DHCP issue

I just downgraded to V2.3.2.22 that was mentioned as being successful in the Netduma community post. Will reply if it occurs again.

Message 94 of 208
Sneakybeaky
Tutor

Re: XR500 DHCP issue

Has this firmware version worked for people? Im also having this issue on the evenings but, its only affected apples devices( most devices in the house are apple ) 

Message 95 of 208
Netduma_Alex
NetDuma Partner

Re: XR500 DHCP issue

I believe the wrong link was given for the hotfix firmware

This is the correct link

New XR500 hotfix firmware for drop outs - DumaOS on NETGEAR Nighthawk Support - Netduma Forum

Message 96 of 208
GooniesNvrSayDi
Apprentice

Re: XR500 DHCP issue

It has been over a month since I have downgraded to V2.3.2.22 and everything is working it should. Hopefully this not only helps others with the same issue but it will be fixed in an upcoming patch.

Message 97 of 208
Netduma_Alex
NetDuma Partner

Re: XR500 DHCP issue

Well I'm glad it's working for you! I'll make sure to tell the devs so we can figure out what it was the caused the problem.

Message 98 of 208
Sneakybeaky
Tutor

Re: XR500 DHCP issue

Running that hotfix version and it didn't fix anything

Message 99 of 208
Netduma_Alex
NetDuma Partner

Re: XR500 DHCP issue

Message 100 of 208
Top Contributors
Discussion stats
Announcements

Orbi WiFi 6E