Discussion stats
  • 16 replies
  • 4070 views
  • 6 kudos
  • 7 in conversation
Announcements

Reply
Highlighted
Tutor

XR500 Factory Reset Itself!!!

I woke up this morning with no wifi and no internet to my wired devices. At first I thought my girlfriend didn't pay the internet bill again. I logged into the router to check some things out. Low and behold, I am greeted by the Initial setup page. All of my settings and preferences were gone and I am forced to start over from scratch! I also noticed that the firmware was updated. I have never in my life seen this before. What gives?

Model: XR500| Nighthawk Pro Gaming Router
Message 1 of 17
Highlighted
NetDuma Partner

Re: XR500 Factory Reset Itself!!!

Hi Xolhid, the router would have auto upgraded you to the latest version. I imagine that is what caused the factory reset though that shouldn't have happened. Can you continue to monitor the router to see if it factory resets again or if it was just that one off? I'll also look into factory reset after updating automatically.
Message 2 of 17
Highlighted
Tutor

Re: XR500 Factory Reset Itself!!!

It won't be hard to keep an eye on it as the internet is unavailable until the setup is complete. It will be obvious if it happens again. I didn't think I needed to use the backup settings feature, but now I guess I have to.

Message 3 of 17
Highlighted
Tutor

Re: XR500 Factory Reset Itself!!!

Yeah I'm having the same issue as well it's really annoying and I don't understand what the issue is.  This was working just fine for the past week and a half since I got it. I also tried to test something out an a simple reboot and that would trigger this problem as well. 

Message 4 of 17
Highlighted
NetDuma Partner

Re: XR500 Factory Reset Itself!!!

Hi Threlnos, make sure you're upgraded to the latest version then do a factory reset and let us know if it happens again and if you're able to reproduce it.
Message 5 of 17
Highlighted
Tutor

Re: XR500 Factory Reset Itself!!!

I'll try this out but this is my third time redoing my settings (did a restore but didn't seem to do anything thing)  so I have had to setup my various devices throught out the house for the 3rd time in less then 12 hours.  I will do the factory reset and let you know the results.

Message 6 of 17
Highlighted
NETGEAR Employee Retired

Re: XR500 Factory Reset Itself!!!

Hi Threlonos,

When performing the factory reset. Make sure you hold the reset button on the back for at least 10-15 seconds and then let it boot all the way up. :]

Please let us know when you have performed those steps.

 

 

- Jason N

Message 7 of 17
Highlighted

Re: XR500 Factory Reset Itself!!!

Hi folks.  THis happened to me last night as well and found this thread while looking for answers.  i have posted in the Netduma forums as well.  This is my post from there.  Any info would be appreciated if anyone knows why or how to make this not happen.  Thanks.

 

So last night I was in my basement and my son and wife starting yelling down complaining about the internet.  I realized it was indeed down so I went to log into the router and was greeted with the setup wizard!  Really not good.  I went through it and everything seemed to work fine.  I then tried to restore from backup and it looked like it was going to work and the router reboot and AGAIN I was greeted with the setup wizard.  I went through again and none of my settings from backup had applied.  I was busy doing other things so I just setup wifi and let it go until this morning. 

 

I saw that overnight it had done a firmware upgrade which I declined when it rebooted last night and went through the setup wizard which seemed to be fine and it kept the wifi settings after the automatic firmware upgrade.  Please note, I DID NOT HAVE AUTO FIRMWARE UPGRADE ON PRIOR TO HAVING THESE ISSUES.  So a firmware update did not blow away my router and set it back to factory. It did this out of nowhere. 

 

To continue, this morning after the overnight auto firmware update, I did a full factory reset again, went through setup wizard then applied my saved config from a few weeks ago and this time it DID work which was great.  What is not great is that any of this happened to begin with.  There is no reason any router should ever factory reset itself out of nowhere obviously.  I think I found another thread about this but does anyone know what is going on?  I don't see anything about this issue itself in the firmware that upgraded last night but I'm hoping that there is something in there that is fixing this problem.  Any info appreciated.  Thanks.

Model: XR500| Nighthawk Pro Gaming Router
Message 8 of 17
Highlighted
Prodigy

Re: XR500 Factory Reset Itself!!!

Dont use a saved config, this has been a known problem (not the reset) but using the saved config file can bring some incompatabilities over from the saved data from the previous firmware. Hard reset and set up manually as new don't use the saved config file. Then see how things go.

 This article explains why ist good to reset after updates and why its not a good idea to use backup files, RMerlin develops firmware alongside Asus and really knows what he is talking about. https://www.snbforums.com/threads/faq-nvram-and-factory-default-reset.22822/


Model: XR500| Nighthawk Pro Gaming Router
Message 9 of 17
Highlighted

Re: XR500 Factory Reset Itself!!!

Yeah I don't think you're wrong about that and that is my general policy.  I probably wouldn't have if I hadn't spent hours setting up static IPs for everything in my house just the week before.  Now that I was able to restore and can copy that stuff into a spreadsheet I can very much more easily set it up again without doing all the hunting around for MAC addresses.  I've never really had to restore from a router backup at home but you're right.  Thanks for the post.  I would still love to know how this happened to some of us and what Netgear/Duma is doing to figure out why and make sure it doesn't happen.  Thanks again.

Message 10 of 17
Highlighted
NetDuma Partner

Re: XR500 Factory Reset Itself!!!

I'm trying to reproduce it based on what I know so I can give information to the Netgear Development team.
Message 11 of 17
Highlighted

Re: XR500 Factory Reset Itself!!!

Fraser!  You're in my Duma forum thread about this same issue Smiley Happy  I'm happy to provide whatever I can to make sure this doens't happen in the future.

Message 12 of 17
Highlighted
NETGEAR Expert

Re: XR500 Factory Reset Itself!!!

I have 2 XR500s both on latest FW 2.2.1.10 and I am not able to reproduce or observe this issue. What firmware version(s) are you guys seeing this on?

Model: XR500| Nighthawk Pro Gaming Router
Message 13 of 17
Highlighted

Re: XR500 Factory Reset Itself!!!

Honestly don't remember.  I'm in the current now.  I was on whatever was before the current firmware.  

Message 14 of 17
Highlighted
Tutor

Re: XR500 Factory Reset Itself!!!

Since my initial post and resetting my router this last time I have not experienced this issue and not other problems to report.

 

Thank

Message 15 of 17
Highlighted
Tutor

Re: XR500 Factory Reset Itself!!!

Ditto. However, I will wait to see what the next automatic firmware update does before I let it go.
Message 16 of 17
Highlighted

Re: XR500 Factory Reset Itself!!!

Same here.  Running V2.2.1.10 currently without any issues since the random reset a few weeks ago.  Fingers crossed.

Message 17 of 17