Reply

Re: XR500 INTERNET PROBLEMS

gt9484
Tutor

XR500 INTERNET PROBLEMS

hi all,
i have the XR500 and have had nothing but problems with it. drops raginging from 20/31 times in a day. I first thought this was my ISP and had multiple engineer visits trying to figure out if it was a infrastructure problem but i now conclude its a hardware problem. I have used both my ISP router with the XR500 and a netgear d7000 as a modem and both setups have seen multiple drops. I have seen that some people have updated firmware to try and patch this problem. I have the most up to date firmware when i re installed this router back to factory reset only two days ago 28/09/19.
can i get a debugging firmware or blanco firmware to wipe this router and re flash a new image to try and get this router working like it should.
Any suggestions are welcome i really dont want to have to bin this peace of kit
thank you

Model: XR500|Nighthawk Pro Gaming Router
Message 1 of 13
Netduma_Alex
NetDuma Partner

Re: XR500 INTERNET PROBLEMS

Can I ask what hardware you have the XR500 connected to? Is it a modem or an ISP router?

Message 2 of 13
gt9484
Tutor

Re: XR500 INTERNET PROBLEMS

Hi thanks for the reply. It's connected to a D7000 Netgear router set as a modem mode. I have had this issue since I first bought this XR500 but thought it was an ISP problem only to find it's actually on my hardware
Message 3 of 13
Netduma_Alex
NetDuma Partner

Re: XR500 INTERNET PROBLEMS

A D7000? Hm, okay you'd think that would be compatible given it's Netgear.

Could you take the D7000 out of Modem Mode and instead put the XR500 into the DMZ of the D7000? This has been known to stop drops.

Message 4 of 13
gt9484
Tutor

Re: XR500 INTERNET PROBLEMS

I will try this but it then has the confusing aspect of having two router and double NATS... This XR500 has done this when connected to the ISP router so I would have had this chance to work in the past... Is their a debugging firmware I can use to see if this has other issues I don't know about? Or can the image be deleted and re sent on the router to give it a proper fresh start? Seems like something isn't running like it should
Message 5 of 13
Netduma_Alex
NetDuma Partner

Re: XR500 INTERNET PROBLEMS

Putting the XR500 into the DMZ of the upstream router should remove the double-nat issue.

 

It sounds like there might be a problem specific to your device. One thing I could suggest that often helps is to downgrade to the earliest available firmware and then upgrade straight to the latest one again. 

 

Here's a link to the earliest available firmware: https://kb.netgear.com/000053241/XR500-Firmware-Version-2-0-0-28

Message 6 of 13
gt9484
Tutor

Re: XR500 INTERNET PROBLEMS

I feel robbed with this equipment as I was led to believe I had an ISP problem and spent the better part of a year dealing with it. Only to figure out it was the hardware. I feel like this router has problems on it, I never seem to get geo filters to work correctly and I have suffered continued drops for this entire time. If the router is malfunctioning is there not a debugging method to figure this out? Or wipe the device of all images and then re flash a new firmware. Downgrading and updating is something I have tried many time. As far as the geo filters I try and set a location yet I only ever get my local servers... I wanted to chose a more appropriate one for BO4 but I seem to just get randomly assigned even after setting geo filter.
Message 7 of 13
FURRYe38
Guru

Re: XR500 INTERNET PROBLEMS

First off, were you able to get your modem into modem only mode or if not, did you use the Modems DMZ for the XR router? This needs to be effected first before the XR can fully work to it's potential. I have zero problems with my XR router. I have a gateway modem with a built in router as well. It's is modem mode and my XR router works fine in this configuration. 


@gt9484 wrote:
I feel robbed with this equipment as I was led to believe I had an ISP problem and spent the better part of a year dealing with it. Only to figure out it was the hardware. I feel like this router has problems on it, I never seem to get geo filters to work correctly and I have suffered continued drops for this entire time. If the router is malfunctioning is there not a debugging method to figure this out? Or wipe the device of all images and then re flash a new firmware. Downgrading and updating is something I have tried many time. As far as the geo filters I try and set a location yet I only ever get my local servers... I wanted to chose a more appropriate one for BO4 but I seem to just get randomly assigned even after setting geo filter.

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | XR1000 (Router Mode) and RBK853 AP Mode  | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 8 of 13
gt9484
Tutor

Re: XR500 INTERNET PROBLEMS

Yes I have had it in the DMZ many times and had the modem/router in both modes and also used an ISP router but I have always had problems with the XR since the beginning. Geo filter has never worked and the unstableness of the ping and connection is really bad. Internet just dropped off and then re established connection multiple times a day. I'm contemplating an netduma R1 it seems like it might be my only option
Message 9 of 13
FURRYe38
Guru

Re: XR500 INTERNET PROBLEMS

What configuration is the XR router in now with the modem? DMZ or is the modem Bridged? 

 

What FW version are you currently using on the XR router? 


@gt9484 wrote:
Yes I have had it in the DMZ many times and had the modem/router in both modes and also used an ISP router but I have always had problems with the XR since the beginning. Geo filter has never worked and the unstableness of the ping and connection is really bad. Internet just dropped off and then re established connection multiple times a day. I'm contemplating an netduma R1 it seems like it might be my only option

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | XR1000 (Router Mode) and RBK853 AP Mode  | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 10 of 13
gt9484
Tutor

Re: XR500 INTERNET PROBLEMS

At the moment it's in modem bridge mode and it's on the most recent firmware
Message 11 of 13
Netduma_Alex
NetDuma Partner

Re: XR500 INTERNET PROBLEMS

Make sure that VLAN Bridging is disabled in the XR500 settings.

Message 12 of 13
FURRYe38
Guru

Re: XR500 INTERNET PROBLEMS

You might try this, go back to v32 or try the very first FW released version. Load either one of these up and see if the problem continues. I would try the very first version. Factory reset and setup from scratch. Let us know what you find.


@gt9484 wrote:
At the moment it's in modem bridge mode and it's on the most recent firmware

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router RBK953 (Router Mode) 2.5Gb Wired Backhaul | Switches NG GS105/8, GS308v3, GS110MX and XS505M | XR1000 (Router Mode) and RBK853 AP Mode  | 

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, EX7500/EX7700

Message 13 of 13
Discussion stats
  • 12 replies
  • 1570 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E