Reply

Re: XR500 OpenVPN issues

Specop
Aspirant

XR500 OpenVPN issues

When setting up OpenVPN I am getting a client side error that reads... 

 

No server certificate verification method has been enabled.

 

Any thoughts on how to resolve this?

 

I've checked to make sure the router firmware and software are up to date.  I've also regen the openva package with no luck.

 

As far as the logs, the only other line in there is "Enter Management Password:"  but I never see that in the status.  Just the error mentioned above.

 

Thanks.

Model: XR500| Nighthawk Pro Gaming Router
Message 1 of 10
smitheram
Guide

Re: XR500 OpenVPN issues

Hi,

Have this problem also. Was advised to do a hard reset after a long conversation by Netgear advisor but still didnt work for me. Gave up in the end because they obviously dont know what there talking about and singing from the same hymn sheet.

Model: XR500| Nighthawk Pro Gaming Router
Message 2 of 10
Netduma_Jack
NetDuma Partner

Re: XR500 OpenVPN issues

Is this in the VPN Client area that you are seeing this?

 

Being able to choose an OpenVPN client is coming in the next firmware on Hybrid VPN (which allows you to apply your OpenVPN provider to any device, game or port range)

Message 3 of 10
smitheram
Guide

Re: XR500 OpenVPN issues

Hi,

No, this is the VPN Service which I think is on the Netgear side of things. Exporting certificate for everything else seems to work. Only the windows exported certificate is affected. 

 

 

Model: XR500| Nighthawk Pro Gaming Router
Message 4 of 10
Netduma-Fraser
NetDuma Partner

Re: XR500 OpenVPN issues

Hi so just to be clear are you experiencing this message on the VPN Service in Settings on the router or the VPN Client you're using on Windows?

If the latter what is the VPN Client you're using for Windows?

Are you using a Static IP for your router or Dynamic DNS?
Message 5 of 10
smitheram
Guide

Re: XR500 OpenVPN issues

Hi,

I’m using OpenVPN to connect to the router at home. I’m using Dynamic DNS.
Model: XR500| Nighthawk Pro Gaming Router
Message 6 of 10
Netduma-Fraser
NetDuma Partner

Re: XR500 OpenVPN issues

I think the issue is that Netgear have only implemented Client verification and not Server verification which is why you're receiving that. It shouldn't prevent you connecting but I realise this is less than ideal. I'd recommend if you still have your ticket open letting them know this so they can let the devs knows.
Message 7 of 10
Specop
Aspirant

Re: XR500 OpenVPN issues

 

Sorry for the late response.  I have been ill the past couple days.

 

It does prevent me from connecting to the router via OpenVPN.  I am using Dynamic DNS and I have configured the OpenVPN section to route all traffic through the router.

 

I have tried the certs from the non windows to no avail either.

 

I hit connect and it just sits there at the error code I gave before.

Message 8 of 10
Netduma-Fraser
NetDuma Partner

Re: XR500 OpenVPN issues

Okay that's annoying. I think it's the reason above, update your ticket with that information if you can.

Also if you use a static IP for the router instead of Dynamic DNS does it work then?
Message 9 of 10
BOZGBOZG
Star

Re: XR500 OpenVPN issues

@Specop and @smitheram

 

Open the client.ovpn file that you downloaded from the router in a text editor and add "remote-cert-tls server" (without quotation marks) to the bottom of the file. Should work after that.

Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 2511 views
  • 1 kudo
  • 5 in conversation
Announcements