× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
Orbi WiFi 7 RBE973
Reply

Re: XR500 QoS, UPnP issue with VLAN tagging.

Huthayfa
Guide

XR500 QoS, UPnP issue with VLAN tagging.

Hi,

recently I have got my XR500 with DumaOS. I discovered an issue, I am using fiber connection that requires VLAN tagging on WAN to get the internet working. when I put my fiber ONT in full bridge, set up the VLAN tag on the XR500 and configure the PPPoE connection, the QoS upload speed limit feature does not work at all, I mean that I limit the upload and download sliders to 70%, the download is limited okay but the upload is still giving full speed on speedtest.net and dslreports.com and buffering like hell. I am on last firmware, tried rebooting the router and factory defaults, no use. I figured out that QoS functioning properly only if I set my connection to anything other than PPPoE, which means not to put my ONT in bridge mode and connect the XR500 to it for getting local IP which will cause double NAT issue. Also, the UPnP is not responding with this setup, I mean it keeps opening ports even while disabled, I can see the ports get appered in the table even after the enable option is unticked.

I tried to call the support since 8 days now and opened two cases with no rsponse, even one of the Netgear support staff called me two days ago and observed the issue through TeamViewer and I am still waiting for her response as she promised to get back to me after two days. ScreenShot.png

 

thanks in advance !

Model: XR500| Nighthawk Pro Gaming Router
Message 1 of 20

Accepted Solutions
Huthayfa
Guide

Re: XR500 QoS, UPnP issue with VLAN tagging.

this issue has not been fixed yet, and guess what? seems like there is no fix at all. 

for everyone else having VLAN setup, be careful while cosndering the XR500 for your setup since you will find some main feaures not working properly.

 

thanks.  

View solution in original post

Model: XR500| Nighthawk Pro Gaming Router
Message 8 of 20

All Replies
Huthayfa
Guide

Re: XR500 QoS, UPnP issue with VLAN tagging.

I have just received a response from Mr. Fraser, that they will work on the issue, hope this get fixed as soon as possible, thanks to everybody. 

Message 2 of 20
Huthayfa
Guide

Re: XR500 QoS, UPnP issue with VLAN tagging.

Hi everyone,

I am still on waiting for the fix, no update from Netduma or Netgear support until now. 

thanks

Message 3 of 20
Netduma-Fraser
NetDuma Partner

Re: XR500 QoS, UPnP issue with VLAN tagging.

A fix takes time, certainly more than 4 days due to testing as well. I don't know the current status as Netgear will be dealing with it, once the new update is released check whether it has been implemented. Can also ask on your ticket for an update
Message 4 of 20
Huthayfa
Guide

Re: XR500 QoS, UPnP issue with VLAN tagging.

thank you Mr. Fraser.

I will wait, just want to make sure that fix will be available soon.4-7 days is not an issue.

 

 

Message 5 of 20
Huthayfa
Guide

Re: XR500 QoS, UPnP issue with VLAN tagging.

as an update to the issue, which is the QoS and UPNP on VLAN tag setup,

I found a statemnet on Netgear user manual that might be making sense,

 

on the VLAN tag section they mentioned this statement:

 

" If you add a VLAN tag group to the bridge, packets sent between the device and the router’s Internet port are not processed through the router’s network address translation (NAT) or firewall"

 

this might be the reason of the problem, the upstream packets specifically are not controlled by NAT on VLAN bridge. that is why download speed can be controlled by anti-bufferbloat but upload is not. 

 

thanks.

Model: XR500| Nighthawk Pro Gaming Router
Message 6 of 20
Netduma-Fraser
NetDuma Partner

Re: XR500 QoS, UPnP issue with VLAN tagging.

Thank you I've updated the ticket on our end about this so will see if we can get a fix in place for this for QoS side of things.
Message 7 of 20
Huthayfa
Guide

Re: XR500 QoS, UPnP issue with VLAN tagging.

this issue has not been fixed yet, and guess what? seems like there is no fix at all. 

for everyone else having VLAN setup, be careful while cosndering the XR500 for your setup since you will find some main feaures not working properly.

 

thanks.  

Model: XR500| Nighthawk Pro Gaming Router
Message 8 of 20
Netduma-Fraser
NetDuma Partner

Re: XR500 QoS, UPnP issue with VLAN tagging.

Netgear confirmed with us this is a VLAN issue so we're working with them now on a fix.
Message 9 of 20
Huthayfa
Guide

Re: XR500 QoS, UPnP issue with VLAN tagging.

thanks, this is what I am looking to hear.

please even if you released a firmware fix for this issue, kindly send it to me soon, I can test it directly. 

good luck.

Message 10 of 20
Jacksonite
Aspirant

Re: XR500 QoS, UPnP issue with VLAN tagging.

I am having very similar issues with certain devices and media not playing. However as soon as i turn off the QOS every device and media works. Technical support is currently working on a new firmware. I am still waiting for them to call me back. I wonder if they fixed this issue on the xr700.

Model: XR500| Nighthawk Pro Gaming Router
Message 11 of 20
Netduma_Jack
NetDuma Partner

Re: XR500 QoS, UPnP issue with VLAN tagging.

Hi Jackson - are you using a VLAN setup too?

 

I wouldn't have expected a total shutdown though. Do you have Share Excess enabled on Bandwidth Allocation? Also make sure you haven't set Anti-Bufferbloat percentages too low. This guide will help: http://support.netduma.com/support/solutions/articles/16000077073-dumaos-optimal-settings-guide-qos-...

 

Message 12 of 20
Danny80916
Luminary

Re: XR500 QoS, UPnP issue with VLAN tagging.

@Jacksonite

Hey I was wondering are devices Sony and 4k content as well ? I currently own a few Sony devices that are acting up With QoS on.

Model: XR500| Nighthawk Pro Gaming Router
Message 13 of 20
Jacksonite
Aspirant

Re: XR500 QoS, UPnP issue with VLAN tagging.

Samsung TV. Content type does not matter. It is only  certain servers and websites that it does not allow streaming. It might be the same issue with Sony. 4k  content requires higher traffic, so therefore the QOS might be blocking some of that traffic and not letting you view that media. I am still waiting for netgear to call me back. hopefully they come up with a solution. When they do i will make sure to upload it here as i know there are many of us in the same or similar situation. 

Message 14 of 20
Jacksonite
Aspirant

Re: XR500 QoS, UPnP issue with VLAN tagging.

So i just figured out something. Do not disable the QOS but set the antibufferbloat to NEVER with 70% on both download and upload. This worked for me.

Message 15 of 20
Jacksonite
Aspirant

Re: XR500 QoS, UPnP issue with VLAN tagging.

NVM!. it worked for a few seconds then it stopped again. All my devices and content work fine when i disable QOS. This is clearly a firmware issue with the QOS. I hope i dont have to return this router 😞

Message 16 of 20
Netduma_Jack
NetDuma Partner

Re: XR500 QoS, UPnP issue with VLAN tagging.

Could you walk me through your setup please:

 

  1. How are the affected devices connected? Wired?
  2. What are the total bandwidth speeds you have entered into Anti-Bufferbloat?
  3. What are the Anti-Bufferbloat sliders set to?
  4. What Anti-Bufferbloat mode do you have it set to?
  5. In Bandwidth Allocation, is Share Excess enabled on both upload and download (click the options menu to check)?
  6. Did you manually add any rules to Traffic Prioritization?

Thanks

Message 17 of 20
Jacksonite
Aspirant

Re: XR500 QoS, UPnP issue with VLAN tagging.

The affected devices are connected through a cat6. 

The  total bandwidth speed is at 97.5 on download and 9.8 upload.

The Anti-bufferbloat is set  to  "when high priority traffic is detected" at 83% on both download and upload. 

Share Excess is enabled on both areas.

 

I manually added  a rule for the xbox one only. 

 

 

Message 18 of 20
heidarren
Tutor

Re: XR500 QoS, UPnP issue with VLAN tagging.

I had mine solved by adding a switch to handle VLAN tagging between modem and router, I think they are too busy on marketing and making money, that's how business do.

VLAN issue?
IPV6 filter issue?

F yourself we r focus on money money money, marketing after marketing, you r paid customer so better stay at what u got out of the box and keep silent, don't waste our time, we now have XR700 and maybe XR1400 XR1800 XR199999999 for new customers, don't spoil our reputation it will hurts our money, don't touch our MONEY!!!
Message 19 of 20
Netduma-Fraser
NetDuma Partner

Re: XR500 QoS, UPnP issue with VLAN tagging.

If you disable Traffic Prioritization completely by disabling DumaOS Classified Games and your manual rule does that resolve the issue?
Message 20 of 20
Discussion stats
  • 19 replies
  • 8886 views
  • 4 kudos
  • 6 in conversation
Announcements

Orbi WiFi 7