Reply

Re: XR500 RApps Not Loading

Endorphine71
Apprentice

XR500 RApps Not Loading

Had a few questions for the NetDuma employees.  I posted a few weeks ago about the R-Apps not loading after setting up out of the box and doing the update to the current firmware.  I had to downgrade and go back to get them working again.  

 

Since then I have had the router go down once, around 12am on May 1st.  I believe this may have been due to the traffic monitor I had setup.  Seems like when it reset the router froze up.  Did a reboot and all was good.  What I didn't realize at the time, is the same R-Apps, QoS and Geo-Filter were not working again.

 

I was looking at the logs that are generated, and notice a bunch of fatal errors with the DumaOS trying to bind specific services.  The geofilter and qos services were throwing all types of errors.  The only thing I had enabled myself on the router was IPv6 with autoconfig and a few static IP assignement to a few Nest Cams.

 

I attempted to reboot the router a few times to get the R-Apps working again, but still erroring out.  The only way I got things to work was to disable IPv6, and then the R-Apps registered and finally worked again.  This is frustrating, as I bought the router for the QoS feature, and will be using it all the time.  Any other reports of this issue?  I would call into Netgear support, but know I will need to be on the phone awhile an routed around.  

 

[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Friday, May 04, 2018 10:11:51 [DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Friday, May 04, 2018 10:11:51 [DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Friday, May 04, 2018 10:11:51 [DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Friday, May 04, 2018 10:11:51 [DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Friday, May 04, 2018 10:11:51 [DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Friday, May 04, 2018 10:11:51 [DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Friday, May 04, 2018 10:11:51 [DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Friday, May 04, 2018 10:11:51 [DumaOS] Ubus object 'com.netdumasoftware.devicemanager' now bound, Friday, May 04, 2018 10:11:51 [DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Friday, May 04, 2018 10:11:52

[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Friday, May 04, 2018 10:12:04

[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Friday, May 04, 2018 10:12:23 [DumaOS] Ubus object 'com.netdumasoftware.devicemanager' now bound, Friday, May 04, 2018 10:12:23 [DumaOS] applying qos for zone wan, Friday, May 04, 2018 10:12:23 [DumaOS] applying qos for zone lan, Friday, May 04, 2018 10:12:23 [DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Friday, May 04, 2018 10:12:23 [DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Friday, May 04, 2018 10:12:23

[DumaOS] applying qos for zone wan, Friday, May 04, 2018 10:13:03 [DumaOS] applying qos for zone lan, Friday, May 04, 2018 10:13:04 [DumaOS] applying qos for zone wan, Friday, May 04, 2018 10:13:44 [DumaOS] applying qos for zone lan, Friday, May 04, 2018 10:13:44 [DumaOS] Marking device that is marked 192.168.1.130 46 16., Friday, May 04, 2018 10:13:45 [DumaOS] config write 'com.netdumsoftware.geofilter.settings', Friday, May 04, 2018 10:14:26 [DumaOS] config write 'com.netdumsoftware.geofilter.settings', Friday, May 04, 2018 10:14:26 [DumaOS] config write 'com.netdumsoftware.geofilter.settings', Friday, May 04, 2018 10:14:27

 

 

Model: XR500| Nighthawk Pro Gaming Router
Message 1 of 12
Netduma-Fraser
NetDuma Partner

Re: XR500 RApps Not Loading

I haven’t heard anything specifically like that before, is it all working now? If not do a factory reset from the settings and that should fix it. It’s very rare for specific apps to have trouble loading - please keep us informed and if possible of specific reproducible steps
Message 2 of 12
Endorphine71
Apprentice

Re: XR500 RApps Not Loading

Thank for sharing your experience.  I did decide on returing the XR500 to Amazon.  I kept having issues with the R-Apps not loading and having to do a factory reset to get things working.  It was also doing a full reset on ocassion for no reason at all.  If I turned on specific features, like IPv6 or set a static IP address for a device, things would just stop functioning.

 

I bought a new XR500 off Costco.com, as they have a deal right now where you get a free S8000 switch.  Not a bad deal for an $80 switch.  Also, Costco has an excellent return policy for most things.  The router doesn't fall under their 90 day limit on some electronics.  Also got another 2 year warranty for using my Costco VISA on top of the 1 year manufacture warranty.

 

The second one worked like a charm out of the box, no issues withe R-Apps or upgrading the firmware automatically out of the box.  The only thing that happened is on the second night of use, I was up playing my PS4, and it said it lost WiFi connectivity.  I check on my iPhone and nothing is showing up for wireless, not even the 2 seperate guest networks I setup.

 

I go look at the router, and all the lights are blinking like normal, except the "Internet" one is amber, not white.  Hmm.. maybe Comcast is down.  Go to my desktop PC connected with Ethernet to the router.  Some things are loading, but I cannot get to the cable modem admin page or go to some websites.  Some are loading, others are not.  Check the NetDuma status page and it shows the Internet connection is down (which it is clearly not), and an IP of 0.0.0.0

 

I cycle the cable mode (Netgear CM500) and the router again.  Same result.  Wifi dead, but lights show white and blinking.  Status page shows no internet.  I look at the IPv6 page and it is getting a WAN address from the modem, but still not working for good old IPv4.  I can still load some pages like Facebook and G-Mail, but no CNN (ha ha). Crap.

 

I have to do a factory reset to get it working again.

 

So not looking good so far for router attempt two.  Seems like setting IPv6 to autodetect is causing some issues.  Guess I will turn it off for now.  Everything else with this one is rock solid when it comes to WiFi performance and range.  I bought it for the NetDuma OS firmware though.  Hope this thing gets better with time.  If not at least Costco has my back.

Message 3 of 12
Netduma-Fraser
NetDuma Partner

Re: XR500 RApps Not Loading

Sorry to hear you returned it but glad to hear the new one is serving you a bit better.

For Wireless can you disable smart connect and connect to the separate band and see if that resolves the issue please.

Are you using PPPoE by any chance? If so make sure it's set to Always On and the disconnect should not happen again.

With IPv6 if you set it manually does it work as expected?

If we can replicate any of the issues then we can fix them, so as much information or reproducible steps you can provide will be very helpful.
Message 4 of 12
Endorphine71
Apprentice

Re: XR500 RApps Not Loading

Router 5 Ghz acting strange, rebooted router and the QoS and Geo-Filter now do not work.  Great, another router with the same issues.

 

[DumaOS] Long call 'dualreserve' exception 'ERROR: Subfield already reserved. stack traceback: ^I?: in function '__new__' ^I?: ,n function '?' ^I?: in function ^I(tail call): ? ^I?: in function '?' ^I?: in function 'dual_reserve' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I[C]: in function 'run' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, May 15, 2018 21:52:33 [DumaOS] Exception caught in 'com.netdumasoftware.qos': ERROR: Subfield already reserved. stack traceback: ^I?: in function '__,ew__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function 'long_call' ^I?: in function 'init' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:52:33 [DumaOS] Long call 'del_rule' exception 'ERROR: Rule not found in chain stack traceback: ^I?: in function '__new__' ^I?: in fun,tion '?' ^I?: in function ^I(tail call): ? ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, May 15, 2018 21:52:33 [DumaOS] Exception caught in cleanup 'com.netdumasoftware.qos': ERROR: Rule not found in chain stack traceback: ^I?: in functio, '__new__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function ^I(tail call): ? ^I(tail call): ? ^I?: in function '?' ^I?: in function 'cleanup' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:52:33 [DumaOS] Restarting 'com.netdumasoftware.qos' for 2 time, Tuesday, May 15, 2018 21:52:33 [DumaOS] subscribe to 'com.netdumasoftware.devicemanager' from 'com.netdumasoftware.qos', Tuesday, May 15, 2018 21:52:33 [DumaOS] Long call 'dualreserve' exception 'ERROR: Subfield already reserved. stack traceback: ^I?: in function '__new__' ^I?: ,n function '?' ^I?: in function ^I(tail call): ? ^I?: in function '?' ^I?: in function 'dual_reserve' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I[C]: in function 'run' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, May 15, 2018 21:52:37 [DumaOS] Exception caught in 'com.netdumasoftware.qos': ERROR: Subfield already reserved. stack traceback: ^I?: in function '__,ew__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function 'long_call' ^I?: in function 'init' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:52:37 [DumaOS] Long call 'del_rule' exception 'ERROR: Rule not found in chain stack traceback: ^I?: in function '__new__' ^I?: in fun,tion '?' ^I?: in function ^I(tail call): ? ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, May 15, 2018 21:52:37 [DumaOS] Exception caught in cleanup 'com.netdumasoftware.qos': ERROR: Rule not found in chain stack traceback: ^I?: in functio, '__new__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function ^I(tail call): ? ^I(tail call): ? ^I?: in function '?' ^I?: in function 'cleanup' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:52:37 [DumaOS] Giving up restarting 'com.netdumasoftware.qos', Tuesday, May 15, 2018 21:52:37

Message 5 of 12
Endorphine71
Apprentice

Re: XR500 RApps Not Loading

[DumaOS] Exception caught in 'com.netdumasoftware.geofilter': ERROR: Ubus error: 7 stack traceback: ^I?: in function '__new__' ,I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function 'long_call' ^I?: in function 'init' ^I?: in function ^I?: in function ^I[C]: in function 'run' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:43 [DumaOS] Long call 'destroy_chain' exception 'ERROR: No chain matching description stack traceback: ^I?: in function '__new__' ,I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, May 15, 2018 21:51:43 [DumaOS] Exception caught in cleanup 'com.netdumasoftware.geofilter': ERROR: No chain matching description stack traceback: ^I?, in function '__new__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function 'long_call' ^I?: in function 'chains_destroy' ^I?: in function 'uninstall_gf' ^I?: in function 'cleanup' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:43 [DumaOS] Restarting 'com.netdumasoftware.geofilter' for 0 time, Tuesday, May 15, 2018 21:51:43 [DumaOS] subscribe to 'com.netdumasoftware.devicemanager' from 'com.netdumasoftware.geofilter', Tuesday, May 15, 2018 21:51:43 [DumaOS] subscribe to 'com.netdumasoftware.dpiclass' from 'com.netdumasoftware.geofilter', Tuesday, May 15, 2018 21:51:43 [DumaOS] Exception caught in 'com.netdumasoftware.geofilter': address already in use -> stack traceback: ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:44 [DumaOS] Forked R-App exit 'com.netdumasoftware.geofilter', Tuesday, May 15, 2018 21:51:44 [DumaOS] Geo-Filter cloudsync result 'true','Geo-Filter is up to date', Tuesday, May 15, 2018 21:51:44 [DumaOS] Long call 'reserve' exception 'ERROR: Subfield already reserved. stack traceback: ^I?: in function '__new__' ^I?: in f,nction '?' ^I?: in function ^I(tail call): ? ^I?: in function '?' ^I?: in function 'reserve' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I[C]: in function 'run' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, May 15, 2018 21:51:44 [DumaOS] Failed to reserve subfields, Tuesday, May 15, 2018 21:51:44 [DumaOS] Exception caught in 'com.netdumasoftware.geofilter': ERROR: Subfield already reserved. stack traceback: ^I?: in functi,n '__new__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function 'long_call' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function '?' ^I?: in function 'init' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:44 [DumaOS] Long call 'destroy_chain' exception 'ERROR: Exec 'iptables -t mangle -X geomarkwhiteserver' failed with 1 stack traceb,ck: ^I?: in function '__new__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function 'safe_execute' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function '?' ^I?: in function ^I... ^I[C]: in function 'run' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, May 15, 2018 21:51:44 [DumaOS] Exception caught in cleanup 'com.netdumasoftware.geofilter': ERROR: Exec 'iptables -t mangle -X geomarkwhiteserver' fa,led with 1 stack traceback: ^I?: in function '__new__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function 'long_call' ^I?: in function 'chains_destroy' ^I?: in function '?' ^I?: in function '?' ^I?: in function 'cleanup' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:44 [DumaOS] Restarting 'com.netdumasoftware.geofilter' for 1 time, Tuesday, May 15, 2018 21:51:44 [DumaOS] subscribe to 'com.netdumasoftware.devicemanager' from 'com.netdumasoftware.geofilter', Tuesday, May 15, 2018 21:51:44 [DumaOS] subscribe to 'com.netdumasoftware.dpiclass' from 'com.netdumasoftware.geofilter', Tuesday, May 15, 2018 21:51:44 [DumaOS] Exception caught in 'com.netdumasoftware.geofilter': address already in use -> stack traceback: ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:44 [DumaOS] Forked R-App exit 'com.netdumasoftware.geofilter', Tuesday, May 15, 2018 21:51:44 [DumaOS] Geo-Filter cloudsync result 'true','Geo-Filter is up to date', Tuesday, May 15, 2018 21:51:44 [DumaOS] Long call 'reserve' exception 'ERROR: Subfield already reserved. stack traceback: ^I?: in function '__new__' ^I?: in f,nction '?' ^I?: in function ^I(tail call): ? ^I?: in function '?' ^I?: in function 'reserve' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I[C]: in function 'run' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, May 15, 2018 21:51:44 [DumaOS] Failed to reserve subfields, Tuesday, May 15, 2018 21:51:44 [DumaOS] Exception caught in 'com.netdumasoftware.geofilter': ERROR: Subfield already reserved. stack traceback: ^I?: in functi,n '__new__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function 'long_call' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function '?' ^I?: in function 'init' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:44 [DumaOS] Long call 'del_rule' exception 'ERROR: Rule not found in chain stack traceback: ^I?: in function '__new__' ^I?: in fun,tion '?' ^I?: in function ^I(tail call): ? ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, May 15, 2018 21:51:44 [DumaOS] Exception caught in cleanup 'com.netdumasoftware.geofilter': ERROR: Rule not found in chain stack traceback: ^I?: in f,nction '__new__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function 'long_call' ^I?: in function '?' ^I?: in function 'install_framework' ^I?: in function 'cleanup' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:44 [DumaOS] Restarting 'com.netdumasoftware.geofilter' for 2 time, Tuesday, May 15, 2018 21:51:44 [DumaOS] subscribe to 'com.netdumasoftware.devicemanager' from 'com.netdumasoftware.geofilter', Tuesday, May 15, 2018 21:51:44 [DumaOS] subscribe to 'com.netdumasoftware.dpiclass' from 'com.netdumasoftware.geofilter', Tuesday, May 15, 2018 21:51:44 [DumaOS] Exception caught in 'com.netdumasoftware.geofilter': address already in use -> stack traceback: ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:44 [DumaOS] Forked R-App exit 'com.netdumasoftware.geofilter', Tuesday, May 15, 2018 21:51:44 [DumaOS] Geo-Filter cloudsync result 'true','Geo-Filter is up to date', Tuesday, May 15, 2018 21:51:45 [DumaOS] Long call 'reserve' exception 'ERROR: Subfield already reserved. stack traceback: ^I?: in function '__new__' ^I?: in f,nction '?' ^I?: in function ^I(tail call): ? ^I?: in function '?' ^I?: in function 'reserve' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I[C]: in function 'run' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, May 15, 2018 21:51:45 [DumaOS] Failed to reserve subfields, Tuesday, May 15, 2018 21:51:45 [DumaOS] Exception caught in 'com.netdumasoftware.geofilter': ERROR: Subfield already reserved. stack traceback: ^I?: in functi,n '__new__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function 'long_call' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function '?' ^I?: in function 'init' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:45 [DumaOS] Long call 'del_rule' exception 'ERROR: Rule not found in chain stack traceback: ^I?: in function '__new__' ^I?: in fun,tion '?' ^I?: in function ^I(tail call): ? ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, May 15, 2018 21:51:45 [DumaOS] Exception caught in cleanup 'com.netdumasoftware.geofilter': ERROR: Rule not found in chain stack traceback: ^I?: in f,nction '__new__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function 'long_call' ^I?: in function '?' ^I?: in function 'install_framework' ^I?: in function 'cleanup' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:45 [DumaOS] Giving up restarting 'com.netdumasoftware.geofilter', Tuesday, May 15, 2018 21:51:45 [DumaOS] Exception caught in 'com.netdumasoftware.qos': ERROR: Ubus error: 7 stack traceback: ^I?: in function '__new__' ^I?: i, function '?' ^I?: in function ^I(tail call): ? ^I?: in function 'rpc_call' ^I?: in function '?' ^I?: in function '?' ^I?: in function '?' ^I?: in function 'init' ^I?: in function ^I?: in function ^I[C]: in function 'run' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:46 [DumaOS] Long call 'del_rule' exception 'ERROR: Rule not found in chain stack traceback: ^I?: in function '__new__' ^I?: in fun,tion '?' ^I?: in function ^I(tail call): ? ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, May 15, 2018 21:51:46 [DumaOS] Exception caught in cleanup 'com.netdumasoftware.qos': ERROR: Rule not found in chain stack traceback: ^I?: in functio, '__new__' ^I?: in function '?' ^I?: in function ^I(tail call): ? ^I?: in function ^I(tail call): ? ^I(tail call): ? ^I?: in function '?' ^I?: in function 'cleanup' ^I?: in function '?' ^I?: in function ^I[C]: in function 'xpcall' ^I?: in function 'try' ^I?: in function ^I?: in function 'try' ^I?: in function ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ? Tuesday, May 15, 2018 21:51:46 [DumaOS] Restarting 'com.netdumasoftware.qos' for 0 time, Tuesday, May 15, 2018 21:51:46 [DumaOS] subscribe to 'com.netdumasoftware.devicemanager' from 'com.netdumasoftware.qos', Tuesday, May 15, 2018 21:51:46

Message 6 of 12
Endorphine71
Apprentice

Re: XR500 RApps Not Loading

Turned off IPv6, rebooted and working again. 

 

 

 

DumaOS] config write 'com.netdumasoftware.devicemanager.database', Tuesday, May 15, 2018 22:04:04

[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Tuesday, May 15, 2018 22:04:05

'com.netdumasoftware.devicemanager' now bound, Tuesday, May 15, 2018 22:04:05

[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Tuesday, May 15, 2018 22:04:05

[DumaOS] Ubus object 'com.netdumasoftware.geofilter' added, attempting to bind pending, Tuesday, May 15, 2018 22:04:07

[DumaOS] applying qos for zone wan, Tuesday, May 15, 2018 22:04:07

[DumaOS] NSS delete root for interface 'brwan', Tuesday, May 15, 2018 22:04:08

[DumaOS] applying qos for zone lan, Tuesday, May 15, 2018 22:04:08

[DumaOS] NSS delete root for interface 'br0', Tuesday, May 15, 2018 22:04:08

[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Tuesday, May 15, 2018 22:04:08

[DumaOS] Ubus object 'com.netdumasoftware.devicemanager' now bound, Tuesday, May 15, 2018 22:04:08

[DumaOS] Ubus object 'com.netdumasoftware.qos' added, attempting to bind pending, Tuesday, May 15, 2018 22:04:08

[DumaOS] applying qos for zone wan, Tuesday, May 15, 2018 22:04:08

[DumaOS] applying qos for zone lan, Tuesday, May 15, 2018 22:04:08

 

 

Message 7 of 12
Netduma-Fraser
NetDuma Partner

Re: XR500 RApps Not Loading

That's really weird, what error were you seeing on the Geo-Filter and QoS page? I've made a ticket for this issue, sounds like it may be related to IPv6. Please keep it disabled for now (IPv6 does not provide benefit over IPv4 anyway) and see if it continues to work as expected.
Message 8 of 12
Endorphine71
Apprentice

Re: XR500 RApps Not Loading

It was timing out and giving the R-App Not Loading error.  All those errors were showing up in the logs.  It tired the 3 times to restart the app/service and failed.  Even after a reboot it was doing the same thing, until I disabled IPv6 Auto-Config setup, with a manually entered DNS entries.

 

 

Message 9 of 12
Netduma-Fraser
NetDuma Partner

Re: XR500 RApps Not Loading

Okay thanks for the additional info. The ticket has been created so the Developers can look into it, I've not seen that behaviour with other people on IPv6 so definitely seems to be an odd issue. Could you describe your physical setup please?
Message 10 of 12
Endorphine71
Apprentice

Re: XR500 RApps Not Loading

Along with the XR500 router, a Netgear CM500 cable modem that is connected to Comcast.

I have mutiple computers around the house.  One Win 10 PC that is connected with a Netgear A7000 wireless adapter, and 3 MacBooks.

 

When this happened I had the Win 10 PC hooked up to the router with Ethernet, but verified the same symptoms on a MacBook Pro.

 

I have around 35 devices connected to the router all at once.  Most of them are Nest cameras and/or smoke detectors, assorted IoT devices.

Message 11 of 12
Netduma-Fraser
NetDuma Partner

Re: XR500 RApps Not Loading

Great thanks for the additional info, have updated the ticket to include this.
Message 12 of 12
Discussion stats
  • 11 replies
  • 5479 views
  • 2 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E