× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Orbi WiFi 7 RBE973

Re: XR500 only has usb2 light soild


XR500 only has usb2 light soild

Okay so I have a xr500 night hawk router that when powered on no other light come on but the usb2. The led switch on the back is on. Now if I plug in my cable from the back of my computer to port 1 on the router the led on the front blinks like it is receiving and sending. Upon going deeper in to the setting on my pc under network connections right click and details my computer is sending packets but not receiving. I have downloaded the earliest firmware and tried flashing it with tftp on command and using the tftpd64 utility with no luck i also tried using factory ddet firmware nothing. i also tried nmrpflash. is this router just dead?

Message 1 of 7

Re: XR500 only has usb2 light soild

What happens if you disconnect everything from the router and press the reset button for a full 10 seconds then release. 

The POWER LED should be on soon after the reset beings. 

Check the volts and amps at the tip plug in to be sure that the volts and amps seen are what is on the power adapters sticker. 

Have you access the routers web page at after the reset happens after about a minute? 

Message 2 of 7
NetDuma Partner

Re: XR500 only has usb2 light soild

Are you actually receiving internet through devices connected via ethernet or WiFi?
Message 3 of 7

Re: XR500 only has usb2 light soild

The power adapter is the oem 12v 3.5amp. Now with nothing connected to it then a power cycle with only the power hooked up all the leds on the right half light up then go off and im stuck with only the usb2 led on solid. the reset button seems to do nothing when pressed for 10sec.

Message 4 of 7

Re: XR500 only has usb2 light soild


Message 5 of 7

Re: XR500 only has usb2 light soild

And you can't access the web page at at all? 


Can try this as last restort:

Try a 30/30/30 reset:

With the router plugged in and powered on, depress the reset button for 30 seconds. This button is usually a tiny dot recessed into the back of the router. You may need a jeweler's screwdriver or a bent paperclip to access it.
While still holding down the button, unplug the router from its power source for another 30 seconds.
With the reset button still held down, turn the power back on and hold for another 30 seconds.


Or try:

Need to press the reset button for 30 seconds then release, then it send to PUT the command and upload the FW. 
Make sure you enable tftp: https://www.thewindowsclub.com/enable-tftp-windows-10
Video walk through using a tftp client. Use the built in one for windows 10 though. the video is more of an example of how its done:
I had a problem on a Windows 10 PC where this didn't work to use TFTP, so I switched to a Windows 7 PC and the TFTP worked.
Mac TFTP: https://www.petenetlive.com/KB/Article/0001247

Try nmrpflash:


I guess if any of this fails, the router is toast. 

Message 6 of 7

Re: XR500 only has usb2 light soild

on i did the 30 30 30 reset but i will try tftp and use the reset button method as i have only done it by turning the router off for 10 sec and powering it then hitting put i will let you know asap. also i am on windows 11 so that could also be a problem with tftp.

Message 7 of 7
Discussion stats
  • 6 replies
  • 1 kudo
  • 3 in conversation

Orbi 770 Series