Reply

Re: ssh problem with wifi on XR500 but works fine via ethernet

lardarse99
Aspirant

ssh problem with wifi on XR500 but works fine via ethernet

Hi hope someone can help here.

I have a windows 10 laptop that i`m trying to connect via putty ssh to a ubuntu server. The windows 10 box is connecting via wifi, and is on the same subnet as the linux server, so no routing is involved here. When i try and connect i get connection timeout after a while. I can ping the linux server and from the putty terminal i can telnet to it on port 22 and i get the ssh handshake greeting back. So looks like there is a problem with firewall stopping me.

I have tried to ssh without the wifi and plugged into the routers ethernet port and that works fine, so i know ssh is working both on the PC and linux box, but the problem is with the wifi. I tried turning off window defender firewall, but still had the problem. So i think there might be a block on the router side.

 

Any help would be great.

 

Regards 

Message 1 of 7
Netduma_Jack
NetDuma Partner

Re: ssh problem with wifi on XR500 but works fine via ethernet

Is Guest WiFi enabled on your XR500? Have you accidentally connected to that? I can't think of any reason why WiFI would not work, but Ethernet would (unless you have set some manual adapter setting rules?)

Message 2 of 7
lardarse99
Aspirant

Re: ssh problem with wifi on XR500 but works fine via ethernet

Hi Thanks for the reply.

No guest network isn`t active.

I have just changed back to my router that came from the ISP and tried with that, in the same network config, ie ethernet for linux server and wifi for win10 and that worked fine with putty ssh. So it looks like the router is blocking the establishing of the ssh connection. Like i say i can telnet to port 22 and get the header ok from my laptop, but the connection won`t establish. 

I turned off QOS and that made no difference at all

Message 3 of 7
Netduma-Fraser
NetDuma Partner

Re: ssh problem with wifi on XR500 but works fine via ethernet

You turned off QoS under Anti-Bufferbloats options? I assume you do not have the Geo-Filter enabled for the device?
Message 4 of 7
lardarse99
Aspirant

Re: ssh problem with wifi on XR500 but works fine via ethernet

Hi Thanks for the reply.

Yes i turned off QoS under Anti-Bufferbloats and that made no difference.

Nothing at the moment has been setup in the geo filters.

 

Is there anyway of putting in a rule to allow an established ssh connection between to boxes?

Message 5 of 7
lardarse99
Aspirant

Re: ssh problem with wifi on XR500 but works fine via ethernet

Hi 

Just to let you know and anyone else having the same kind of problem, i think i`ve found what the issue was here.

I enabled HT160 in the advance-advanced wireless settings. And now i`m able to shh connect from my laptop (wifi) to linux box (lan). I really don`t know why that would effect my ssh connection as that is i believe to do with wifi performace, and the performance on this laptop works fine, and i get the max speed on tests that my isp allows.

 

 

Message 6 of 7
Netduma-Fraser
NetDuma Partner

Re: ssh problem with wifi on XR500 but works fine via ethernet

Well done on finding the solution and posting back with an update. I would not have guessed that would have affected it but happy you managed to resolve it!
Message 7 of 7
Discussion stats
  • 6 replies
  • 1454 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E