Reply
Highlighted
Tutor

stack traceback error in logs

Hello,

I see the following ERROR in the logs freqently.  Should I be concerened?

 

Running V2.3.2.40, with an incredible uptime of 65 days with no incidents.  To be honest, i could never run this XR500 for more then a few days without needing a reboot, but for the last couple months its been flawless without any changes done oddly enough.  Maybe since the firewall can't restart thats why its stable?  lol.

 

[DumaOS] Long call 'fw_restart' exception 'ERROR: Unknown field stack traceback: ^I?: in function '__new__' ^I?: in function '?, ^I?: in function <?:469> ^I(tail call): ? ^I?: in main chunk ^I[C]: in function 'require' ^I?: in main chunk ^I?: in function <?:261> ^I(tail call): ? ^I/dumaos/api/cli.lua:48: in function </dumaos/api/cli.lua:30> ^I[C]: in function 'xpcall' ^I/dumaos/api/cli.lua:59: in main chunk ^I[C]: ?' Tuesday, April 16, 2019 22:51:44
[DumaOS] Unknown appid, Tuesday, April 16, 2019 22:51:44
Model: XR500|Nighthawk Pro Gaming Router
Message 1 of 6
Highlighted
NetDuma Partner

Re: stack traceback error in logs

I wouldn't worry about any log entries if you're not having any issues. They just show backend processes some of which fail sometimes but won't generally cause an issue.
Message 2 of 6
Guru

Re: stack traceback error in logs

Has a factory reset been performed since v40 was applied. Might try this if you just updated to v40 and continued to use the router with out a reset. Seen it were lingering code can still remain until a reset is performed. 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 3 of 6
Highlighted
Tutor

Re: stack traceback error in logs

I haven't done a factory reset in a while but can do that. Scared to touch it tho since its been so stable now.

I was mostly asking if the duma devs can make any sense or have seen such a nasty looking error?!?!

Model: XR500|Nighthawk Pro Gaming Router
Message 4 of 6
Highlighted
NetDuma Partner

Re: stack traceback error in logs

I would suggest you don't factory reset, you're not having issues so don't do anything. If it ain't broke don't fix it as they say. Errors can look nasty but they're quite common, as long as you're not experiencing any issues you can safely ignore it.
Message 5 of 6
Highlighted
Guru

Re: stack traceback error in logs

First do a back up of the routers config to file before doing a reset. Then see what happens after the reset with out loading the config. See if the logs still report these errors. If not, then re-load the saved config from file. 


@hharamis wrote:

I haven't done a factory reset in a while but can do that. Scared to touch it tho since its been so stable now.

I was mostly asking if the duma devs can make any sense or have seen such a nasty looking error?!?!


 


My Setup (Cable 900Mbps/50Mbps)>CAX80(Modem Mode)>RBK853 v3.2.16.6(Router Mode)

Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P, EX7500/EX7700, XR450 and WNHDE111
Message 6 of 6
Discussion stats
  • 5 replies
  • 788 views
  • 0 kudos
  • 3 in conversation
Announcements