Discussion stats
  • 9 replies
  • 757 views
  • 2 kudos
  • 4 in conversation
Announcements

Top Contributors
Reply
Highlighted
Tutor

Can't get Gigibit speeds from Nighthawk Routers (RAX45, R6400)

I have the RAX45 | Nighthawk (AX4300) but it wasn't on the list to select, so I'll pick the RAX40

https://www.netgear.com/support/product/rax45.aspx

https://www.netgear.com/home/products/networking/wifi-routers/rax45.aspx

 

My internet connection is GIG speed (1000mb) from Comcast / xFininity and it tests at 950mb as spec'd from their cable modem.

 

I'm using a Nighthawk as my router / AP, I only get 340mb from the ethernet port to my desktop (using Speedtest.net)

Btw, 5ghz from the Nighthawk gets me 375mb,

 

My setup (Windows 10, Dell Inspirion desktop, 5' ethernet runs)

 

After many seaches, I found many other users running into the same situation. They have 1000mb coming into their xFinity / Router or CM1000/1100 but can't get anything close to that coming out of their Nighthawk Router / AP

 

I have read numerous posts about turning off Device Control (which I have done), turn off QoS (did)  disable AX, turn off traffic meter, Change MTU, etc.

 

Is there an answer to this or am I stuck with line speeds well below 500mb??  which is just terrible given 950mb is coming into the Nighthawk

 

I just upgraded from the Nighthawk R6400 (AC1750), thinking that the firmware was buggy, the router was 5 years old, was built when there wasn't much gig speed, etc. I'm disappointed I'm back to where I was with the R6400

 

Thinking a new Nighthawk would be my answer, I puchased the A6-RAX45 but am not seeing any improvement on line speeds

 

Firmware Version V1.0.2.10_2.0.26

 

What are others doing in order to get to 900+ speeds from their Netgear routers??

 

Thanks

Model: RAX40|Nighthawk AX4 4-Stream WiFi Router
Message 1 of 10

Accepted Solutions
Highlighted
Initiate

Re: Can't get Gigibit speeds from Nighthawk Routers (RAX45, R6400)

Hey Christian,

 

thanks for the reply,  I ended up doing a factory reset on the router and that fixed my issue.  I am now getting full speeds.  So far its been working great since yesterday.

View solution in original post

Message 4 of 10

All Replies
Highlighted
Initiate

Re: Can't get Gigibit speeds from Nighthawk Routers (RAX45, R6400)

I have this router (RAX45) with the same issue.  Purchased it at costco and will be returning it soon If I cant figure out how to get decent speeds.

Message 2 of 10
Highlighted
NETGEAR Moderator

Re: Can't get Gigibit speeds from Nighthawk Routers (RAX45, R6400)

Hello mando41, 

 

May you check to see if setting the cable modem to modem mode only and having the Nighthawk act as the router produces the same results. 

 

Thanks,

Christian 

Message 3 of 10
Highlighted
Initiate

Re: Can't get Gigibit speeds from Nighthawk Routers (RAX45, R6400)

Hey Christian,

 

thanks for the reply,  I ended up doing a factory reset on the router and that fixed my issue.  I am now getting full speeds.  So far its been working great since yesterday.

View solution in original post

Message 4 of 10
Highlighted
NETGEAR Moderator

Re: Can't get Gigibit speeds from Nighthawk Routers (RAX45, R6400)

Hi mando41, 

 

Happy to hear!

 

Best,

Christian 

Message 5 of 10
Highlighted
Tutor

Re: Can't get Gigibit speeds from Nighthawk Routers (RAX45, R6400)

I went ahead and reset my old R6400 to factory setting, attached this to the 2nd connection on my xFinity Gig Router  to see if I get different results. I do not

 

The R6400 is set to AP only, the same top line speed of 300-350mb going through the router 

 

-- It's in  AP Mode

-- WMM is disabled

-- No access control (as it's not in router mode)

-- Firmware up to date (v.1.0.1.52_1.0.36)

-- Just 1 device connected to R6400 Wired - Surface running Windows 10

Model: R6400|AC1750 Smart WiFi Router
Message 6 of 10
Highlighted
Tutor

Re: Can't get Gigibit speeds from Nighthawk Routers (RAX45, R6400)

Wouldn't I have to sit on Comcast product support so that they then provisioned my new router?  that doesn't sound like a fun exercise

 

I'm going to call netgear and see if they can tell me why I can't get more than 350mb out of this new router I just bought

Model: R6400|AC1750 Smart WiFi Router, RAX40|Nighthawk AX4 4-Stream WiFi Router
Message 7 of 10
Highlighted
Tutor

Re: Can't get Gigibit speeds from Nighthawk Routers (RAX45, R6400)

I'm getting around 800+mb down /40mb up using Speedtest app, to my Surface, direct connection to xfinity gig router , not the 950mb down I was getting a few days ago.  It's eary evening, could be just the time of day

 

Model: R6400|AC1750 Smart WiFi Router, RAX40|Nighthawk AX4 4-Stream WiFi Router
Message 8 of 10
Highlighted
Tutor

Re: Can't get Gigibit speeds from Nighthawk Routers (RAX45, R6400)

I can't select RAX45 in the Model Field so choosing RAX40

 

3 things happened and now I can get ~950mb down  from my router

 

1. I upgraded Firmware on the RAX45 and suddenly I had a burst over 500mb (speedtest app) and then I tested again and was at 806mb . This was wired connection to my desktop

 

2. 15 minutes later I was getting less than 100mb and called Netgear support. I spent 30 minutes on support, while they did their magic, After they rebooted xFinity Modem,  I once again hit 900mb+ speeds (wired connection to Desktop running Windows 10)

 

3. I had an open issue with Netgear support and they recommended a change to MTU which I did
" On the WAN Setup page you would see an option " MTU Size(in bytes)". Change the value from 1500 to 1492"

Not convinced this did anything but made the change

 

4. Change Firewall setting on xFinity modem from Medium to Low. They could not tell me the difference, only that low was optimal setting for fastest connection.  I asked for more information on Firewall settings and they could not provide. 

 

It's now Day 2, I am still getting ~950mb down / 40mb up which is the fastest possible speed from the xFinity XB6 Router (1gb minus 50mb overhead)

 

Whichever step fixed this, I am not sure. My guess is that the new firmware / Firewall setting was part of this equation

 

Current Firmware is Firmware Version V1.0.2.20_2.0.31

 

Now onto my next troubleshooting which is my Extender 8000 - AC3000 Nighthawk Extender

Firmware Version: V1.0.1.206

From everything I read, this appears to be buggy firmware on this device. Like everyone else that has posted, sometimes it works great and other times I can't connect. I am also asked to reenter the Wifi password which seems to be fairly consistent with my setup.

My workaround - reboot the Extender. I'm hopeful they are working out these bugs as this seems to be a Netgear issues

 

My config 

 

xFinity XB6 Router ---> Nighthawk RAX45 --- Extender 8000 (AC3000)

Desktop connected via ethernet to RAX45 (now getting up to ~950mb down , 4-5ms ping)

Speed Tested on mult servers using www.speedtest.net application running on Desktop (Windows 10)

** It's important to try  multiple servers when using Speedtest, not all will register highest speeds)

 

 

 

Model: RAX40|Nighthawk AX4 4-Stream WiFi Router
Message 9 of 10
Highlighted
Aspirant

Re: Can't get Gigibit speeds from Nighthawk Routers (RAX45, R6400)

Disable traffic meter in advanced setup. I can max my gigabit internet now. 

 

Message 10 of 10