Reply
Highlighted
Follower

FireCube Apps not working with Nighthawk AX600 after firmware update.

New to this!!!

Bought this NETGEAR AX8 8-Stream router a few months ago (over 90 days) to try and help manage all of the devices now filling my home.

A couple of days in I realized my Netflix, Hulu, and amazon prime did not work on my fire cube or fire sticks. At first I believed it was an issue with having this router (NETGEAR) connected after my internet service providers router modem combo (arris). However everything else (Xbox gaming, netflix on the Xbox, WiFi on the phones etc...) all worked fine . So I called NETGEAR support and was transferred to some advanced troubleshooting guru. That all in all was able to fix the issue (not sure how) he said that it was a firmware issue. When I downloaded the app I had upgraded the firmware to the newest version. He (guru) apparently just took the new version away and it worked.

I just switched internet service providers and the installer used only the NETGEAR router. When he was setting it up he updated the firmware and now I am at square one. I called NETGEAR and they informed me that I would have to pay for them to help me over the phone because it has been more than 90 days (which I find ridiculous).

So my questions:
1. Can I fix this myself?

2. If so How? ( Do I re install the original firmware?) if I can how would I do that?
If not what if any solution is there?

Thank you in advance!!!
Model: RAX80|Nighthawk AX8 8-Stream WiFi Router
Message 1 of 2
Highlighted
Guru

Re: FireCube Apps not working with Nighthawk AX600 after firmware update.

The manual walks you through manually updating firmware on page 99 of the manual. You can use this and instead of slecting the most recent firmware, you can use the prior firmware to downgrade to. Older firmware can be found on the support site under downloads   +view previous versions.

Anytime you change firmware, make sure to do it over a hardwired connection.  Make sure to factory reset after downgrading as well. In fact, to me the RAX devices have responded well to factory resets anytime the firmware has been changed. It might be worth trying that first (as you'll need to reset after the downgrade anyway).

here's the support site. 

https://www.netgear.com/support/product/RAX80.aspx

 

CM2000-> Arris AX11000 W31-> GS716v2-> WAX***-AP
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 394 views
  • 0 kudos
  • 2 in conversation
Announcements