Reply
Aspirant

NightHawk RAX50 does not have labels on antennas

I just received my RAX50 this afternoon.  I was ready to get it open and get it fired up.  Finished work and shut all devices down to begin the install of my new router. 

No labels on the antennas.  A very simple thing.  Perhaps they no longer need to be connected in specific locations?   Perhaps these antennas are knock-offs, ordered cheaply?  I don't know and I don't care at this point.  I was looking for a quick answer so I knew what my next step would be.   There is no way, that I found, to contact support unless you create an account with them and register the product.

I decided to check here because communities like this one are often the holy grail when it comes to product support and knowledge.

 

I see at least one other is having the same issue and his post has been here all day.  I do not know if others have this issue and maybe have spoken up sooner, or if they already had accounts and contacted Netgear directly.  Either way, I don't see how a company would not have this community monitored for cases such as this one. 

 

I am thinking I should go ahead and return this immediately, if the support level is this bad.  I had read some reviews but thought they might be exaggerating.   Nope!   It is that bad.  I don't know that I can trust this company with my new remote-work status.

 

So, have any of you fine people found any news regarding this manufacturing, packing, or communication issue?  Smiley Happy

 

Message 1 of 6

Accepted Solutions
Apprentice

Re: NightHawk RAX50 does not have labels on antennas

The early one's appeared to have specific inner and outer antennas.  The latest builds do not, all 4 are the same so you are good.

 

Make sure you download the latest firmware (.72 I  believe at the moment) and update it from a wired connection before you make any changes.  Then factory reset and make any of your own custom settings ( like ssid and passwords).  This router should be nice and stable for you on this latest version.

View solution in original post

Message 2 of 6

All Replies
Apprentice

Re: NightHawk RAX50 does not have labels on antennas

The early one's appeared to have specific inner and outer antennas.  The latest builds do not, all 4 are the same so you are good.

 

Make sure you download the latest firmware (.72 I  believe at the moment) and update it from a wired connection before you make any changes.  Then factory reset and make any of your own custom settings ( like ssid and passwords).  This router should be nice and stable for you on this latest version.

View solution in original post

Message 2 of 6

Re: NightHawk RAX50 does not have labels on antennas

Now that printed manuals are rare, I suspect that you did not get one when you bought this device.

 

Visit the support pages:

Support | NETGEAR

and feed in your model number and check the documentation for your hardware.

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 3 of 6
Aspirant

Re: NightHawk RAX50 does not have labels on antennas

I thought it might be a communicatioin issue on Netgear's part.  I did a bit of research and did not find the information you provided, however, and thus my frustration.

I've already returned the router.   It may be a great router, but the fact that this information is not readily available worries me, since as I said above, I've read very negative reviews concerning the support at netgear, and I have experienced difficulty in getting a simple answer.   I can't wait 3 or 4 days for a response to such a simple communication issue if I need to be connected to work right now.

 

Thank you for your response and the information, Dan32.  I knew the community would be helpful and knowledgeable.

 

Message 4 of 6
Aspirant

Re: NightHawk RAX50 does not have labels on antennas

Thank for the advice, Michael, but the documentation is inaccurate.  While I did not read the entire manual, I read the part that concerns attaching antennas, and if there was a change in the way this is done it should be noted right there.  As of now, it still says to make certain the labels match up, and the antennas must be connected to the correct antenna post.  Poor quality control and communication from Netgear, in my opinion.

Users Manual 

 

 

Message 5 of 6
Aspirant

Re: NightHawk RAX50 does not have labels on antennas

I had an email exchange with NetGear supoort on this topic of a period of a week. The bottom-line is that there has been an update to the RAX50, new firmware means that the antennas do not need to be in any specific position, there has been a change from the prior version and the documentation is up-to-date.

 

Below are my specific questions:

a) It is normal for the antennas NOT to be labelled. Correct? Yes, correct.
b) The antennas used to be labeled for side and back, but this is no longer the case. Correct? Yes, correct. You can attach them anywhere.
c) Based on your email, the firmware updates have enabled the change mentioned in (b). Yes, correct

 

So, it should be fine. I had the same question. I do not have an noticable degradation in the performance.

Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 550 views
  • 1 kudo
  • 4 in conversation
Announcements