Purchased Armor But Nighthawk App States Expired



I recently purchased an Armor subscription but when I use my nighthawk app the summary page Security section states Expired -off

However, when I login to the website it shows that I have 332 days remaining. Whenever I use the nighthawk app and click on the security section it brings me to a subscription page. Something is out of sync. I tried to open a netgear support ticket but my rax80 was purchased last year and they won't allow me to open a case. Any guidance / advice will be most appreciated.




Model: RAX80|Nighthawk AX8 8-Stream WiFi Router
Message 1 of 3

Re: Purchased Armor But Nighthawk App States Expired

I have the same problem. Contacted Bitdefender several times who have not been of much help and still haven't resolved the issue after 3 weeks. No reply since sending router ID and MAC address over 10 days ago.

I have tried:

  1. Restarting router several times
  2. Deleted the Nighthawk app and re-installed
  3. Installed Nighthawk on a spare iPhone
  4. Disabled//Enabled remote management from Nighthawk.
  5. Router reset

After router reset it now says Not Activate, but then doesn’t find my subscription and offers a trial, which then gets an activation error. 


Model: RAX120|Nighthawk AX12 12-Stream WiFi Router
Message 2 of 3

Re: Purchased Armor But Nighthawk App States Expired

I have the same issue.  App on my phone says Security Expired - Off. I have a receipt and our card was charged.  When I login to my PC it says it's on, but the Security button isn't clickable. 

Model: R6400|AC1750 Smart WiFi Router
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 0 kudos
  • 3 in conversation