Discussion stats
  • 9 replies
  • 396 views
  • 2 kudos
  • 4 in conversation
Announcements

Top Contributors
Reply
Highlighted

RAX 40 5ghz useless

I got this router in December. The last few months I did a full factory restore on it twice. No matter what 5Ghz channel I select device won’t stay connected. I used WiFi Analyzerr to find the best channels etc. The router is becoming a pricey paperweight. Wired and 2.4Ghz work fine. I have heard some people say the firmware is to blame, but it has not been updated in ages. Can anyone tell me a stable firmware to try, or even a beta one? I am working from home and 2.4Ghz is kind of slow... thanks!
Model: RAX40|Nighthawk AX4 4-Stream WiFi Router
Message 1 of 10
Highlighted
NETGEAR Moderator

Re: RAX 40 5ghz useless

Hello scott200lhs, 

 

Welcome to the community! May you try disabling AX to see if there any improvements. 

 

Christian 

Message 2 of 10
Highlighted

Re: RAX 40 5ghz useless

Hey. I have done that. Now my only device that won’t connect is an Acer Predator laptop. iPhone stayed connected all day but I had to roll back to the last firmware. I’m freaking annoyed. I’m assuming my laptop is the issue now. On newest firmware iPhone couldn’t stay on. It wasn’t given an IP address from router. Now the acer does that instead
Message 3 of 10
Highlighted
NETGEAR Moderator

Re: RAX 40 5ghz useless

Hi scottt2203lhs,

 

I would check to see if your laptop is due for a WiFi adapter update.

 

Christian 

Message 4 of 10
Highlighted

Re: RAX 40 5ghz useless

It is back to giving all devices issues. If I leave home and come back, 5ghz says wrong password and loses internet. 2.4 goes very slowly. At times all my laptops, including work ones, say no internet on both bands. But phones have internet working. Switch to an open Xfinity hotspot and it magically has internet on laptop. Can I get my money back? I have never had such a bad experience with a netgear product. It is so broken atm... I used netgear for years, and this is the worst. I see other threads with similar issues
Message 5 of 10
Highlighted
Aspirant

Re: RAX 40 5ghz useless

"wifi says wrong password"  YES!  Same issue here wiht RAX120.  Was also seeing wifi drop devices often and I'd have to manually reconnect.

 

Just did a factory reset and re-config by hand (no restore of backups).  We'll see if this clears up all of these issues.

 

 

Model: RAX120|Nighthawk AX12 12-Stream WiFi Router
Message 6 of 10
Highlighted

Re: RAX 40 5ghz useless

Please let me know if it does. I don’t wanna have a 200 dollar paper weight
Message 7 of 10
Highlighted
Initiate

Re: RAX 40 5ghz useless

I’m having the exact same issues. Factory reset didn’t help. Changing settings doesn’t help. This is hands down the worst WiFi router I’ve ever purchased!!! And Netgear support has been absolutely worthless. Telling everyone to stay away from Netgear products.
Message 8 of 10
Highlighted

Re: RAX 40 5ghz useless

I am so disappointed. This RAX lineup could’ve been amazing. They don’t care. I have seen no acknowledgement of problems by netgear staff in this thread or any other. I guess I will get a competitors product. I used only netgear for 15 years. No more. Thanks. You lost a customer for not caring about us or your broken firmware.
Message 9 of 10
Highlighted
NETGEAR Moderator

Re: RAX 40 5ghz useless

Hello Nighthawk AX Community, 

 

For those experiencing issues with their RAX40 and would like to be contacted by support, please send me a private message. Please provide me with your contact info and serial number. 

 

Christian 

Message 10 of 10