Reply

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

ronald_fr
Luminary

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

Hello,

 

I've changed ISP and got a brand new WIFI-6 router running 160MHz  + optional WIFI-6 repeter ... I don't need anymore the  RAX40 .... Happy !!!

 

BR

Ron

Model: RAX40|Nighthawk AX4 4-Stream WiFi Router
Message 201 of 390
aoeex
Guide

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

After experiencing the crashing for a while and posting about it, I had downgraded my router to firmware RAX40-V1.0.2.60_1.0.1 for a while to have a stable experience.

 

With the talk of a beta firmware I went ahead and upgraded again to 1.0.3.80 and opened a support case (on the last day of the window) to see if I could get a copy of the beta firmware but had no luck with that.  Curiously though, it's been almost a month now with 1.0.3.80 again and so far I've had no issues with it. 

 

No idea if the downgrade then later upgrade fixed the issue or if something about the wireless environment here has changed and caused it to be more stable.  Recently I even bought a new Wifi 6 adapter for my pc to see if that might cause the crash (previously I had no Wifi6 devices yet) and still it's been a week or so with no issues. 

 

Message 202 of 390

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

After complaining on the officiale Netgear FB page, I was contacted directly by the Italian Netgear support, I must say, very polite and capable.
They made me sign to get the beta firmware and since I installed it (V1.0.3.83_1.0.2) I had no more problems (on the same network I also have an EAX20 that was arguing a lot with the RAX40).
I activated AX and SmartConnect on both of them and finally I have a high performance Wi-Fi network without reboots or continuous bugs.
I'm still waiting a few days before exulting definitively but the premises are good.

Message 203 of 390
itsmehuey
Luminary

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log


@Gioel_Assecondi wrote:

After complaining on the officiale Netgear FB page, I was contacted directly by the Italian Netgear support, I must say, very polite and capable.
They made me sign to get the beta firmware and since I installed it (V1.0.3.83_1.0.2) I had no more problems (on the same network I also have an EAX20 that was arguing a lot with the RAX40).
I activated AX and SmartConnect on both of them and finally I have a high performance Wi-Fi network without reboots or continuous bugs.
I'm still waiting a few days before exulting definitively but the premises are good.


I've been on V1.0.3.83_1.0.6 for about 3 weeks now. I contacted them with updates regarding my experience about 2 weeks ago and yet they still haven't gotten back to me. Support has fallen off the face of the earth again for me. I'm hoping they finalise the new firmware soon, as I have a similar experience as you, albeit only 1 initial dropout on the first day after installing the beta. It's been MONTHS, I seriously don't understand why they're taking so long to finalise the firmware.

Message 204 of 390
jweaver4475
Aspirant

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

I'm using firmware 1.0.3.80 and have been experiencing issues, wifi dropped out today and some devices did not recconect without a reboot.     Could someone from support get me in the beta tester program? I would like to assist in finding bugs/issues with this device.

 

Also it seems that the router is changing channels or using other channels then the one selected, not even when using DFS channels.

 

Message 205 of 390
jweaver4475
Aspirant

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

Also I am only able to select channels 36-64 while using 160mhz (up to 2400mb/s),

Is this a bug? Should I be able to use UNII-3 channels 149-165?

I know only 149 or 150 whould give the full 160mhz wide channel.

Message 206 of 390
MrLRC
Aspirant

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

Thanks all for the info, my router has auto updated to 1.0.3.80 and broke itself, I used it for AP and suddently it stopped working.

 

Hard reset it and it failed to let me change SSID, password, region, everything. I can only use the standard SSID/password, what the heck.

 

Found this thread and I cannot believe almost 6 months now and they didn't fix the firmware, and the broken firmware is still auto updating to our router!

Model: RAX40|Nighthawk AX4 4-Stream WiFi Router
Message 207 of 390
itsmehuey
Luminary

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log


@MrLRC wrote:

Found this thread and I cannot believe almost 6 months now and they didn't fix the firmware, and the broken firmware is still auto updating to our router!


Have you tried disabling auto-update in the router's admin console?

Message 208 of 390
jweaver4475
Aspirant

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

I seen this post on the netgear RAX40 support page, probably not a great idea to run old firmware as it appears there is a security misconfiguration.
Security Advisory for Security Misconfiguration on RAX40, PSV-2019-0267

https://kb.netgear.com/000062356/Security-Advisory-for-Security-Misconfiguration-on-RAX40-PSV-2019-0...

They advise to update to the latest firmware. This is an issue is on firmware prior to 1.0.3.80. So if your running previous versions you could be at risk. Hopefully they fix the firmware but, it doesn’t seem like it.
I chatted with support and they couldn’t answer any questions I had about my router. Waited 45 minutes without a reply to a basic question and I’ve also posted a few questions on here but, it doesn’t seem like any netgear support are active in the community or they are just dodging any post about this router.
Message 209 of 390
itsmehuey
Luminary

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log


@jweaver4475 wrote:
 Waited 45 minutes without a reply to a basic question and I’ve also posted a few questions on here but, it doesn’t seem like any netgear support are active in the community or they are just dodging any post about this router.

Do what I did and have the matter escalated to L2 support by @Christian_R  Netgear support are really dropping the ball... I've been able to get in contact with L2 to provide me with a link to test out the beta firmware but apart from that, it's all radio silence since then.

Message 210 of 390
ninjadudexp
Aspirant

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

It blows my mind away that people can't share the firmware and that it's still not fixed but also that to get the firmware you need to call support in which they try and make you pay for fixing a product that is known to have issues. This is annoying I just went back to my wrt1900ac. I wish they would just publish the beta firmware that seems to work as I need the extra range for security cameras.
Message 211 of 390
Newfiedrool
Virtuoso

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

Beta firmware can be very unpredictable and some times the firmware is written to test on a select few devices with the aid of level 2 support.

This way they can control the whole process and find the results in an orderly method which means fixes are quicker.

 

 

Message 212 of 390

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

So let's see... I bought this POS about a year ago, it didn't work and it still doesn't work correctly.  The choice is constant disconnects or drop back to firmware thay has serious security issues.  Damned if you do and damned if you don't.  But wait!!!  There's beta firmware to correct the problem!  Aw-w-w, but you can't get it and there's no plan for general release.  Moderators are hiding under their desks.  Support wants you to PAY so they can tell you that they don't have a solution.  Sounds like a great deal to me.  What a flippin circle J!  Fix it or refund our money.  I'll be posting the CEO's email address and I encourage each of you to tell him about his RAX40 team.

Message 213 of 390
ninjadudexp
Aspirant

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

Couldn't agree more how can you have a product that just doesn't work at all. Not kind of not working but completely not working. I rather an unstable beta than absolutely no function at all.
Message 214 of 390
itsmehuey
Luminary

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log


@grumpyolman22 wrote:

So let's see... I bought this POS about a year ago, it didn't work and it still doesn't work correctly.  The choice is constant disconnects or drop back to firmware thay has serious security issues.  Damned if you do and damned if you don't.  But wait!!!  There's beta firmware to correct the problem!  Aw-w-w, but you can't get it and there's no plan for general release.  Moderators are hiding under their desks.  Support wants you to PAY so they can tell you that they don't have a solution.  Sounds like a great deal to me.  What a flippin circle J!  Fix it or refund our money.  I'll be posting the CEO's email address and I encourage each of you to tell him about his RAX40 team.


I agree with your sentiments, and this whole thing has been an absolute debacle. I still haven't gotten any further response from my case raised after I started testing the beta and I've made numerous follow ups. I've even asked @Christian_R to also follow up but still nothing..

Message 215 of 390
itsmehuey
Luminary

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

OK after weeks and numerous follow ups to my L2 support representative, they finally have another beta for me to test.. RAX40-V1.0.3.83_1.0.10 dated 4th November 2020


I'll be testing and monitoring over the course of the week and will report back my findings and experience with the update.

Message 216 of 390
ExcelsiorNY8
Aspirant

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

Yes reverting to previous firmware stabilizes the router. If I upgrade again it will render it useless, I’ve upgraded and downgraded several times. I have spent who knows how many hours on the phone with netgear support and they exchanged router for a new one. Issues still persist as soon as I upgraded to 1.0.3.80. This is a major issue since we are not able to use wpa3 unless we update firmware. Is a fix being worked on?
Message 217 of 390
itsmehuey
Luminary

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

Yes.. if you’ve been following the discussion around the forums a number of us have been testing beta versions which include numerous fixes. I don’t use WPA3 so cannot comment on that. However I haven’t had any dropouts with the latest beta I’ve been shared by the Netgear engineer and I have ax enabled and have not disabled anything.
Message 218 of 390
ExcelsiorNY8
Aspirant

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

@itsmehuey where did you get the beta your currently using? Do you have this engineer’s email? Thanks!
Message 219 of 390
itsmehuey
Luminary

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

Sorry but no I don’t have their email. So communications were done through Netgear level 2 support who were provided the beta firmware from the engineer team. You’d need to raise a support case with Netgear which will go to L1 support first. I had to go through so many hurdles and required the assistance of one of the mods here to escalate my initial support case to L2.
Message 220 of 390
vijaygopal81
Tutor

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

Could you share with us the beta firmware? 

Message 221 of 390
vijaygopal81
Tutor

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

Guys,


After 2 months of disconnection issues and frustration, things seems to have settled for me.  

 

This is what I did and I am sure that it has been already mentioned somewhere in this topic.  

 

Step 1: Upgraded to the latest Firmware - RAX40-V1.0.3.83_1.0.10 

Step 2: Downgraded to the previous Firmware version - RAX40-V1.0.3.64_1.0.1

Step 3: Reset using the reset button

Step 4: Reconfigured manually

 

Since 2 days now, things are smooth till now and no disconnections yet.  Fingers crossed.

Message 222 of 390
itsmehuey
Luminary

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

Beta cannot be shared unfortunately. It will be a breach of the T&C of use. It can only be obtained directly through support.
Message 223 of 390
vijaygopal81
Tutor

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

Ok no problem. But how is the performance of Beta? Did you face any issues since then? 
Also did they inform you when the final version will be out?

Message 224 of 390
itsmehuey
Luminary

Re: RAX40 Firmware 1.0.3.80 Crash/Bug Log

No issues so far. I am still going to test and monitor for at least 3-4 more days before I report back to the support team.

They did not inform when they are releasing the update as it is dependent on the feedback from the beta testers.
Message 225 of 390
Top Contributors
Announcements

Orbi WiFi 6E