RAX40 drops DNS queries

This device with Hardware R1.05 and now FW 1.03.80_1.0.1 has been very unreliable.

I've tried it behing two different cable modems and two different ISPs. I've been able to get good results with an Asus router and with a Unifi based network behind the cable modems so I feel the problem is in this router.

I am using 2.4 and 5G. I've tried Wifi6 on and off.

What happens is this: With IOT devices, PCs, Android phones there will be good and fast connectivity. Suddenly pages won't load and websites will be unreachable on different phones and different PCs. Sometimes all devices have the problem, sometimes only a few devices are effected. If you try to ping by IP it will work. If you try to ping by domain name it will fail. Using the program "ping tools" on Android I can see DNS lookup failure when this occurs. I have tried specifying Google DNS of and using cable modem/ISP default DNS servers. I'm pretty sure (but not 100%) it has also occured using Cloudfare private DNS on a Samsung phone. Sometimes switching between 2.4 and 5G networks solves the problems as does rebooting the router. If I switch immediately to a Unifi AP I can browse by domain name.

This problem occured with the previous FW. I've owned this more than 90 days so there is essentially no support since the tech on the phone said that if all the lights come on it isn't a hardware problem.

Model: RAX40|Nighthawk AX4 4-Stream WiFi Router
Message 1 of 3

Re: RAX40 drops DNS queries

I forgot to mention in my inital post that I did a paperclip factory reset before loading the lates FW.

Message 2 of 3

Re: RAX40 drops DNS queries

I am probably not as networking savvy as you might be but the latest FW for RAX40 made one of my extenders (EAX20) unusable. Wifi drops occasionaly on SmartConnect.

Cox Gigablast = CM1000 = RAX40 = N300/EAX20/EX7500
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation