Reply

RAX40 wifi issues

Casem0dder
Follower

RAX40 wifi issues

I've updated my network to support 500mbps. New cable modem with this new RAX40 router. I've successfully set it up with the app and it works flawless with my galaxy S10 device on wifi BUT my issue is my other devices cannot even detect my wifi network such as my laptops, tablets. I upgraded to the latest firmware that's available as it checked when I set it up with the app. All the wifi passwords were printed and saved. I logged out of the wifi with my galaxy S10 device and tried to connect again and router said incorrect password so I logged back in the router settings and it displayed the same password as how I set it up so I performed a hard reset on the router set it up all over again and same thing. The only device that can use the wifi is the galaxy S10 device. I disconnected the RAX40 from my setup and connected my asus router and it worked perfectly except as I cannot download my maximum speed so I know it's not any issue on my end. I have since boxed this rax40 back up thinking I got a defective unit. My question is why is this doing this or am I missing a setting I'm not checking on the initial setup.

Model: RAX40|Nighthawk AX4 4-Stream WiFi Router
Message 1 of 2
schumaku
Guru

Re: RAX40 wifi issues

Im case these unspecified laptops and tablets are Windows equipped with Intel wireless interfaces, you need current drivers ->  Intel® Driver and Support Assistant (Intel® DSA)

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 1517 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi WiFi 6E