Reply
Highlighted
Follower

RAX75 firmware update not working

I just purchased the RAX75 from Costco and am running into issues both automatically and manually updating the router firmware.  

 

Here's the setup:

- RAX75 on AP mode behind a Linksys SOHO router (wired)

- Firmware out of the box is 1.0.1.70_1.0.30

- Wired and wireless clients connected to the RAX75 has no issues with connecting amongst each other or to the internet

 

From this website, I can see that the latest firmware is 1.0.3.88.  In the web admin console, I checked for new firmware and got the firmware is up to date message.  I then downloaded the binary for the 1.0.3.88 firmware and tried to upload (over a wired and a wireless client), both of which resulted in the following message after uploading: 

 

"This firmware file is incorrect! Please get the firmware file again and make sure it is the correct firmware for this product."

 

I tried a different firmware version - 1.0.2.76 - and got the same error message, again on both clients.  

 

This is frustrating, seeing as this exact setup from an R7000 (which this replaces) worked just fine.  Can someone help me with what I might be able to do here?  

 

Model: RAX80|Nighthawk AX8 8-Stream WiFi Router
Message 1 of 2
Highlighted
NETGEAR Moderator

Re: RAX75 firmware update not working

Hello neverest5, 


Can you confirm you are using the following download link located at the bottom of this article. You may also try using the Nighthawk app to check for a firmware update. 

 

https://kb.netgear.com/000061901/RAX75-Firmware-Version-1-0-3-88

 

Christian 

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 298 views
  • 0 kudos
  • 2 in conversation
Announcements