Reply
Follower

RAX80 - a lot of issues

I bought this a week ago and have encountered many issues

 

1.  With smart connect - android/apple phones disconnects after a few hours and have to reboot to regain connection

 

Did factory reset to run without smart connect

 

2. Without smart connect - rax80 complained there is no internet connectivity and have to reboot to regain connection

 

The router is running with the latest firmware.   This is an expensive router and I am expecting it to work but with daily disconnections/inability to connect to the internet - it's been a massive disappointment.  Please advise how to to fix.

Model: RAX80|Nighthawk AX8 8-Stream WiFi Router
Message 1 of 2
Highlighted
Apprentice

Re: RAX80 - a lot of issues

I had the same issues with the RAX80 at the beginning after first connection & firmware update.

 

For me, a factory reset & reconfiguration with the Nighthawk App seemed to fix the behaviour.

I have good internet connection & Wifi with SmartConnect enabled.

 

For several other users (seems like yourself) the factory reset doesn't work.

Many users reported that downgrading to firmware .40 or .56 gives more stability & resolved these kind of issues.

However, I havent seen any comment from Netgear about whether these issues are known/accepted with the current firmware or if there are really changes to these functions between .40 or .56 firmware.

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 711 views
  • 0 kudos
  • 2 in conversation
Announcements