Reply
Donbossman
Aspirant

Xbox live party issues with AX8

I created an account to hopefully get this sorted. I google searched this issue and found one topic with no solution.

I can get on Xbox live just fine. The problem is when joining or creating a party, I’m instantly disconnected from Xbox live and my network reboots for some reason. When I log back in, I get a message saying my network is blocking party chat.

This wasn’t an issue before as I’ve had this router since launch. Everything worked fine before. Now it’s making playing Xbox live unbearable. And it’s connected via Ethernet.

I’m suspecting it’s the latest firmware. I’m on the verge of scrapping this router if there is no solution to this. I even stated in that post I found how Netgear’s firmware updates lately have been a joke.

Anyone else having this issue and found a solution? Thank you and advance.
Model: RAX80|Nighthawk AX8 8-Stream WiFi Router
Message 1 of 2

Re: Xbox live party issues with AX8

Have you sniffed around here for stuff on the Xbox? It is a constant theme.

 

Search - NETGEAR Communities – Xbox live

 

It seems that these devices can need some careful configuration.

 

Hard to tell if it is an Xbox or Netgear thing. Probably some subtle interaction.

 


@Donbossman wrote:

I’m suspecting it’s the latest firmware.


You could confirm that by rolling back to something older. Previous firmware exists on the support pages for the RAX80.

 

If you visit the support pages:

 

Support | NETGEAR

 

you can feed in the model number and find documentation and downloads for your hardware.

 

 

 

 

Just another user.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 1105 views
  • 0 kudos
  • 2 in conversation
Announcements