Reply
Highlighted
Follower

rax120 admin login authentication issues

I've got a weird authentication issues here.

I bought a RAX120 half a month ago and set up the router through Nighthawk app, everything worked fine until 3 or 4 days later I couldn't log into the router with correct admin password on routerlogin.net, neither can I recover the password with correct security answers. Then I tried hard reset the router but 3 or 4 days later same thing happened again.

I'm sure there's no type errors because I stored my password and security questions/answers in 1Password, I simply copy and paste them.

Any thoughts?

Model: RAX120|Nighthawk AX12 12-Stream WiFi Router
Message 1 of 2
Highlighted
NETGEAR Moderator

Re: rax120 admin login authentication issues

Hi rocevil,

 

If you recently purchased the device I would recommend contacting our support team as newly purchased devices are provided with 90 days of complimentary support. You may open a ticket by registering your device using the link below. 

 

https://www.netgear.com/support/contact.aspx

 

Christian 

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 108 views
  • 1 kudo
  • 2 in conversation
Announcements