Orbi WiFi 7 RBE973
Reply

AC2400 router randomly dropping Internet connection

eljayottawa
Guide

AC2400 router randomly dropping Internet connection

Hi.  I have an AC2400 router connected to a Rogers Ignite gateway that's acting only as a modem.  For the past couple of years, everything has worked flawlessly.  Connected devices include a NAS, a couple of laptops, a couple of streaming devices (e.g., Fire TV Stick, Roku Stick), an AVR and a couple of BD/DVD players.

 

About a week ago, the router started randomly dropping my internet connection throughout the day.  Dropouts last anywhere from 30 seconds to a couple of minutes and affect all connected devices.  While the dropouts are happening, the blinking-green status light on the Rogers gateway/modem indicates that it is connected to the 'net but not receiving a response from the router.

 

No new devices have been added recently, no settings have been altered and the router was running the latest version of firmware (I believe it was 1.2.0.88.*).

 

I have rebooted the router (and the gateway), reset the router and even rolled back the firmware (I believe the version on there now is 1.2.0.76.*).  No change.

 

Any straightforward fix for this?  Or is it time to toss the router and buy something more reliable (maybe an Asus)?  Please advise.

 

Thank you.

Message 1 of 8

Accepted Solutions
eljayottawa
Guide

Re: AC2400 router randomly dropping Internet connection

Follow-up and final comment: Turns out it wasn't the router or even the gateway/modem.  After several calls to Rogers and visits by 2 technicians, the problem was diagnosed as (a combination of) a badly corroded connection in the nearby network node and an unnecessary splitter in the cable box attached to the side of my house.  The connection was replaced, the splitter was removed...and everything seems to be working fine.  I'll be re-installing the router shortly.  Thanks again to plemans for the assistance.  🙂 

View solution in original post

Message 7 of 8

All Replies
eljayottawa
Guide

Re: AC2400 router randomly dropping Internet connection

I updated my initial post just now and when I tried to save it my internet connection had dropped...again.  The irony of it all.  Smiley Frustrated

Message 2 of 8
plemans
Guru

Re: AC2400 router randomly dropping Internet connection

what rogers gateway is it? 

Have you tried the rogers back in router mode and putting the netgear in access point mode? 

it wouldn't be the first time I've seen an ISP gateway get an update and break something in its modem only/passthrough mode. 

Message 3 of 8
eljayottawa
Guide

Re: AC2400 router randomly dropping Internet connection

I believe it's an XB7 Gen 2.  I haven't tried reverting it to router mode, but I can give that a try and see what happens.  Thanks for the suggestion.  🙂

Message 4 of 8
plemans
Guru

Re: AC2400 router randomly dropping Internet connection

I've seen a couple other posts lately running the xb7 in passthrough with drops. 

I'd try it in router mode and the AC2400 in access point mode. Maybe xfinity pushed out an update th at caused issues. 

Message 5 of 8
eljayottawa
Guide

Re: AC2400 router randomly dropping Internet connection

Update: I set the XB7 to router mode and the AC2400 to AP mode.  Same issue - the AC2400 randomly dropped connectivity.  So I reset both devices, set the XB7 as a modem and the AC2400 as a router, confirmed that the latest firmware was installed, and ensured that IPV6 was enabled in the router.  No luck.  Downloaded a WiFi analyzer app and set the 5GHz band to channel 36 (which had no other traffic on it).  That seemed to help...for about a day, and then the router resumed randomly dropping connectivity.  (Well over 30 dropouts so far today.)  Check the logs in both devices and I can't see anything that indicates any sort of critical error.  So, tomorrow it's time to try a new router.  Fingers crossed...

Message 6 of 8
eljayottawa
Guide

Re: AC2400 router randomly dropping Internet connection

Follow-up and final comment: Turns out it wasn't the router or even the gateway/modem.  After several calls to Rogers and visits by 2 technicians, the problem was diagnosed as (a combination of) a badly corroded connection in the nearby network node and an unnecessary splitter in the cable box attached to the side of my house.  The connection was replaced, the splitter was removed...and everything seems to be working fine.  I'll be re-installing the router shortly.  Thanks again to plemans for the assistance.  🙂 

Message 7 of 8
plemans
Guru

Re: AC2400 router randomly dropping Internet connection

glad it fixed the issue! if you mark your response as solved, it can help others with the similar problem and prevent others from trying to solve it 🙂

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 1468 views
  • 4 kudos
  • 2 in conversation
Announcements

Orbi WiFi 7