Orbi WiFi 7 RBE973

Re: Bug in R800P firmware v1.4.2.84_1.3.4?


Bug in R800P firmware v1.4.2.84_1.3.4?

Spent a lot of time troubleshooting this in the last two days, hopefully I can get some confirmation that I'm not losing my mind.

Relevant network setup:

  • Nighthawk R800P as my primary router (WAN from xfinity modem)
    • Xbox Series S plugged into LAN1
    • LAN4 runs into wall downstairs
  • Netgear WAX206 in AP mode running latest firmware (1.0.3, I believe?)
    • wall to WAN
    • Xbox Series X plugged into LAN1

Started seeing the following behavior after latest firmware applied to R800P

  • on both xbox consoles, periodic failures to report all network statistics, hit or miss as to how much can be reported vs 'unable to determine'
  • when this happens, even though I'm connected and online, the box acts as if it isn't online when attempting to start media content, erroring out with a message to connect to the network
  • BUT, if I close the error and retry, within three or four attempts I will just magically get past the issue and be able to watch whatever was erroring out

Once I revert to the previous firmware, I cannot replicate this issue. To be clear, the problem isn't permanent and consistent, but I could get it to reliably happen on both boxes within 2-3 restart/network checks. On previous firmware, I've tried upwards of 6-8 times on each console and don't see the error.


For now I will not apply the newest firmware, but I'm hoping someone can corroborate that I'm actually seeing a bug and not something else to troubleshoot/control on my end?


Thanks in advance! 

Model: R8000P|Nighthawk X6S AC4000 Tri Band WiFi Router
Message 1 of 6

Re: Bug in R800P firmware v1.4.2.84_1.3.4?

What is the Mfr and model# of the Internet Service Providers modem/ONT the NG router is connected too?

Have you connected the xbox consoles directly to the router to see if problem still continues? 

Does this still happen with the WAX206 turned OFF? 


Has a factory reset and setup from scratch been performed since last FW update then try to replicate the issue? 



Message 2 of 6

Re: Bug in R800P firmware v1.4.2.84_1.3.4?

I think my assumptions are wrong. After posting my message, I again saw the behavior on the Xbox Series X (downstairs wired to the WAX206). More interestingly, right now on the Xbox Series S wired to the R8000P, I'm seeing that NAT is now at STRICT and UPNP not successful. First time I've seen this message, so I'm kind of stuck, but thinking that it's actually an issue with having two Xbox consoles on the same network.

I should have mentioned in the beginning that the Series S is new to the network, added on the same day as when I did the firmware updates. I thought the problem was with a bad update, but now I don't think so.


To respond to your specific questions:

  • ISP modem: xfinity, XB7-CM
  • the Series S is directly connected to the R8000P
  • the Series X is directly connected to the WAX206
  • I have NOT tried connecting both to a single device, just didn't want to pull everything apart when it didn't seem a likely issue
  • Yes, it happened with the WAX206 OFF, which would mean it occurred at a time when the Nighthawk was the only router on the network and the Series S the only console on the network. NOTE: this is why I wasn't originally thinking that two consoles on the same network was an issue.
  • I have NOT done a factory refresh of the R8000P. I did the firmware revert, a firmware current, and then a firmware revert as part of testing, but never a factory refresh. I figured the firmware update covered the factory refresh, but maybe I'm wrong?

I am really lost here. I don't mess around with the network device settings so I don't know if I should be setting up static IP, port forwarding or anything else to help. I wouldn't even know how to do this if it was recommended. I also want to get my R8000P on latest firmware if this issue isn't a bug, but haven't updated yet until I can sort the overall problem out.


Any guidance you might have would be extremely appreciated!


Message 3 of 6

Re: Bug in R800P firmware v1.4.2.84_1.3.4?

"xfinity, XB7-CM" this already has a built in router and wifi. This would be a double NAT condition which isn't recommended. Especially for game consoles.

Couple of options,
1. Configure the modem for transparent bridge or modem only mode. Then use the NG router in router mode. You'll need to contact the ISP for help and information in regards to the modem being bridged correctly.
2. If you can't bridge the modem, disable ALL wifi radios on the modem, configure the modems DMZ/ExposedHost or IP Pass-Through for the IP address the NG router gets from the modem. 


Also you might set NAT FIlter to OPEN under Advanced Tab/Settings/WAN setup...


Message 4 of 6

Re: Bug in R800P firmware v1.4.2.84_1.3.4?

Thanks for the quick reply!

  1. I already have the xfinity modem in Bridge mode. Solved the double NAT issue as soon as I had the new modem in place many months ago 🙂
  2. I actually found this comment on reddit while searching for R8000P and two Xbox consoles, thinking that UPNP was a problem:

"On a relevant note, to get the R7000 working with multiple X1's (open NAT on both) you have to change a particular setting on the router itself. This is probably applicable to the R8000 as well. Remove any port forwards and disable triggering. Turn on UPnP Then go to advanced -> setup -> wan check disable sip alg and check open instead of secured Reset the boxes."


As it happens, on my device I don't have any port forwards in place, and port triggering isn't enabled as far as I can tell. But, I did see that for NAT filtering, Disable SIP ALG was not checked, and Secured was selected instead of Open. I assume this is what you are referring to in your comment. I don't know what SIP ALG means, but I've disabled it, selected open, and will now run some tests.


Message 5 of 6

Re: Bug in R800P firmware v1.4.2.84_1.3.4?

ALG should be left at default. Just set NAT Filter to OPEN. 

Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 0 kudos
  • 2 in conversation

Orbi WiFi 7