Orbi WiFi 7 RBE973
Reply

Netgear Router not working with modem

QBaaLLzz
Tutor

Netgear Router not working with modem

I have had a Netgear R6700 v3 and have used it at my old resident but switched houses and modem. I had to buy my own modem (motorola MB7621) this time, and couldn't get my internet to go through the router.

 

Techs with the company set up the modem and said everything worked great, all the lights on the router were lit up, including the internet status one, it was white after plugging in ethernet from modem, but when I logged into the router via wifi, it said internet connection status was offline/red, and ethernet got the same results.

 

When I plug into modem directly via internet, my computer works fine with internet.


I hard reset the router, took it to a friends and updated firmware and tested it with his modem and it worked fine, wifi and ethernet.

 

Where do I go from here? modem is brand new so I can return it hopefully, waiting on their support, Router is over a year old and Netgear's support is about as much as a new router costs, ridiculous...

 

Link to Modem https://www.motorola.com/us/mb7621/p

 

 

Model: R6700|Nighthawk AC1750 Smart WiFi Router
Message 1 of 13

Accepted Solutions
QBaaLLzz
Tutor

Re: Netgear Router not working with modem

I GOT IT TO WORK!

Log into router via ethernet/routerlogin.net
advanced->
Advanced setup->
IPv6->
I then did all auto config settings all the way down the list. Internet connection type is now DHCP, IPV6 address is get automatically, and LAN setup is auto config. I looked into the manual on the router about ipv6 because my ISP was giving me ipv4 and ipv6 options. If you have my problem look in the routers manual about ipv6. It must have been confused with ipv6 and ipv4. Hopefully this works for some down the road thanks for the assistance here!

View solution in original post

Message 11 of 13

All Replies
FURRYe38
Guru

Re: Netgear Router not working with modem

Swap LAN cables between modem and router. CAT6 is recommended.

Power OFF both Modem and Router for 1 minute, then back ON with the modem then router. Factory reset the router and walk thru it's setup wizard. 

 

Message 2 of 13
QBaaLLzz
Tutor

Re: Netgear Router not working with modem

I highly doubt cat6 is recommended being both modem and router didnt come with it. I tried both cat 5e cords that came with router and modem. Also tried my 100ft cat6 i had laying around. Didnt work.
Message 3 of 13
FURRYe38
Guru

Re: Netgear Router not working with modem

Well if the router worked before you got this new modem and doesn't work now, kinda points to the modem or something on the new modem that the router is not liking or handling right. 

 

Is the FW on the router up to date? 

 

Another user sent his 6 series router back as it would work his modem. The 6 series line of routers is getting to be a bit old and may not be compatible with newer modems. MIght try something newer with this new modem and see if it works. If not, then you know its the modem. If ti does work, then may point to the 6 series router. 

 

Message 4 of 13
QBaaLLzz
Tutor

Re: Netgear Router not working with modem

Firmware is up to date. Any suggestions on modems that would work with the 6 series? If those are considered old thats ridiculous. Id rather return the modem while i can, cant get my money back on router.

Edit: I can get on snapchat on my phone, and it will work thru wifi. Not sure if that points to anything
Message 5 of 13
FURRYe38
Guru

Re: Netgear Router not working with modem

Any of NGs CM series modems would work the the 6 series...

Message 6 of 13

Re: Netgear Router not working with modem


@FURRYe38 wrote:

 

Another user sent his 6 series router back as it would work his modem. 

 


Is there a NOT missing in there? 

 

If so, that is the first hint I have seen here that newer modems have left a router stranded. 

 

I would not give up on the modem router combination without further research.

 

Moving a router to a different ISP isn't just a case of a reset. There may also be some subtle settings that the ISP needs.

 

This might be useful:

 

Search - NETGEAR Communities

 

Local stuff on the motorola MB7621.

 

 

 

Message 7 of 13
QBaaLLzz
Tutor

Re: Netgear Router not working with modem

I spent 9hrs researching, calling isp, netgear and motorola. Ive exhausted everything. I think the problem lies with ISP, i think i need to configure router manually, not sure I can do that without ISP. But they keep saying its dynamic ISP, yet router isnt picking that up thru modem. I have three ips, the 2 to log in to router and modem, and there is an ISP when I log into modem that the ISP can see but cant give me any explanation on. It wont change they said
Message 8 of 13

Re: Netgear Router not working with modem


@QBaaLLzz wrote:
I think the problem lies with ISP, i think i need to configure router manually, not sure I can do that without ISP.


That seems likely to me. ISPs hate it when you buy your own equipment, they also seem to be clueless when it comes to questions about third party hardware. Fair enough given the many options available out there.

 

I can't see any mention of the ISP earlier in this discussion. (Perhaps I missed it.) But you could try to search the archive for that.

 

Some ISPs also have their own user groups. If your ISP has one, try there too.

 

One final thought, Netgear's routers do try to navigate these things with the setup wizard. Most of us ignore that, but if you haven't tried it, there is no harm on throwing it at your router. The R6700 isn't the fanciest box on the block, and is getting a bit old, albeit just three years for the V3 model, but it does claim to support the Internet Setup Wizard.

Message 9 of 13
QBaaLLzz
Tutor

Re: Netgear Router not working with modem

I tried the wizard on the routerlogin site and the nighthawk app. It says internet not connected. Im starting to think it has to be the router. I can connect direct to modem fine. Internet company is telling me it is a dynamic isp they provide not static or PPPoe
Message 10 of 13
QBaaLLzz
Tutor

Re: Netgear Router not working with modem

I GOT IT TO WORK!

Log into router via ethernet/routerlogin.net
advanced->
Advanced setup->
IPv6->
I then did all auto config settings all the way down the list. Internet connection type is now DHCP, IPV6 address is get automatically, and LAN setup is auto config. I looked into the manual on the router about ipv6 because my ISP was giving me ipv4 and ipv6 options. If you have my problem look in the routers manual about ipv6. It must have been confused with ipv6 and ipv4. Hopefully this works for some down the road thanks for the assistance here!
Message 11 of 13
wjnelson76
Initiate

Re: roterlogin.net did not work - resolved!

I spent an hour on not being able to log into the router. It was because in the windows network settings "network discovery" was turned off! I turned it on and connected immediately. Best to all.

Model: R9000|Nighthawk X10 AD7200 Smart WiFi Router
Message 12 of 13

Re: roterlogin.net did not work - resolved!


@wjnelson76 wrote:

I spent an hour on not being able to log into the router. It was because in the windows network settings "network discovery" was turned off! I turned it on and connected immediately. Best to all.


Ah. That one. There are various way in which Windows frustrates network access.

 

Well spotted and thanks for reporting back. It could help another victim later on.

 

This can also be useful in some circumstances:

 

Fix network connection issues in Windows 10

 

 

 

 

Message 13 of 13
Top Contributors
Discussion stats
  • 12 replies
  • 4274 views
  • 3 kudos
  • 4 in conversation
Announcements

Orbi 770 Series