Orbi WiFi 7 RBE973

Nighthawk X6S R8000P AC4000 FIrmware will not Update, fails to connect to Netgear Servers


Nighthawk X6S R8000P AC4000 FIrmware will not Update, fails to connect to Netgear Servers

I have been using Netgear products since they started spelling it with an 'N', but my current experience is anything but reassuring. I am about fed up trying to update my Nighthawk Router Model R8000P. I have been trying on and off since January to update my firmware from version In the last two days I have tried (I believe) most all the avenues I have found in the Netgear Community and on the Internet to update to version I have tried updating through the router and through the app (connected via Anywhere Access) and I have tried the manual update route - per instructions. Also, my router is set for Auto Update and I have tried this through 3 different browsers.  Also, I turn my router off and unplug it for 10 to 15 minutes once every three weekends.  It appears that has been 'just for grins'.


This is stupid that a company like Netgear would have this kind of lingering/reoccurring issue. From what I see this has been going on for many months for many people.

I have uploaded, via, the router admin function file R8000P-V1.4.4.94_1.3.56.chk which appeared successful, only to see no change after the router "appeared" to reboot. I keep getting the message when using the router login and new version update function, "Cannot connect to the Netgear server".


When I login to the router as admin, I get the message that there is "a router firmware update is available". Clicking on that message shows "attempting to connect with Netgear...." and then it takes me to the panel showing the version update information. It shows me this:
            Current GUI version       
            New GUI Version           
            Current Firmware Version
            New Firmware Version   


In my attempts at updates after I get the above information and I click Yes, the router runs for a few minutes and then the "Cannot Connect to Netgear Servers" message pops up. This has been happening since January. The firmware version has been mentioned in posts I have seen since at least 2021-01-23 in the Community.


I am running Windows 11 Pro on a Lenovo desktop with 32GB of ram and 500GB disk. I am connected via a new Ethernet cable directly to my Router. My other attempts have been through the Nighthawk app on my cell phone with the app version


All this leads to my questions:

  1. How do I diagnosis my failure to connect to the Netgear servers when I try to update through the router or the phone app?
  2. Will connecting to the Netgear servers solve my updating issues?
  3. What have I missed doing, other than updating to a much lower firmware version and starting over again.
  4. Will a factory reset (nuclear option) ensure my connection to the Netgear servers?

All help and advice is appreciated,



Message 1 of 2

Re: Nighthawk X6S R8000P AC4000 FIrmware will not Update, fails to connect to Netgear Servers

This is said to be the fix:


My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode  | Wifi Router RBKE963 and RBE973 | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX30/CAX80/CM1100/CM1200/CM2000, Orbi: CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MK93S, R7000, R7800, R7960P, R8000, RAXE500, RAX120v2, RAX50v2, XR450/500/700/1000,

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 0 kudos
  • 2 in conversation

Orbi WiFi 7