R6700v3 Capped at 100Mbps (yeah, me too)


R6700v3 Capped at 100Mbps (yeah, me too)

Setup a new R6700v3 on 1Gbps broadband service, and found that I couldn't achieve better than 100Mbps in any speed test.  Eliminating the router and connecting directly to the broadband modem showed the full service speed expected.


My issue ended up being two things:


1. Primarily, for whatever reason using the Netgear Ethernet cable between my broadband modem and the WAN port of the R6700v3 would only allow 100Mbps to be negotiated on the R6700v3 WAN port.  The status for this is kind of "hidden", but you can view it in "Show Statistics" of the Internet Connection from the Advanced home page, as shown in the attached screen shot.  I replaced that with my own CAT6 cable and now the WAN port negotiates 1000Mbps as expected.


2. On the latest 1.04.106 firmware shown in the screen shot, I encountered the "latest firmware cuts speed in half" issue that is reported here several times over for the R6700v3 and other models.  As recommended in one of those existing discusions, I reverted to the R6700v3 1.03.66 firmware, performed and factory reset, and then re-implemented my intended configuration.  Now I get the same speeds going through the R6700v3 as when I'm connected directly to the broadband modem.


So "R6700v3 1.04.106 firmware still causing slower speed", and "If stuck at specifically 100Mbps, include a check of the Show Statistics of the WAN port to see if it has even negotiated the gigabit connection that it should have."

Model: R6700|Nighthawk AC1750 Smart WiFi Router
Message 1 of 2

Re: R6700v3 Capped at 100Mbps (yeah, me too)

Replacing a router behind a  modem requires a network reboot.


As this is a router, there is probably a modem sitting in front of it. You need to get the devices to forget any inherited settings. Among other things, that means rebooting the network.

Be sure to restart your network in this sequence:

  • Turn off and unplug modem.
  • Turn off router and computers.
  • Plug in and turn on modem. Wait 2 minutes for it to connect.
  • Turn on the router and wait 2 minutes for it to connect.
  • Turn on computers and rest of network.

Maybe you did this. I can't tell from your message.


Perhaps you could also tell people what the modem is.




Just another user with a set of boilerplate macros.

My network DM200 -> R7800 -> GS316 -> PL1000 -> Orbi RBR40 -> Orbi RBS50Y -> RBS40V
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 0 kudos
  • 2 in conversation

Orbi WiFi 6E