In early 2019 I bought this router to replace my Airport Extreme and for the most part the Netgear has worked ok.When I installed the routr I wrote down the password and answers to the security questions I chose and went on my merry way. 

 The latest update arrived ( ) and I tried to update using my iPhone 11, but the password did not work. So I went to the Recover Password page and tried to enter the info. The serial # and 1st question were ok but the second question that poppd up (est friend's name)was not the one I had chosen (father's middle name) and the login would not accept the answer I would have put down . No matter how many times I tried to log in after disconnecting from the router, turning off my laptop and phone, and so on, the security question would not change and I see no way to select another question. I really do not want to do the hard reset due to all the connected devices and just wish I could get the correct question. Anyone have a suggestion??

Message 1 of 1
Top Contributors
Discussion stats
  • 0 replies
  • 0 kudos
  • 1 in conversation

Orbi WiFi 6E