Orbi WiFi 7 RBE973
Reply

Re: R7000 usb 3.0 doesn't work

shayaant
Aspirant

R7000 usb 3.0 doesn't work

Hello,

 

My nighthawk usb 2.0 port works fine with both my "My book external hdds", but fails for both with the usb 3.0 port.

 

I'm on firmware version, V1.0.5.48_1.1.79. 

 

Both external drives work on my pc's usb 3.0 port, not the router tho.

 

I see some solutions that indicate a beta firmware update fixed it for some people? where can I get that? Or is there some obvious solution I'm missing. (https://community.netgear.com/t5/Nighthawk-WiFi-Routers/R7000-USB-ports-not-working-properly/m-p/108...)

 

I read another article with a solution that says to basically check the compatibility guide, https://kb.netgear.com/18985/ReadySHARE-USB-Drives-Compatibility-List, which doesn't seem like a solution. I did check the guide and both my external hdd's are valid.

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 1 of 24

Accepted Solutions
SalAKhan
Aspirant

Re: R7000 usb 3.0 doesn't work

It's the latest firmware.  I just ran a factory reset and then formatted the drive in NTFS.  Seems to work now.  Thank you.

 

View solution in original post

Message 15 of 24

All Replies
Pluto8
Apprentice

Re: R7000 usb 3.0 doesn't work

Firmware 1.0.5.48_1.1.79? Isn’t that quite old? I have two R7000, both running 1.0.7.12, and I have no problem with USB 3.0 (well, except for the router’s USB LED light not being on, but that’s a different story).

 

There is also a never firmware version for R7000, see the sticky messages.

Message 2 of 24
JamesGL
Master

Re: R7000 usb 3.0 doesn't work

Hi shayaant,

 

You can download the firmware on the link below.

 

https://www.netgear.com/support/product/R7000#download

Message 3 of 24
IrvSp
Master

Re: R7000 usb 3.0 doesn't work


@JamesGL wrote:

Hi shayaant,

 

You can download the firmware on the link below.

 

https://www.netgear.com/support/product/R7000#download


Isn't it about time to change the STICKY for the old R7000 flash to this new one?

Message 4 of 24
shayaant
Aspirant

Re: R7000 usb 3.0 doesn't work

Updated router to V1.0.7.12_1.2.5, still does not work.

 

Is there a compatibility issue with https://www.amazon.com/Book-Desktop-External-Drive-WDBBGB0040HBK-NESN/dp/B01LQQHL4E this drive?

 

I think the model number is wdbbgb0040hbk

Message 5 of 24
IrvSp
Master

Re: R7000 usb 3.0 doesn't work

I've got 2 of those here, but NOT connected to the R7000. I will tell you I did have a problem with them initially. I have Dell XPS's. They 'choked' on the drives at boot up. Turned out the FORMAT of those particular drives are not NTFS. They are FORMATTED as ExFAT so Mac's can use them too. It is QUITE possible that the format is the problem.

 

My thread on this at WD if you wish to read it, https://community.wd.com/t/wd-my-book-new-4tb-dell-xps-8700-will-not-boot/184511

Message 6 of 24
JamesGL
Master

Re: R7000 usb 3.0 doesn't work

Hi shayaant,

 

What is the file format of your drive?

 

Use this firmware instead.

 

https://kb.netgear.com/000038774/R7000-Firmware-Version-1-0-8-34-North-America-Only

Message 7 of 24
shayaant
Aspirant

Re: R7000 usb 3.0 doesn't work

exFat, I tried V1.0.8.34_1.2.15, still doesn't work for either usb port.

Message 8 of 24
IrvSp
Master

Re: R7000 usb 3.0 doesn't work

ExFat could be the problem....

 

Check this http://www.partition-tool.com/resource/convert-file-system/convert-exfat-to-ntfs.html out on how to convert it. However using those options you WILL lose data.

 

You will need to BACKUP the contents of the drive first. You could lose ALL data on it doing the conversion.

 

Alternatively you could 'test' if this is the problem. Using Disk Manager SHRINK the size of the ExFat partition. Then create a new one in NTFS on the drive utilizing the space recovered shrinking the drive.  See if Windows Explorer can see that drive or not? May not be able to with the ExFat there, I don't know if this would work or not because of that. Might need to play around with the partitions and move the ExFat to the end of the drive? Even moving the partition could cause data loss, so the best option would be to just backup the partition, delete it and recreate it as NTFS. Then restore the partition.

Message 9 of 24
JamesGL
Master

Re: R7000 usb 3.0 doesn't work

Hi shayaant,

 

As what IrvSp suggested, try to use the NTFS file format.

Message 10 of 24
JamesGL
Master

Re: R7000 usb 3.0 doesn't work

Hi shayaant,

 

We’d greatly appreciate hearing your feedback letting us know if you need further assistance.

Message 11 of 24
shayaant
Aspirant

Re: R7000 usb 3.0 doesn't work

You guys have been great, all the responses were prompt and reasonable. I don't have any options to reformat/backup my current ex-fat system, but I'll get another hdd soon and try this out.

 

I do wish ex-fat was more easily supported 😕

My only problem now is I've noticed streaming/network latency issues with the latest firmware.

 

Where can i get V1.0.5.48_1.1.79 to confirm this?

Message 12 of 24
SalAKhan
Aspirant

Re: R7000 usb 3.0 doesn't work

I have a Seagate Expansion 5TB that won't recognize on the USB3 port but fine on the USB2.  When will this be fixed?

Message 13 of 24
JamesGL
Master

Re: R7000 usb 3.0 doesn't work

Hi Shayaant,

 

v1.0.5.48 is not an official firmware. Below are the firmwares you can try.

 

https://www.netgear.com/support/product/R7000#download

 

Hi SalAKhan,

 

What is the firmware version of your router? Make sure to update it. Reset and reconfigure.

Message 14 of 24
SalAKhan
Aspirant

Re: R7000 usb 3.0 doesn't work

It's the latest firmware.  I just ran a factory reset and then formatted the drive in NTFS.  Seems to work now.  Thank you.

 

Message 15 of 24
wingsandleaves
Aspirant

Re: R7000 usb 3.0 doesn't work

I have tried the same with not luck (July 2017)

 

Firmware version:  V1.0.9.6_1.2.19

 

I just installed the latest firmware and reset to factory defults and the problem persists.

 

I have a perfect connection to my MY BOOK DUO via the USB 2.0 port however when I connect to the R7000's USB 3.0 port it will not work with the HD formatted as NTFS.

 

This was the selling point for this router and I really hope that Netgear can give us a good fix.

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 16 of 24
IrvSp
Master

Re: R7000 usb 3.0 doesn't work


@wingsandleaves wrote:

I have tried the same with not luck (July 2017)

 

Firmware version:  V1.0.9.6_1.2.19

 

I just installed the latest firmware and reset to factory defults and the problem persists.

 

I have a perfect connection to my MY BOOK DUO via the USB 2.0 port however when I connect to the R7000's USB 3.0 port it will not work with the HD formatted as NTFS.

 

This was the selling point for this router and I really hope that Netgear can give us a good fix.


Question? Do you KNOW if the USB 3.0 port works at all? Have you plugged another drive or flash/thumb drive into the 3.0 port and checked?

 

What method are you using to verify 'it works in USB 2.0'?

Message 17 of 24
wingsandleaves
Aspirant

Re: R7000 usb 3.0 doesn't work

The drive connects to my network and the router can see and control it via USB 2.O but not 3.0.

Message 18 of 24
IrvSp
Master

Re: R7000 usb 3.0 doesn't work


@wingsandleaves wrote:

The drive connects to my network and the router can see and control it via USB 2.O but not 3.0.


Of course it connects to your network, otherwise you couldn't use it. But how do you use it on the network? 'What' looks at it?

 

Is the drive lighting up on USB 3.0?

 

Does the drive work on a USB 3.0 port on a PC?

 

What SIZE is the DUO? Some reports I've seen have had USB 3.0 problems with large drives?

 

My WD 4TB My Book External USB 3.0 drive works fine and has been working in the USB 3.0 port since I got it.

 

Have you VERIFIED the Router USB 3.0 port works with another device?

Message 19 of 24
wingsandleaves
Aspirant

Re: R7000 usb 3.0 doesn't work

Some additional information:

 

I just connected a second USB 3.0 Hard drive to the router via the USB 3.0 port and it works. This drive is a WD Pasport drive 1.0TB. I can see and control this drive via a browser connection to the router. If I try to use the hard drive I want to use (WD My Book Duo) it is not discovered by the router on the 3.0 port but it is discoved on the 2.0 port.

 

The main difference between the two hard drives is the My Book Duo is powered but the pasport drive gets it's power from the router's USB port. I've seen this distinction for functionality in other threads with other Netgear routers and my symptons are exactly the same. Powered drives (with power adapter) do not work wheras USB powered drives do work.

Message 20 of 24
wingsandleaves
Aspirant

Re: R7000 usb 3.0 doesn't work

The router's 3.0 port does work. I tried it with an unpowered WD passport HD.

 

The DUO is 4.0TB just like yours! I can only get it to work on the router's 2.0 port though.

 

The drive works perfectly as 3.0 on the PC.

Message 21 of 24
IrvSp
Master

Re: R7000 usb 3.0 doesn't work


wingsandleaves wrote:.

 

The main difference between the two hard drives is the My Book Duo is powered but the pasport drive gets it's power from the router's USB port. I've seen this distinction for functionality in other threads with other Netgear routers and my symptons are exactly the same. Powered drives (with power adapter) do not work wheras USB powered drives do work.


I see the USB 3.0 port does work with another drive, good.

 

Actually it is usually the other way around. Portable External drives get their power from the USB port whereas the non-Portable External drives come with a power adapter. If the Portable drives need more power than the Router's USB port can deliver, those drives do not work.

 

How are you using the drive? As a RAID drive with normal remote access to it, that is as a Network connected drive or using the WD S/W? That drive has a LOCK/UNLOCK feature it seems, so it is possible you can't move it without re-registering it to the new location? Don't know? The manual isn't that clear and I don't have a drive like that.

Message 22 of 24
wingsandleaves
Aspirant

Re: R7000 usb 3.0 doesn't work

It is a RAID drive with AC/DC power from the wall outlet. I've always guessed the RAID configuration added a layer of complexity but figured that if the router's 2.0 can see it so should the 3.0. Plugged into the 2.0 port it works like a dream...I'd just like the 3.0 speed for large files.

Message 23 of 24
IrvSp
Master

Re: R7000 usb 3.0 doesn't work


@wingsandleaves wrote:

It is a RAID drive with AC/DC power from the wall outlet. I've always guessed the RAID configuration added a layer of complexity but figured that if the router's 2.0 can see it so should the 3.0. Plugged into the 2.0 port it works like a dream...I'd just like the 3.0 speed for large files.


You'd think it would work, a normal drive does. I don't know the contents of the firmware itself, only NetGear can answer that question. It is quite possible different code is used for the different ports and the 3.0 code can't handle a RAID drive?

 

If you are still under warranty call NetGear for help, they (the developers or phone agents) are not here to help.  If you are out of warranty I'd consider a 3rd party Firmware, there are a few available. Some work better than NG's depending what you want out of the firmware. NG's code base is available as open source but usually not the latest versions.

Message 24 of 24
Top Contributors
Discussion stats
  • 23 replies
  • 13897 views
  • 0 kudos
  • 6 in conversation
Announcements

Orbi 770 Series