Orbi WiFi 7 RBE973
Reply

R7000P only routes to subnet IP after a few "warm up" tries?

HU72
Tutor

R7000P only routes to subnet IP after a few "warm up" tries?

I have an R7000P (edit: firmware V1.3.2.134_10.1.66) operating a subnet in my outbuilding, providing wireless, etc. Works great in general.

 

When I ssh or ping from my desktop to another computer on the same subnet, it doesn't work the first couple times in the morning, and then suddenly starts working.

 

My desktop and the other computer have static IPs associated with them. This worked fine for years with my old/slow D-Link router and the problem has only started with the new router.

 

The desktop is hard-wired to the router and the other computer connects wirelessly (2.4GHz). There is no indication in log files that it's a problem with the other computer or its wireless connectivity: it seems to be connected fine.

 

E.g. I will "ssh myhostname" and get "no route to host", then I wait 5 seconds, "ssh myhostname" and it connects just fine. Thereafter there are no problems. If I start with a ping instead, sometimes it takes a few tries before the link "warms up" and starts working again. It always eventually works. Sometimes it works the first time, but not usually.

 

The impression is that the router is not maintaining the routes and they are not being activated until prompted, and then the router is expiring them at some later point. This seems inappropriate for static IPs. Is there a way to make the router function properly in this case? Thanks for any ideas!

Model: R7000P|Nighthawk AC2300 Smart WiFi Dual Band Gigabit Router
Message 1 of 8
antinode
Guru

Re: R7000P only routes to subnet IP after a few "warm up" tries?

> I have an R7000P (edit: firmware V1.3.2.134_10.1.66) operating a
> subnet in my outbuilding, providing wireless, etc. Works great in
> general.

 

   Any particular reason for a different subnet with its own router
(instead of configuring the R7000P as a wireless access point)?

 

> When I ssh or ping from my desktop to another computer on the same
> subnet, it doesn't work the first couple times in the morning, and then
> suddenly starts working.

 

   These devices are all on the R7000P-LAN subnet?

 

> The desktop is hard-wired to the router and the other computer
> connects wirelessly (2.4GHz). [...]

 

   Adding another wire-connected computer might reveal if the problem is
wireless-related.

 

> [...] "no route to host"


   Someone is not responding as expected.  Not necessarily an actual
"route" problem.

 

   Besides, for "another computer on the same subnet", there is no
actual routing needed.  The only actual route(s) of interest would be on
the router connected to the WAN/Internet side of the R7000P (unless you
have yet another router whose WAN/Internet port is connected to the
R7000P LAN).

 

> The impression is that the router is not maintaining the routes [...]

 

   Which routes?  Who needs a route?

 

   An R7000P is a Netgear router, so I can imagine almost any firmware
defect, but I don't see "routes" being involved here.

 

   Some actual IP addresses might be interesting to see.

Message 2 of 8
HU72
Tutor

Re: R7000P only routes to subnet IP after a few "warm up" tries?

> Any particular reason for a different subnet with its own router
> (instead of configuring the R7000P as a wireless access point)?

 

There are, no doubt, smarter ways to organize things, but I came from an older/dumber school of networking and so our setup is that the main cable modem is attached to a parent router (R7000) which is hardwired to a router in an outbuilding (the R7000P in question here) that has it's own SSID's and subnet which forwards packets to the higher-up router. I have been told this is a dumb way to handle things in the modern era, but there are a few devices and some scripts and such that are set up for it so it was easier to swap in the new router configured like this.

 

> These devices are all on the R7000P-LAN subnet?

 

Correct, main computer is hardwired at 192.168.3.141, connecting to "other computer", which is a raspberry pi connecting wirelessly, at 192.168.3.254.

 

> Besides, for "another computer on the same subnet", there is no actual routing needed.

 

Yeah I am probably using the wrong terminology. Maybe Iptables filter rule or something? Point being that it seems like the router is going to sleep on this IP destination in some way.

 

When I check the logs on the Pi, there is no indiction that it has lost connectivity, which was my first suspicion (even though it worked fine for years on the D-Link, maybe it had some incompatability with the new router, etc.) It logs whenever anything changes for its wireless interface and there is nothing whatsoever in the logs (about anything) when this broken-to-not-broken transition happens... just a few log lines about me ssh'ing in to read the logs.

 

I also have a script that runs on the Pi that every 5 minutes curl's a remote WAN URL and pings a machine on the parent R7000 subnet. IIRC that script was written to prevent the previous D-Link router from dropping the DHCP connection (perhaps before it had a static IP) and is probably useless now. But that script generats a log, and the log indicates that it never has any trouble reaching the WAN or the machine on the other subnet, implying that (at least when it polls every five minutes) there are no connectivity issues.

 

I can imagine the Pi just ignoring ssh and ping requests every now and then, but I can't imagine why it would start doing so now where it worked fine for at least 5 years. Hence my suspicioun that there is some kind of issue on the R7000P.

 

Message 3 of 8
antinode
Guru

Re: R7000P only routes to subnet IP after a few "warm up" tries?

> [...] I have been told this is a dumb way to handle things in the
> modern era, [...]

 

   It was just as lame in the old days, too.

 

> [...] but [...]

 

   Without all the details, I can't say that configuring the R7000P as a
WAP would solve the problem, only that it would put all your client
devices on one subnet, and thus remove any worries about (actual)
routing.  How much work the new/different IP addresses would create for
you, I couldn't say.

 

> I can imagine the Pi just ignoring ssh and ping requests every now and
> then, [...]

 

   Doesn't sound likely, but who knows?  If you had other wired and
wireless devices in that neighborhood, which either failed or not, then
you might be able to find some common factor or lack thereof.


   I just poked my seldom-used R-Pi Zero W after a pretty long idle
stretch:

 

proa$ ssh -l pi rpizw
[...]
Last login: Thu Dec 10 22:59:12 2020 from 10.0.0.87
pi@rpizw:~$

 

   No trouble there. (Also no R7000P or any other secondary router
invoved.)

 

> [...] Hence my suspicioun that there is some kind of issue on the
> R7000P.

 

   "some kind", I'd believe, but I have no special wisdom.

 

> [...] static IP [...]


   Actual static, or reserved dynamic?  I always shudder when someone
mixes actual static addresses with DHCP.  I do it (too much old junk
which can't do DHCP), but it does open whole new vistas of error
possibilities.

 

> [...] firmware V1.3.2.134_10.1.66 [...]

 

   Looks current, but "latest" and "best" are spelled differently for a
reason.  Plenty of older versions exist; trying one might be
interesting.  Your environment is atypical around here, but a little Web
or forum searching for "R7000P" might turn up other complaints of flaky
behavior.

 

   Unless you have more time than cash, I'd be tempted to get a similar
router made by someone else, or something like a cheap/used R7000
(Ebay?) and see if a different set of hardware+firmware changes things.

Message 4 of 8
HU72
Tutor

Re: R7000P only routes to subnet IP after a few "warm up" tries?

> Actual static, or reserved dynamic? I always shudder when someone
> mixes actual static addresses with DHCP. I do it (too much old junk
> which can't do DHCP), but it does open whole new vistas of error
> possibilities.

 

Not sure about the distinction -- the latter, maybe? I have "static ip_address=192.168.3.254/24" in /etc/dhcpcd.conf (among other things.)

 

Appreciate the brainstorms. I'll keep poking at it. Maybe I'll have the pi ping my desktop as part of it's every-5-minutes script and see if that makes any difference.

 

Message 5 of 8
antinode
Guru

Re: R7000P only routes to subnet IP after a few "warm up" tries?

> Not sure about the distinction [...]

 

   Terminology: A "static" address is configured on the device itself.
What you configure on a (DHCP server on a) router is a reserved dynamic
address, not a static address.  Either one should fix the address of a
device, but some implications are different.

 

> I have "static ip_address=192.168.3.254/24" in /etc/dhcpcd.conf (among
> other things.)

 

   I believe that that's a true static address.  (You have to admire an
OS design where you configure a static address in a file named
"dhcp<anything>".)

 

   Static addresses are harmless, so long as they're not in the DHCP
address pool.  What you don't want is for the DHCP server in the router
to think that, say, ".254" in not in use (because the DHCP server hasn't
granted it to anyone) when it really is (because you've manually
assigned it to something as a static address, without notifying the DHCP
server).


   By default, Netgear router DHCP servers typically put every available
address into the DHCP pool: ".2" - ".254".  If you want to use static
addresses, then you could shrink the pool to, say, ".2" - ".199", and
use the ".200" - ".254" range for your static addresses.
ADVANCED > Setup > LAN Setup : Use Router as DHCP Server ...

 

   Knowing nothing, I'd expect the Netgear router DHCP server to start
granting addresses from the low end of the pool (".2", ".3", ...), so a
collision with ".25x" might be unlikely, but "certainly not" beats
"unlikely" in my book.

 

> Appreciate the brainstorms. [...]

 

   I wish I had something more solid to offer.  But I offer a "double
your nonsense back" guarantee if the original nonsense fails to satisfy.

Message 6 of 8
HU72
Tutor

Re: R7000P only routes to subnet IP after a few "warm up" tries?

After setting up the script on the remote computer to ping the desktop every 5 minutes (whether it's on or not), things seem to be working as expected now. Maybe it just needed some activity to keep the link warm. Kind of annoying, but at least there's a workaround. I'll report back if this turns out to be wrong.

 

 

Message 7 of 8
HU72
Tutor

Re: R7000P only routes to subnet IP after a few "warm up" tries?

Unfortunately things still aren't working. They're better than before, but still intermittent. ssh for example suffers a similar issue. Here for example is a series of ssh attempts in rapid succession, demonstrating the behavior when I try to ssh from my desktop (wired to the router) to the raspberry pi zero (wirelessly connected to the router):

 

$ ssh myhost
ssh: connect to host 192.168.3.254 port 22: No route to host
$ ssh myhost
ssh: connect to host 192.168.3.254 port 22: No route to host
$ ssh myhost

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Mon May 31 16:29:14 2021 from 192.168.3.141
pi@myhost:~ $ exit
logout
Connection to 192.168.3.254 closed.
$

It's really seeming like the R7000P can't be bothered to route things until you bang on it a couple times... ? Again, this was never an issue in the past, just this new router. If I have misconfigured something or there is some kind of tweaking I can try, I'd love any suggestions. Thanks!

 

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 746 views
  • 4 kudos
  • 2 in conversation
Announcements

Orbi WiFi 7